summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-07-17 16:50:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-07-17 17:46:31 +0200
commita1053b22affd8dcb41a7e59ef6147c4ab6a28e6d (patch)
tree22d64761a893424eedca9eca43dcc4a8134a3f64
parentsci-mathematics/alt-ergo: remove broken live 9999 (diff)
downloadgentoo-a1053b22affd8dcb41a7e59ef6147c4ab6a28e6d.tar.gz
gentoo-a1053b22affd8dcb41a7e59ef6147c4ab6a28e6d.tar.bz2
gentoo-a1053b22affd8dcb41a7e59ef6147c4ab6a28e6d.zip
dev-util/0xtools: bump to 2.0.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-util/0xtools/0xtools-2.0.2.ebuild70
-rw-r--r--dev-util/0xtools/Manifest1
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/0xtools/0xtools-2.0.2.ebuild b/dev-util/0xtools/0xtools-2.0.2.ebuild
new file mode 100644
index 000000000000..d73227e1d32b
--- /dev/null
+++ b/dev-util/0xtools/0xtools-2.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit python-single-r1 systemd toolchain-funcs
+
+DESCRIPTION="Always-on profiling for production systems"
+HOMEPAGE="https://0x.tools/
+ https://github.com/tanelpoder/0xtools/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/tanelpoder/${PN}.git"
+else
+ SRC_URI="https://github.com/tanelpoder/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+
+ sed -e "/^sys.path.append/s|(.*)|('$(python_get_sitedir)/${PN}')|" \
+ -i bin/psn -i bin/schedlat || die
+}
+
+src_install() {
+ # C executables and scripts
+ exeinto /usr/bin
+ doexe bin/{cpumhz,cpumhzturbo,vmtop,xcapture,xtop}
+ doexe bin/{run_xcapture.sh,run_xcpu.sh}
+
+ # Python executables
+ python_domodule "lib/${PN}"
+ python_doscript bin/psn
+ python_doscript bin/schedlat
+ python_doscript bin/syscallargs
+
+ # Service
+ systemd_dounit xcapture.service
+ systemd_dounit xcapture-restart.service
+ systemd_dounit xcapture-restart.timer
+
+ # Service config
+ insinto /etc/default
+ newins xcapture.default xcapture
+
+ # Service logs
+ keepdir /var/log/xcapture
+
+ einstalldocs
+}
diff --git a/dev-util/0xtools/Manifest b/dev-util/0xtools/Manifest
index 190a0c5615ce..8205eb80d533 100644
--- a/dev-util/0xtools/Manifest
+++ b/dev-util/0xtools/Manifest
@@ -1 +1,2 @@
DIST 0xtools-1.2.4.tar.gz 61830 BLAKE2B 6221ded289bc4cf4c39527f35d1ad3ee43f41a60a4a9877056a5ff74fcdd203575d96edbf13af1d32bcc49465d87a2133a8dbec813ae9a5bb233b5fe2e4a36b3 SHA512 f835de65e783d9eb4b26f38be155961a2f4da91639c7e1e39df71cf8be17d27987c8749e44b7b6affe6cdc45c5f65c90be5b2cf22b2f37dcc2eb45452a384ff3
+DIST 0xtools-2.0.2.tar.gz 5989710 BLAKE2B 5e4efd4d21e3ed1fc8b1eed5378d25af3170f2386c738a68d28df5bad44ebdb88fd20a0b554d101b678c15131adb83ae786df1267c8333075c58ea58b8c2ce88 SHA512 5cb627e9b990063867869cdbbdefd7e2b6151410ac19950f683086c9200a8ba1f92192378779dbabc4efd91283cd23243a4b46259d97426331f823941b85883b