summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-08-09 10:23:29 -0400
committerSam James <sam@gentoo.org>2024-08-09 15:28:52 +0100
commit9f442ca90187f99c4812018de6d878b16947f5a2 (patch)
tree3da0c720774dd83c51c24a42b73b39a44d8aff6a
parentprofiles: update glib-2.80 mask (diff)
downloadgentoo-9f442ca90187f99c4812018de6d878b16947f5a2.tar.gz
gentoo-9f442ca90187f99c4812018de6d878b16947f5a2.tar.bz2
gentoo-9f442ca90187f99c4812018de6d878b16947f5a2.zip
media-libs/lib3mf: Fix compilation on GCC 15
- Tests pass - Patched file is not an installed header Note: Upstream PR fixes an additional file that does not error on 2.2.0 Upstream: https://github.com/3MFConsortium/lib3mf/pull/387 Closes: https://bugs.gentoo.org/937423 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/38030 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/lib3mf/files/lib3mf-2.2.0-include-cstdint.patch13
-rw-r--r--media-libs/lib3mf/lib3mf-2.2.0.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/media-libs/lib3mf/files/lib3mf-2.2.0-include-cstdint.patch b/media-libs/lib3mf/files/lib3mf-2.2.0-include-cstdint.patch
new file mode 100644
index 000000000000..36776fd02751
--- /dev/null
+++ b/media-libs/lib3mf/files/lib3mf-2.2.0-include-cstdint.patch
@@ -0,0 +1,13 @@
+diff --git a/Source/Common/Platform/NMR_ImportStream_Unique_Memory.cpp b/Source/Common/Platform/NMR_ImportStream_Unique_Memory.cpp
+index 43fd428..e966aa0 100644
+--- a/Source/Common/Platform/NMR_ImportStream_Unique_Memory.cpp
++++ b/Source/Common/Platform/NMR_ImportStream_Unique_Memory.cpp
+@@ -35,6 +35,8 @@ This is a platform independent class for keeping data in a memory stream that ow
+ #include "Common/NMR_Exception.h"
+ #include "Common/NMR_Exception_Windows.h"
+
++#include <cstdint>
++
+ namespace NMR {
+
+ CImportStream_Unique_Memory::CImportStream_Unique_Memory()
diff --git a/media-libs/lib3mf/lib3mf-2.2.0.ebuild b/media-libs/lib3mf/lib3mf-2.2.0.ebuild
index 97ec4b4b7146..d5d470010791 100644
--- a/media-libs/lib3mf/lib3mf-2.2.0.ebuild
+++ b/media-libs/lib3mf/lib3mf-2.2.0.ebuild
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${P}-0001-use-system-provided-act-binary.patch
"${FILESDIR}"/${P}-0002-Gentoo-specific-remove-add_dependencies.patch
"${FILESDIR}"/${P}-0001-remove-std-and-opt-flags.patch
+ "${FILESDIR}"/${P}-include-cstdint.patch
)
src_configure() {