summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-07 09:51:25 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-07 10:08:01 +0100
commit96a3e1d6f578b6e505ae664d28499caecf1cc6fc (patch)
tree4eefcb2ea30af2b0a1cc0abc4152349233fe4f04
parentsys-apps/fwupd: drop 1.7.7-r2 (diff)
downloadgentoo-96a3e1d6f578b6e505ae664d28499caecf1cc6fc.tar.gz
gentoo-96a3e1d6f578b6e505ae664d28499caecf1cc6fc.tar.bz2
gentoo-96a3e1d6f578b6e505ae664d28499caecf1cc6fc.zip
sys-apps/fwupd: explicitly call xdg_pkg_post{inst,rm}
fwupd installs icons so we need to update the icon cache. This used to be done implicitly via inherit xdg, however when floppym added custom implementations of pkg_post{inst,rm} in commit c36a53996de7797e831150967c66536fdbea67d1 to handle udev rules xdg.eclass defaults stopped being called. Closes: https://bugs.gentoo.org/869032 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-apps/fwupd/fwupd-1.8.3.ebuild2
-rw-r--r--sys-apps/fwupd/fwupd-1.8.4.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-apps/fwupd/fwupd-1.8.3.ebuild b/sys-apps/fwupd/fwupd-1.8.3.ebuild
index 6dd2394f80cf..27984e59c834 100644
--- a/sys-apps/fwupd/fwupd-1.8.3.ebuild
+++ b/sys-apps/fwupd/fwupd-1.8.3.ebuild
@@ -198,9 +198,11 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
use minimal || udev_reload
}
pkg_postrm() {
+ xdg_pkg_postrm
use minimal || udev_reload
}
diff --git a/sys-apps/fwupd/fwupd-1.8.4.ebuild b/sys-apps/fwupd/fwupd-1.8.4.ebuild
index 4d97b8c02eb5..df9202e9d65c 100644
--- a/sys-apps/fwupd/fwupd-1.8.4.ebuild
+++ b/sys-apps/fwupd/fwupd-1.8.4.ebuild
@@ -195,9 +195,11 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
use minimal || udev_reload
}
pkg_postrm() {
+ xdg_pkg_postrm
use minimal || udev_reload
}