summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-01-20 20:18:22 +0800
committerYixun Lan <dlan@gentoo.org>2023-01-20 20:21:08 +0800
commit860e59cdf84bf887090b361a3f0ac505ba9d6356 (patch)
tree19730f6bf6fd9291f8cdc32c1b92071bbf5c5161
parentx11-misc/autorandr: sync live ebuild (diff)
downloadgentoo-860e59cdf84bf887090b361a3f0ac505ba9d6356.tar.gz
gentoo-860e59cdf84bf887090b361a3f0ac505ba9d6356.tar.bz2
gentoo-860e59cdf84bf887090b361a3f0ac505ba9d6356.zip
net-misc/ofono: add 2.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-2.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index e8662a38301e..d384595b12a8 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1,2 +1,3 @@
DIST ofono-1.33.tar.xz 1060408 BLAKE2B 646a96c0926ea032fef0357aabe6a4be6da88f4ccbdff59bb86b5de73a9b469362151b212a05234619f5d616b534343137c66e923782c7d50dfe13d2bf66558c SHA512 8d88226aa2b43eca840c6330045ee7a96c91f6003b06fca5ea55b74fc229f0e0ba0c8d98f7945f8c23ec5a8e7057bffef6335c61842e245686e0ed7c5feda589
DIST ofono-1.34.tar.xz 1060828 BLAKE2B be0d3787ca9226763fb2bff46f1c3cec813d702730d6231986ec5aa43e2d96e08385fa3f64ccff97cf15844e41a33d6c37d1d35c8b0c5fcf3765848e258e3372 SHA512 79ebf0bc795288f07b58eeaa1a0aa3309b4afecae3abdd26c0749e22a4c2e74b65e93cbcfdfd1738dbcb2d0cfb8c687d182d706696a7c1cd5b4ed3bcec059489
+DIST ofono-2.0.tar.xz 1096856 BLAKE2B 28b29577cdd70129fd8f7346bd82e03078452b03bb4baf152c4e406cfc17a5eeac11312999592acad85d7c61c4595403d266482068576573fd1d75a15e610d80 SHA512 3b29845d06784bfec8e60f6590237b77baa0826b1366f7ed8491d41622da19c72290ff8508a4625e5d7d5f68a03237524aa2ef1936b26dbc035fb3e7fa747f23
diff --git a/net-misc/ofono/ofono-2.0.ebuild b/net-misc/ofono/ofono-2.0.ebuild
new file mode 100644
index 000000000000..9da45c1586a8
--- /dev/null
+++ b/net-misc/ofono/ofono-2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/ofono/ofono"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable cdmamodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable provision) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-provider-name \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}