summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-08-15 12:11:01 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-08-15 12:11:01 +0000
commit6c073dfb92c169df76d5588bea0d711e9cf920d9 (patch)
tree5569afd3cb156bf4d2f28e372cc71a905231e796
parent2018-08-15 11:44:24 UTC (diff)
parentsys-fs/treesize: Fix LICENSE (diff)
downloadgentoo-6c073dfb92c169df76d5588bea0d711e9cf920d9.tar.gz
gentoo-6c073dfb92c169df76d5588bea0d711e9cf920d9.tar.bz2
gentoo-6c073dfb92c169df76d5588bea0d711e9cf920d9.zip
Merge updates from master
-rw-r--r--eclass/cmake-utils.eclass39
-rw-r--r--eclass/kde5-functions.eclass17
-rw-r--r--eclass/kde5.eclass68
-rw-r--r--sys-fs/treesize/files/0.54.1-amd64.patch4
-rw-r--r--sys-fs/treesize/treesize-0.54.1-r1.ebuild24
5 files changed, 74 insertions, 78 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index e64502b3b9b0..d69c79f83b41 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -112,8 +112,7 @@ esac
inherit toolchain-funcs ninja-utils flag-o-matic multiprocessing xdg-utils
case ${EAPI} in
- 7) ;;
- *) inherit eapi7-ver eutils multilib ;;
+ 5|6) inherit eutils multilib ;;
esac
EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
@@ -226,9 +225,18 @@ _cmake_generator_to_use() {
ninja)
# if ninja is enabled but not installed, the build could fail
# this could happen if ninja is manually enabled (eg. make.conf) but not installed
- if ! ROOT=/ has_version dev-util/ninja; then
- die "CMAKE_MAKEFILE_GENERATOR is set to ninja, but ninja is not installed. Please install dev-util/ninja or unset CMAKE_MAKEFILE_GENERATOR."
- fi
+ case ${EAPI} in
+ 5|6)
+ if ! ROOT=/ has_version dev-util/ninja; then
+ die "CMAKE_MAKEFILE_GENERATOR is set to ninja, but ninja is not installed. Please install dev-util/ninja or unset CMAKE_MAKEFILE_GENERATOR."
+ fi
+ ;;
+ *)
+ if ! has_version -b dev-util/ninja; then
+ die "CMAKE_MAKEFILE_GENERATOR is set to ninja, but ninja is not installed. Please install dev-util/ninja or unset CMAKE_MAKEFILE_GENERATOR."
+ fi
+ ;;
+ esac
generator_name="Ninja"
;;
emake)
@@ -508,23 +516,14 @@ cmake-utils_src_configure() {
# Prepare Gentoo override rules (set valid compiler, append CPPFLAGS etc.)
local build_rules=${BUILD_DIR}/gentoo_rules.cmake
- # Since cmake-3.4.0_rc1 "<FLAGS>" no longer contains includes and thus
- # we need to add "<INCLUDES>"
- local includes=
- if [[ ${PN} == cmake ]] ; then
- if $(ver_test $(ver_cut 1-3 ${PV}) -ge 3.4.0) ; then
- includes="<INCLUDES>"
- fi
- elif ROOT=/ has_version \>=dev-util/cmake-3.4.0_rc1 ; then
- includes="<INCLUDES>"
- fi
+
cat > "${build_rules}" <<- _EOF_ || die
- SET (CMAKE_ASM_COMPILE_OBJECT "<CMAKE_ASM_COMPILER> <DEFINES> ${includes} ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "ASM compile command" FORCE)
- SET (CMAKE_ASM-ATT_COMPILE_OBJECT "<CMAKE_ASM-ATT_COMPILER> <DEFINES> ${includes} ${CPPFLAGS} <FLAGS> -o <OBJECT> -c -x assembler <SOURCE>" CACHE STRING "ASM-ATT compile command" FORCE)
+ SET (CMAKE_ASM_COMPILE_OBJECT "<CMAKE_ASM_COMPILER> <DEFINES> <INCLUDES> ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "ASM compile command" FORCE)
+ SET (CMAKE_ASM-ATT_COMPILE_OBJECT "<CMAKE_ASM-ATT_COMPILER> <DEFINES> <INCLUDES> ${CPPFLAGS} <FLAGS> -o <OBJECT> -c -x assembler <SOURCE>" CACHE STRING "ASM-ATT compile command" FORCE)
SET (CMAKE_ASM-ATT_LINK_FLAGS "-nostdlib" CACHE STRING "ASM-ATT link flags" FORCE)
- SET (CMAKE_C_COMPILE_OBJECT "<CMAKE_C_COMPILER> <DEFINES> ${includes} ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "C compile command" FORCE)
- SET (CMAKE_CXX_COMPILE_OBJECT "<CMAKE_CXX_COMPILER> <DEFINES> ${includes} ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "C++ compile command" FORCE)
- SET (CMAKE_Fortran_COMPILE_OBJECT "<CMAKE_Fortran_COMPILER> <DEFINES> ${includes} ${FCFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "Fortran compile command" FORCE)
+ SET (CMAKE_C_COMPILE_OBJECT "<CMAKE_C_COMPILER> <DEFINES> <INCLUDES> ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "C compile command" FORCE)
+ SET (CMAKE_CXX_COMPILE_OBJECT "<CMAKE_CXX_COMPILER> <DEFINES> <INCLUDES> ${CPPFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "C++ compile command" FORCE)
+ SET (CMAKE_Fortran_COMPILE_OBJECT "<CMAKE_Fortran_COMPILER> <DEFINES> <INCLUDES> ${FCFLAGS} <FLAGS> -o <OBJECT> -c <SOURCE>" CACHE STRING "Fortran compile command" FORCE)
_EOF_
local myCC=$(tc-getCC) myCXX=$(tc-getCXX) myFC=$(tc-getFC)
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index bd3fa08b2576..7631be4de391 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -47,12 +47,6 @@ case ${CATEGORY} in
: ${QT_MINIMAL:=5.11.1}
fi
;;
- kde-apps)
- if [[ ${PV} = 17.12.3* ]]; then
- : ${FRAMEWORKS_MINIMAL:=5.43.0}
- : ${QT_MINIMAL:=5.9.1}
- fi
- ;;
esac
# @ECLASS-VARIABLE: QT_MINIMAL
@@ -92,17 +86,6 @@ fi
debug-print "${ECLASS}: ${KDEBASE} ebuild recognized"
-# @ECLASS-VARIABLE: KDE_SCM
-# @DESCRIPTION:
-# SCM to use if KDE_BUILD_TYPE is determined to be "live".
-# Currently, only git is supported.
-: ${KDE_SCM:=git}
-
-case ${KDE_SCM} in
- git) ;;
- *) die "KDE_SCM: ${KDE_SCM} is not supported" ;;
-esac
-
# @FUNCTION: _check_gcc_version
# @INTERNAL
# @DESCRIPTION:
diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 07d6c26a264c..03be801c0605 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -38,9 +38,7 @@ case ${EAPI} in
esac
if [[ ${KDE_BUILD_TYPE} = live ]]; then
- case ${KDE_SCM} in
- git) inherit git-r3 ;;
- esac
+ inherit git-r3
fi
if [[ -v KDE_GCC_MINIMAL ]]; then
@@ -394,40 +392,36 @@ _calculate_live_repo() {
SRC_URI=""
- case ${KDE_SCM} in
- git)
- # @ECLASS-VARIABLE: EGIT_MIRROR
- # @DESCRIPTION:
- # This variable allows easy overriding of default kde mirror service
- # (anongit) with anything else you might want to use.
- EGIT_MIRROR=${EGIT_MIRROR:=https://anongit.kde.org}
-
- local _kmname
-
- # @ECLASS-VARIABLE: EGIT_REPONAME
- # @DESCRIPTION:
- # This variable allows overriding of default repository
- # name. Specify only if this differ from PN and KMNAME.
- if [[ -n ${EGIT_REPONAME} ]]; then
- # the repository and kmname different
- _kmname=${EGIT_REPONAME}
- elif [[ -n ${KMNAME} ]]; then
- _kmname=${KMNAME}
- else
- _kmname=${PN}
- fi
+ # @ECLASS-VARIABLE: EGIT_MIRROR
+ # @DESCRIPTION:
+ # This variable allows easy overriding of default kde mirror service
+ # (anongit) with anything else you might want to use.
+ EGIT_MIRROR=${EGIT_MIRROR:=https://anongit.kde.org}
- if [[ ${PV} == ??.??.49.9999 && ${CATEGORY} = kde-apps ]]; then
- EGIT_BRANCH="Applications/$(ver_cut 1-2)"
- fi
+ local _kmname
- if [[ ${PV} != 9999 && ${CATEGORY} = kde-plasma ]]; then
- EGIT_BRANCH="Plasma/$(ver_cut 1-2)"
- fi
+ # @ECLASS-VARIABLE: EGIT_REPONAME
+ # @DESCRIPTION:
+ # This variable allows overriding of default repository
+ # name. Specify only if this differ from PN and KMNAME.
+ if [[ -n ${EGIT_REPONAME} ]]; then
+ # the repository and kmname different
+ _kmname=${EGIT_REPONAME}
+ elif [[ -n ${KMNAME} ]]; then
+ _kmname=${KMNAME}
+ else
+ _kmname=${PN}
+ fi
- EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
- ;;
- esac
+ if [[ ${PV} == ??.??.49.9999 && ${CATEGORY} = kde-apps ]]; then
+ EGIT_BRANCH="Applications/$(ver_cut 1-2)"
+ fi
+
+ if [[ ${PV} != 9999 && ${CATEGORY} = kde-plasma ]]; then
+ EGIT_BRANCH="Plasma/$(ver_cut 1-2)"
+ fi
+
+ EGIT_REPO_URI="${EGIT_MIRROR}/${_kmname}"
}
case ${KDE_BUILD_TYPE} in
@@ -493,11 +487,7 @@ kde5_src_unpack() {
debug-print-function ${FUNCNAME} "$@"
if [[ ${KDE_BUILD_TYPE} = live ]]; then
- case ${KDE_SCM} in
- git)
- git-r3_src_unpack
- ;;
- esac
+ git-r3_src_unpack
else
default
fi
diff --git a/sys-fs/treesize/files/0.54.1-amd64.patch b/sys-fs/treesize/files/0.54.1-amd64.patch
index d7d9d787ad39..c03df8a258e7 100644
--- a/sys-fs/treesize/files/0.54.1-amd64.patch
+++ b/sys-fs/treesize/files/0.54.1-amd64.patch
@@ -1,5 +1,5 @@
---- src/ui-util.c 2007-11-16 22:08:01.000000000 +0100
-+++ src/ui-util.c.new 2009-05-09 11:34:59.000000000 +0200
+--- a/src/ui-util.c 2007-11-16 22:08:01.000000000 +0100
++++ b/src/ui-util.c 2009-05-09 11:34:59.000000000 +0200
@@ -18,6 +18,7 @@
#include "ui-util.h"
diff --git a/sys-fs/treesize/treesize-0.54.1-r1.ebuild b/sys-fs/treesize/treesize-0.54.1-r1.ebuild
new file mode 100644
index 000000000000..ab8727ebfd4f
--- /dev/null
+++ b/sys-fs/treesize/treesize-0.54.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A disk consumption analyzing tool"
+HOMEPAGE="http://treesize.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tbz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-amd64.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}