summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-11-24 17:31:55 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-11-24 17:31:55 +0000
commit6036566f4cabfc1d80a173f7143b8a8830a4308a (patch)
treec8e28254f73a03e53aa333d44333c7e76481f840
parent2023-11-24 17:17:02 UTC (diff)
parentdev-python/cython: Stabilize 3.0.5 arm, #917706 (diff)
downloadgentoo-6036566f4cabfc1d80a173f7143b8a8830a4308a.tar.gz
gentoo-6036566f4cabfc1d80a173f7143b8a8830a4308a.tar.bz2
gentoo-6036566f4cabfc1d80a173f7143b8a8830a4308a.zip
Merge updates from master
-rw-r--r--dev-python/cython/cython-3.0.5.ebuild2
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.19.ebuild2
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild2
-rw-r--r--eclass/go-env.eclass21
4 files changed, 3 insertions, 24 deletions
diff --git a/dev-python/cython/cython-3.0.5.ebuild b/dev-python/cython/cython-3.0.5.ebuild
index 1d5c8c437e24..7ea37ef29dde 100644
--- a/dev-python/cython/cython-3.0.5.ebuild
+++ b/dev-python/cython/cython-3.0.5.ebuild
@@ -26,7 +26,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/python-stdnum/python-stdnum-1.19.ebuild b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
index e9309781b27c..848cbf574444 100644
--- a/dev-python/python-stdnum/python-stdnum-1.19.ebuild
+++ b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
+KEYWORDS="amd64 arm64 x86"
IUSE="vies"
RDEPEND="
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild
index 6b158c7b0aec..30760ca95b0e 100644
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.14.0.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
diff --git a/eclass/go-env.eclass b/eclass/go-env.eclass
index 4bc8c4b15c65..08e3cf498a70 100644
--- a/eclass/go-env.eclass
+++ b/eclass/go-env.eclass
@@ -19,8 +19,6 @@ inherit toolchain-funcs
# @FUNCTION: go-env_set_compile_environment
# @DESCRIPTION:
# Set up basic compile environment: CC, CXX, and GOARCH.
-# Necessary platform-specific settings such as GOARM or GO386 are also set
-# according to the Portage configuration when building for those architectures.
# Also carry over CFLAGS, LDFLAGS and friends.
# Required for cross-compiling with crossdev.
# If not set, host defaults will be used and the resulting binaries are host arch.
@@ -30,9 +28,6 @@ go-env_set_compile_environment() {
tc-export CC CXX
export GOARCH="$(go-env_goarch)"
- use arm && export GOARM=$(go-env_goarm)
- use x86 && export GO386=$(usex cpu_flags_x86_sse2 '' 'softfloat')
-
export CGO_CFLAGS="${CGO_CFLAGS:-$CFLAGS}"
export CGO_CPPFLAGS="${CGO_CPPFLAGS:-$CPPFLAGS}"
export CGO_CXXFLAGS="${CGO_CXXFLAGS:-$CXXFLAGS}"
@@ -62,20 +57,4 @@ go-env_goarch() {
esac
}
-# @FUNCTION: go-env_goarm
-# @USAGE: [CHOST-value]
-# @DESCRIPTION:
-# Returns the appropriate GOARM setting for the CHOST given, or the default
-# CHOST.
-go-env_goarm() {
- case "${1:-${CHOST}}" in
- armv5*) echo 5;;
- armv6*) echo 6;;
- armv7*) echo 7;;
- *)
- die "unknown GOARM for ${1:-${CHOST}}"
- ;;
- esac
-}
-
fi