summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-09-21 14:26:02 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-09-21 15:00:39 -0400
commit591de6c3bd0d7a69586256114fb276f080130b6e (patch)
tree3851796a7a32352b159036cd8ae56bba66e3a2f7
parentsci-biology/foldingathome: minor ebuild improvements (diff)
downloadgentoo-591de6c3bd0d7a69586256114fb276f080130b6e.tar.gz
gentoo-591de6c3bd0d7a69586256114fb276f080130b6e.tar.bz2
gentoo-591de6c3bd0d7a69586256114fb276f080130b6e.zip
sci-biology/foldingathome: drop old 7.4.4-r1 ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--sci-biology/foldingathome/files/7.3/fah-init30
-rw-r--r--sci-biology/foldingathome/files/7.3/initfolding5
-rw-r--r--sci-biology/foldingathome/foldingathome-7.4.4-r1.ebuild87
3 files changed, 0 insertions, 122 deletions
diff --git a/sci-biology/foldingathome/files/7.3/fah-init b/sci-biology/foldingathome/files/7.3/fah-init
deleted file mode 100644
index c5bb460d482a..000000000000
--- a/sci-biology/foldingathome/files/7.3/fah-init
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $
-
-extra_commands="unitinfo"
-
-unitinfo() {
- einfo "$(head -n1 /opt/foldingathome/unitinfo.txt):"
- sed -e '1,2d' /opt/foldingathome/unitinfo.txt
-}
-
-start() {
- ebegin "Starting Folding@Home"
- cd /opt/foldingathome
- start-stop-daemon --chdir ${PWD} --user foldingathome --nicelevel 19 \
- --make-pidfile --pidfile "${PIDFILE}" \
- --start --background --exec ./FAHClient -- ${FOLD_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping Folding@Home"
- start-stop-daemon --stop --user foldingathome --pidfile "${PIDFILE}"
- if [ $? -ne 0 ]; then
- killall --user foldingathome --signal SIGKILL
- ewarn "killing all processes running as user 'foldingathome' ..."
- fi
- eend $?
-}
diff --git a/sci-biology/foldingathome/files/7.3/initfolding b/sci-biology/foldingathome/files/7.3/initfolding
deleted file mode 100644
index 240b7fa2f17b..000000000000
--- a/sci-biology/foldingathome/files/7.3/initfolding
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-cd /opt/foldingathome
-/opt/foldingathome/FAHClient --configure
-/bin/chown -R foldingathome:nogroup /opt/foldingathome
diff --git a/sci-biology/foldingathome/foldingathome-7.4.4-r1.ebuild b/sci-biology/foldingathome/foldingathome-7.4.4-r1.ebuild
deleted file mode 100644
index bed9135f0d25..000000000000
--- a/sci-biology/foldingathome/foldingathome-7.4.4-r1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit versionator user
-
-MY_BASEURI="https://fah.stanford.edu/file-releases/public/release/fahclient"
-MY_64B_URI="${MY_BASEURI}/centos-5.3-64bit/v$(get_version_component_range 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
-MY_32B_URI="${MY_BASEURI}/centos-5.5-32bit/v$(get_version_component_range 1-2)/fahclient_${PV}-32bit-release.tar.bz2"
-
-DESCRIPTION="Folding@Home is a distributed computing project for protein folding"
-HOMEPAGE="http://folding.stanford.edu/FAQ-SMP.html"
-SRC_URI="x86? ( ${MY_32B_URI} )
- amd64? ( ${MY_64B_URI} )"
-
-RESTRICT="mirror bindist strip"
-
-LICENSE="FAH-EULA-2014 FAH-special-permission"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-# Expressly listing all deps, as this is a binpkg and it is doubtful whether
-# i.e. uclibc or clang can provide what is necessary at runtime
-RDEPEND="app-arch/bzip2
- sys-devel/gcc
- sys-libs/glibc
- sys-libs/zlib"
-
-S="${WORKDIR}"
-
-I="opt/foldingathome"
-
-QA_PREBUILT="${I}/*"
-
-pkg_setup() {
- elog ""
- elog "Special permission is hereby granted to the Gentoo project to provide an"
- elog "automated installer package which downloads and installs the Folding@home client"
- elog "software. Permission is also granted for future Gentoo installer packages on the"
- elog "condition that they continue to adhere to all of the terms of the accompanying"
- elog "Folding@home license agreements and display this notice."
- elog "-- Vijay S. Pande, Stanford University, 07 May 2013"
- elog ""
- elog "(ref: http://foldingforum.org/viewtopic.php?f=16&t=22524&p=241992#p241992 )"
- elog ""
-}
-
-src_install() {
- local myS="fahclient_${PV}-64bit-release"
- use x86 && myS="${myS//64bit/32bit}"
- exeinto ${I}
- doexe "${FILESDIR}"/7.3/initfolding
- doexe "${myS}"/{FAHClient,FAHCoreWrapper}
- newconfd "${FILESDIR}"/7.3/folding-conf.d foldingathome
- newinitd "${FILESDIR}"/7.3/fah-init foldingathome
-}
-
-pkg_preinst() {
- # the bash shell is important for "su -c" in init script
- enewuser foldingathome -1 /bin/bash "${EPREFIX}"/opt/foldingathome
-}
-
-pkg_postinst() {
- chown -R foldingathome:nogroup "${EROOT}"${I}
- einfo "To run Folding@home in the background at boot (with openrc):"
- einfo "\trc-update add foldingathome default"
- einfo ""
- if [ ! -e "${EROOT}"${I}/config.xml ]; then
- elog "No configuration found -- please run ${I}/initfolding or"
- elog "emerge --config ${P} to configure your client and edit"
- elog "${EPREFIX}/etc/conf.d/foldingathome for options"
- fi
- einfo ""
- einfo "The original author encourages you to acquire a username and join team 36480."
- einfo "http://folding.stanford.edu/English/Download#ntoc2"
- einfo ""
-}
-
-pkg_postrm() {
- elog "Folding@home data files were not removed."
- elog "Remove them manually from ${I}"
-}
-
-pkg_config() {
- "${EROOT}"${I}/initfolding
-}