summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-11-21 09:03:35 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-11-21 09:03:35 +0000
commit5143b581c1c0908c05133d419cdb445f4d7e7c92 (patch)
treee7935ce696ee1296f48506dcaf32982bba9bdc21
parent2024-11-21 08:33:41 UTC (diff)
parentmedia-gfx/prusaslicer: fixes and improvements (diff)
downloadgentoo-5143b581c1c0908c05133d419cdb445f4d7e7c92.tar.gz
gentoo-5143b581c1c0908c05133d419cdb445f4d7e7c92.tar.bz2
gentoo-5143b581c1c0908c05133d419cdb445f4d7e7c92.zip
Merge updates from master
-rw-r--r--media-gfx/prusaslicer/Manifest1
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.7.2-opencascade-7.8.0.patch16
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.8.0-cgal-6.0.patch189
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.8.0-fixed-linking.patch19
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.8.1-fix-libsoup-double-linking.patch11
-rw-r--r--media-gfx/prusaslicer/files/prusaslicer-2.8.1-fixed-linking.patch25
-rw-r--r--media-gfx/prusaslicer/prusaslicer-2.8.0-r1.ebuild108
-rw-r--r--media-gfx/prusaslicer/prusaslicer-2.8.1-r1.ebuild (renamed from media-gfx/prusaslicer/prusaslicer-2.8.1.ebuild)6
-rw-r--r--media-gfx/prusaslicer/prusaslicer-9999.ebuild6
9 files changed, 19 insertions, 362 deletions
diff --git a/media-gfx/prusaslicer/Manifest b/media-gfx/prusaslicer/Manifest
index a1d14e59d466..070d14534a75 100644
--- a/media-gfx/prusaslicer/Manifest
+++ b/media-gfx/prusaslicer/Manifest
@@ -1,2 +1 @@
-DIST prusaslicer-2.8.0.tar.gz 69806919 BLAKE2B b87c63ae411814dbffc8ae96c243bf06018d600db732ef32f7c766ce6bdf156b0aca6da90868482f39b9c6421c6a386bccc9f69e23218dadc07f1bcdb21b9793 SHA512 d98b43e9e1a6da9cbab46b2564da02fc0f8521d84a4df915d0ffd0878ee1a25afebe7078e38b124ec8565782379c51a7f9564462652ef1a7d9819d29297c1937
DIST prusaslicer-2.8.1.tar.gz 69409077 BLAKE2B dd3ee810ea00d03f1790386d1fe1fd044c038429700cd33f21299abdf5def12902f7a07c23aa3d2a6cfc5e18d1e2534080889d4a33beefb493a504978a742453 SHA512 0471fa579a494d66e6b49c0bc1a9fa91f3a5f9147d8b7fa8133c6f03391f8daddddb19ed222d1be44f6f22e2de3021f3fb839331e3c3ccdf5643caa8a61d6912
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.7.2-opencascade-7.8.0.patch b/media-gfx/prusaslicer/files/prusaslicer-2.7.2-opencascade-7.8.0.patch
deleted file mode 100644
index 296c0366e34a..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.7.2-opencascade-7.8.0.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/src/occt_wrapper/CMakeLists.txt
-+++ b/src/occt_wrapper/CMakeLists.txt
-@@ -22,11 +22,8 @@ generate_export_header(OCCTWrapper)
- find_package(OpenCASCADE REQUIRED)
-
- set(OCCT_LIBS
-- TKXDESTEP
-- TKSTEP
-- TKSTEP209
-- TKSTEPAttr
-- TKSTEPBase
-+ TKDESTEP
-+ TKDESTL
- TKXCAF
- TKXSBase
- TKVCAF
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.8.0-cgal-6.0.patch b/media-gfx/prusaslicer/files/prusaslicer-2.8.0-cgal-6.0.patch
deleted file mode 100644
index 52013146b1c3..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.8.0-cgal-6.0.patch
+++ /dev/null
@@ -1,189 +0,0 @@
-From a9283c62cec2b802aa2133c92b7ff5bf320c0bb6 Mon Sep 17 00:00:00 2001
-From: Laurent Rineau <laurent.rineau@cgal.org>
-Date: Sat, 13 Jul 2024 01:19:21 +0200
-Subject: [PATCH] compatibility with CGAL-6.0 (and 5.6.x)
-
---- a/src/libslic3r/CutSurface.cpp
-+++ b/src/libslic3r/CutSurface.cpp
-@@ -4,6 +4,14 @@
- ///|/
- #include "CutSurface.hpp"
-
-+template <typename T>
-+auto access_pmap(std::optional<T> opt) -> T {
-+ return opt.value();
-+}
-+
-+template <typename Pair>
-+auto access_pmap(Pair pair) { return pair.first; }
-+
- /// models_input.obj - Check transormation of model to each others
- /// projection_center.obj - circle representing center of projection with correct distance
- /// {M} .. model index
-@@ -33,6 +41,7 @@ using namespace Slic3r;
- #include <CGAL/Exact_integer.h>
- #include <CGAL/Surface_mesh.h>
- #include <CGAL/Cartesian_converter.h>
-+#include <CGAL/AABB_traits.h>
- #include <tbb/parallel_for.h>
-
- // libslic3r
-@@ -997,8 +1006,8 @@ priv::CutMesh priv::to_cgal(const ExPolygons &shapes,
- if (shapes.empty()) return {};
-
- CutMesh result;
-- EdgeShapeMap edge_shape_map = result.add_property_map<EI, IntersectingElement>(edge_shape_map_name).first;
-- FaceShapeMap face_shape_map = result.add_property_map<FI, IntersectingElement>(face_shape_map_name).first;
-+ EdgeShapeMap edge_shape_map = access_pmap((result.add_property_map<EI, IntersectingElement>(edge_shape_map_name)));
-+ FaceShapeMap face_shape_map = access_pmap((result.add_property_map<FI, IntersectingElement>(face_shape_map_name)));
-
- std::vector<VI> indices;
- auto insert_contour = [&projection, &indices, &result,
-@@ -1408,17 +1417,17 @@ priv::CutAOIs priv::cut_from_model(CutMesh &cgal_model,
- const ExPolygonsIndices &s2i)
- {
- // pointer to edge or face shape_map
-- VertexShapeMap vert_shape_map = cgal_model.add_property_map<VI, const IntersectingElement*>(vert_shape_map_name, nullptr).first;
-+ VertexShapeMap vert_shape_map = access_pmap((cgal_model.add_property_map<VI, const IntersectingElement*>(vert_shape_map_name, nullptr)));
-
- // detect anomalities in visitor.
- bool is_valid = true;
- // NOTE: map are created when convert shapes to cgal model
-- const EdgeShapeMap& edge_shape_map = cgal_shape.property_map<EI, IntersectingElement>(edge_shape_map_name).first;
-- const FaceShapeMap& face_shape_map = cgal_shape.property_map<FI, IntersectingElement>(face_shape_map_name).first;
-+ const EdgeShapeMap& edge_shape_map = access_pmap((cgal_shape.property_map<EI, IntersectingElement>(edge_shape_map_name)));
-+ const FaceShapeMap& face_shape_map = access_pmap((cgal_shape.property_map<FI, IntersectingElement>(face_shape_map_name)));
- Visitor visitor{cgal_model, cgal_shape, edge_shape_map, face_shape_map, vert_shape_map, &is_valid};
-
- // a property map containing the constrained-or-not status of each edge
-- EdgeBoolMap ecm = cgal_model.add_property_map<EI, bool>(is_constrained_edge_name, false).first;
-+ EdgeBoolMap ecm = access_pmap((cgal_model.add_property_map<EI, bool>(is_constrained_edge_name, false)));
- const auto &p = CGAL::parameters::visitor(visitor)
- .edge_is_constrained_map(ecm)
- .throw_on_self_intersection(false);
-@@ -1427,7 +1436,7 @@ priv::CutAOIs priv::cut_from_model(CutMesh &cgal_model,
-
- if (!is_valid) return {};
-
-- FaceTypeMap face_type_map = cgal_model.add_property_map<FI, FaceType>(face_type_map_name, FaceType::not_constrained).first;
-+ FaceTypeMap face_type_map = access_pmap((cgal_model.add_property_map<FI, FaceType>(face_type_map_name, FaceType::not_constrained)));
-
- // Select inside and outside face in model
- set_face_type(face_type_map, cgal_model, vert_shape_map, ecm, cgal_shape, s2i);
-@@ -1563,8 +1572,8 @@ void priv::collect_surface_data(std::queue<FI> &process,
-
- void priv::create_reduce_map(ReductionMap &reduction_map, const CutMesh &mesh)
- {
-- const VertexShapeMap &vert_shape_map = mesh.property_map<VI, const IntersectingElement*>(vert_shape_map_name).first;
-- const EdgeBoolMap &ecm = mesh.property_map<EI, bool>(is_constrained_edge_name).first;
-+ const VertexShapeMap &vert_shape_map = access_pmap((mesh.property_map<VI, const IntersectingElement*>(vert_shape_map_name)));
-+ const EdgeBoolMap &ecm = access_pmap((mesh.property_map<EI, bool>(is_constrained_edge_name)));
-
- // check if vertex was made by edge_2 which is diagonal of quad
- auto is_reducible_vertex = [&vert_shape_map](VI reduction_from) -> bool {
-@@ -1749,10 +1758,10 @@ priv::VDistances priv::calc_distances(const SurfacePatches &patches,
- for (const SurfacePatch &patch : patches) {
- // map is created during intersection by corefine visitor
- const VertexShapeMap &vert_shape_map =
-- models[patch.model_id].property_map<VI, const IntersectingElement *>(vert_shape_map_name).first;
-+ access_pmap((models[patch.model_id].property_map<VI, const IntersectingElement *>(vert_shape_map_name)));
- uint32_t patch_index = &patch - &patches.front();
- // map is created during patch creation / dividing
-- const CvtVI2VI& cvt = patch.mesh.property_map<VI, VI>(patch_source_name).first;
-+ const CvtVI2VI& cvt = access_pmap((patch.mesh.property_map<VI, VI>(patch_source_name)));
- // for each point on outline
- for (const Loop &loop : patch.loops)
- for (const VI &vi_patch : loop) {
-@@ -2640,7 +2649,7 @@ priv::SurfacePatch priv::create_surface_patch(const std::vector<FI> &fis,
- /* const */ CutMesh &mesh,
- const ReductionMap *rmap)
- {
-- auto is_counted = mesh.add_property_map<VI, bool>("v:is_counted").first;
-+ auto is_counted = access_pmap((mesh.add_property_map<VI, bool>("v:is_counted")));
- uint32_t count_vertices = 0;
- if (rmap == nullptr) {
- for (FI fi : fis)
-@@ -2670,7 +2679,7 @@ priv::SurfacePatch priv::create_surface_patch(const std::vector<FI> &fis,
- cm.reserve(count_vertices, count_edges, count_faces);
-
- // vertex conversion function from mesh VI to result VI
-- CvtVI2VI mesh2result = mesh.add_property_map<VI,VI>("v:mesh2result").first;
-+ CvtVI2VI mesh2result = access_pmap((mesh.add_property_map<VI,VI>("v:mesh2result")));
-
- if (rmap == nullptr) {
- for (FI fi : fis) {
-@@ -2722,7 +2731,7 @@ priv::SurfacePatch priv::create_surface_patch(const std::vector<FI> &fis,
- assert(count_edges >= cm.edges().size());
-
- // convert VI from this patch to source VI, when exist
-- CvtVI2VI cvt = cm.add_property_map<VI, VI>(patch_source_name).first;
-+ CvtVI2VI cvt = access_pmap((cm.add_property_map<VI, VI>(patch_source_name)));
- // vi_s .. VertexIndex into mesh (source)
- // vi_d .. new VertexIndex in cm (destination)
- for (VI vi_s : mesh.vertices()) {
-@@ -2913,7 +2922,7 @@ bool priv::is_patch_inside_of_model(const SurfacePatch &patch,
- uint32_t priv::get_shape_point_index(const CutAOI &cut, const CutMesh &model)
- {
- // map is created during intersection by corefine visitor
-- const VertexShapeMap &vert_shape_map = model.property_map<VI, const IntersectingElement *>(vert_shape_map_name).first;
-+ const VertexShapeMap &vert_shape_map = access_pmap((model.property_map<VI, const IntersectingElement *>(vert_shape_map_name)));
- // for each half edge of outline
- for (HI hi : cut.second) {
- VI vi = model.source(hi);
-@@ -2938,7 +2947,7 @@ priv::SurfacePatch priv::separate_patch(const std::vector<FI>& fis,
- patch_new.model_id = patch.model_id;
- patch_new.shape_id = patch.shape_id;
- // fix cvt
-- CvtVI2VI cvt = patch_new.mesh.property_map<VI, VI>(patch_source_name).first;
-+ CvtVI2VI cvt = access_pmap((patch_new.mesh.property_map<VI, VI>(patch_source_name)));
- for (VI &vi : cvt) {
- if (!vi.is_valid()) continue;
- vi = cvt_from[vi];
-@@ -2956,9 +2965,9 @@ void priv::divide_patch(size_t i, SurfacePatchesEx &patches)
- CutMesh& cm = patch.mesh;
- assert(!cm.faces().empty());
- std::string patch_number_name = "f:patch_number";
-- CutMesh::Property_map<FI,bool> is_processed = cm.add_property_map<FI, bool>(patch_number_name, false).first;
-+ CutMesh::Property_map<FI,bool> is_processed = access_pmap((cm.add_property_map<FI, bool>(patch_number_name, false)));
-
-- const CvtVI2VI& cvt_from = patch.mesh.property_map<VI, VI>(patch_source_name).first;
-+ const CvtVI2VI& cvt_from = access_pmap((patch.mesh.property_map<VI, VI>(patch_source_name)));
-
- std::vector<FI> fis;
- fis.reserve(cm.faces().size());
-@@ -3059,7 +3068,7 @@ priv::SurfacePatches priv::diff_models(VCutAOIs &cuts,
- CutAOIs &model_cuts = cuts[model_index];
- CutMesh &cut_model_ = cut_models[model_index];
- const CutMesh &cut_model = cut_model_;
-- ReductionMap vertex_reduction_map = cut_model_.add_property_map<VI, VI>(vertex_reduction_map_name).first;
-+ ReductionMap vertex_reduction_map = access_pmap((cut_model_.add_property_map<VI, VI>(vertex_reduction_map_name)));
- create_reduce_map(vertex_reduction_map, cut_model);
-
- for (size_t cut_index = 0; cut_index < model_cuts.size(); ++cut_index, ++index) {
-@@ -3145,7 +3154,7 @@ bool priv::is_over_whole_expoly(const CutAOI &cutAOI,
- const CutMesh &mesh)
- {
- // NonInterupted contour is without other point and contain all from shape
-- const VertexShapeMap &vert_shape_map = mesh.property_map<VI, const IntersectingElement*>(vert_shape_map_name).first;
-+ const VertexShapeMap &vert_shape_map = access_pmap((mesh.property_map<VI, const IntersectingElement*>(vert_shape_map_name)));
- for (HI hi : cutAOI.second) {
- const IntersectingElement *ie_s = vert_shape_map[mesh.source(hi)];
- const IntersectingElement *ie_t = vert_shape_map[mesh.target(hi)];
-@@ -3682,7 +3691,7 @@ void priv::store(const CutMesh &mesh, const FaceTypeMap &face_type_map, const st
- }
-
- CutMesh &mesh_ = const_cast<CutMesh &>(mesh);
-- auto face_colors = mesh_.add_property_map<priv::FI, CGAL::Color>("f:color").first;
-+ auto face_colors = access_pmap((mesh_.add_property_map<priv::FI, CGAL::Color>("f:color")));
- for (FI fi : mesh.faces()) {
- auto &color = face_colors[fi];
- switch (face_type_map[fi]) {
-@@ -3708,7 +3717,7 @@ void priv::store(const CutMesh &mesh, const ReductionMap &reduction_map, const s
- std::string off_file = dir + "model" + std::to_string(reduction_order++) + ".off";
-
- CutMesh &mesh_ = const_cast<CutMesh &>(mesh);
-- auto vertex_colors = mesh_.add_property_map<priv::VI, CGAL::Color>("v:color").first;
-+ auto vertex_colors = access_pmap((mesh_.add_property_map<priv::VI, CGAL::Color>("v:color")));
- // initialize to gray color
- for (VI vi: mesh.vertices())
- vertex_colors[vi] = CGAL::Color{127, 127, 127};
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.8.0-fixed-linking.patch b/media-gfx/prusaslicer/files/prusaslicer-2.8.0-fixed-linking.patch
deleted file mode 100644
index 33ab6256d6b0..000000000000
--- a/media-gfx/prusaslicer/files/prusaslicer-2.8.0-fixed-linking.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/src/slic3r/CMakeLists.txt
-+++ b/src/slic3r/CMakeLists.txt
-@@ -376,6 +376,7 @@ set(SLIC3R_GUI_SOURCES
- )
-
- find_package(NanoSVG REQUIRED)
-+find_package(OpenSSL REQUIRED)
-
- if (APPLE)
- list(APPEND SLIC3R_GUI_SOURCES
-@@ -404,7 +405,7 @@ endforeach()
-
- encoding_check(libslic3r_gui)
-
--target_link_libraries(libslic3r_gui libslic3r avrdude libcereal imgui libvgcode GLEW::GLEW OpenGL::GL hidapi libcurl ${wxWidgets_LIBRARIES} NanoSVG::nanosvg NanoSVG::nanosvgrast)
-+target_link_libraries(libslic3r_gui libslic3r avrdude libcereal imgui libvgcode GLEW::GLEW OpenGL::GL hidapi libcurl ${wxWidgets_LIBRARIES} NanoSVG::nanosvg NanoSVG::nanosvgrast OpenSSL::SSL OpenSSL::Crypto)
-
- if (MSVC)
- target_link_libraries(libslic3r_gui Setupapi.lib)
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fix-libsoup-double-linking.patch b/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fix-libsoup-double-linking.patch
new file mode 100644
index 000000000000..dbb0aa36727a
--- /dev/null
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fix-libsoup-double-linking.patch
@@ -0,0 +1,11 @@
+--- a/src/slic3r/CMakeLists.txt
++++ b/src/slic3r/CMakeLists.txt
+@@ -465,7 +465,7 @@ if (UNIX AND NOT APPLE)
+ find_package(GTK${SLIC3R_GTK} REQUIRED)
+ find_package(PkgConfig REQUIRED)
+
+- pkg_search_module(WEBKIT2GTK REQUIRED IMPORTED_TARGET webkit2gtk-4.0 webkit2gtk-4.1)
++ pkg_search_module(WEBKIT2GTK REQUIRED IMPORTED_TARGET webkit2gtk-4.1)
+ target_link_libraries(libslic3r_gui PUBLIC ${GTK${SLIC3R_GTK}_LIBRARIES} fontconfig PkgConfig::WEBKIT2GTK)
+ endif ()
+
diff --git a/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fixed-linking.patch b/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fixed-linking.patch
index b7fc95554591..9d387a07993d 100644
--- a/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fixed-linking.patch
+++ b/media-gfx/prusaslicer/files/prusaslicer-2.8.1-fixed-linking.patch
@@ -1,28 +1,3 @@
---- a/bundled_deps/admesh/CMakeLists.txt
-+++ b/bundled_deps/admesh/CMakeLists.txt
-@@ -13,4 +13,3 @@ add_library(admesh STATIC
-
- target_include_directories(admesh PUBLIC .)
- target_link_libraries(admesh PRIVATE boost_headeronly localesutils)
--target_link_libraries(admesh PUBLIC Eigen3::Eigen)
---- a/src/clipper/CMakeLists.txt
-+++ b/src/clipper/CMakeLists.txt
-@@ -10,5 +10,4 @@ add_library(clipper STATIC
- )
-
- target_link_libraries(clipper PRIVATE TBB::tbb TBB::tbbmalloc int128)
--target_link_libraries(clipper PUBLIC Eigen3::Eigen)
- target_include_directories(clipper PUBLIC .)
---- a/src/libslic3r/CMakeLists.txt
-+++ b/src/libslic3r/CMakeLists.txt
-@@ -629,7 +629,6 @@ target_link_libraries(libslic3r PRIVATE
- int128
- )
- target_link_libraries(libslic3r PUBLIC
-- Eigen3::Eigen
- semver
- admesh
- localesutils
--- a/src/slic3r/CMakeLists.txt
+++ b/src/slic3r/CMakeLists.txt
@@ -383,6 +383,7 @@ set(SLIC3R_GUI_SOURCES
diff --git a/media-gfx/prusaslicer/prusaslicer-2.8.0-r1.ebuild b/media-gfx/prusaslicer/prusaslicer-2.8.0-r1.ebuild
deleted file mode 100644
index 92c404bba643..000000000000
--- a/media-gfx/prusaslicer/prusaslicer-2.8.0-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER="3.2-gtk3"
-MY_PN="PrusaSlicer"
-MY_PV="$(ver_rs 3 -)"
-
-inherit cmake wxwidgets xdg
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/prusa3d/prusaslicer.git"
-else
- SRC_URI="https://github.com/prusa3d/PrusaSlicer/archive/refs/tags/version_${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~x86"
- S="${WORKDIR}/${MY_PN}-version_${MY_PV}"
-fi
-
-DESCRIPTION="A mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
-HOMEPAGE="https://www.prusa3d.com/prusaslicer/"
-
-LICENSE="AGPL-3 Boost-1.0 GPL-2 LGPL-3 MIT"
-SLOT="0"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-cpp/eigen:3
- dev-cpp/tbb:=
- dev-libs/boost:=[nls]
- dev-libs/cereal
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/gmp:=
- dev-libs/mpfr:=
- media-gfx/openvdb:=
- media-gfx/libbgcode
- net-misc/curl[adns]
- media-libs/glew:0=
- media-libs/libjpeg-turbo:=
- media-libs/libpng:0=
- media-libs/qhull:=
- sci-libs/libigl
- sci-libs/nlopt
- sci-libs/opencascade:=
- sci-mathematics/cgal:=
- sys-apps/dbus
- sys-libs/zlib:=
- virtual/opengl
- x11-libs/gtk+:3
- >=x11-libs/wxGTK-3.2.2.1-r3:${WX_GTK_VER}[X,opengl,webkit]
- media-libs/nanosvg:=
-"
-DEPEND="${RDEPEND}
- media-libs/qhull[static-libs]
- test? ( =dev-cpp/catch-2* )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.6.0-dont-force-link-to-wayland-and-x11.patch"
- "${FILESDIR}/${PN}-2.8.0-missing-includes.patch"
- "${FILESDIR}/${PN}-2.8.0-fixed-linking.patch"
- "${FILESDIR}/${PN}-2.8.0-wxwidgets-3.2.4.patch"
- "${FILESDIR}/${PN}-2.8.0-cgal-6.0.patch"
-)
-
-src_prepare() {
- if has_version ">=sci-libs/opencascade-7.8.0"; then
- eapply "${FILESDIR}/prusaslicer-2.7.2-opencascade-7.8.0.patch"
- fi
-
- sed -i -e 's/PrusaSlicer-${SLIC3R_VERSION}+UNKNOWN/PrusaSlicer-${SLIC3R_VERSION}+Gentoo/g' version.inc || die
-
- sed -i -e 's/find_package(OpenCASCADE 7.6.2 REQUIRED)/find_package(OpenCASCADE REQUIRED)/g' \
- src/occt_wrapper/CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- CMAKE_BUILD_TYPE="Release"
-
- setup-wxwidgets
-
- local mycmakeargs=(
- -DOPENVDB_FIND_MODULE_PATH="/usr/$(get_libdir)/cmake/OpenVDB"
-
- -DSLIC3R_BUILD_TESTS=$(usex test)
- -DSLIC3R_FHS=ON
- -DSLIC3R_GTK=3
- -DSLIC3R_GUI=ON
- -DSLIC3R_PCH=OFF
- -DSLIC3R_STATIC=OFF
- -DSLIC3R_WX_STABLE=ON
- -Wno-dev
- )
-
- cmake_src_configure
-}
-
-src_test() {
- CMAKE_SKIP_TESTS=(
- "^libslic3r_tests$"
- )
- cmake_src_test
-}
diff --git a/media-gfx/prusaslicer/prusaslicer-2.8.1.ebuild b/media-gfx/prusaslicer/prusaslicer-2.8.1-r1.ebuild
index ee32a6be8059..6b3be9ea12e5 100644
--- a/media-gfx/prusaslicer/prusaslicer-2.8.1.ebuild
+++ b/media-gfx/prusaslicer/prusaslicer-2.8.1-r1.ebuild
@@ -43,6 +43,7 @@ RDEPEND="
media-libs/libjpeg-turbo:=
media-libs/libpng:0=
media-libs/qhull:=
+ net-libs/webkit-gtk:4.1
sci-libs/libigl
sci-libs/nlopt
sci-libs/opencascade:=
@@ -66,6 +67,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.8.1-fixed-linking.patch"
"${FILESDIR}/${PN}-2.8.1-cgal-6.0.patch"
"${FILESDIR}/${PN}-2.8.1-fstream.patch"
+ "${FILESDIR}/${PN}-2.8.1-fix-libsoup-double-linking.patch"
)
src_prepare() {
@@ -78,8 +80,8 @@ src_prepare() {
sed -i -e 's/find_package(OpenCASCADE 7.6.[0-9] REQUIRED)/find_package(OpenCASCADE REQUIRED)/g' \
src/occt_wrapper/CMakeLists.txt || die
- find . -type f \( -name '*.cpp' -o -name '*.h' -o -name '*.hpp' \) -exec \
- sed -i 's|#include <Eigen/|#include <eigen3/Eigen/|g; s|#include <unsupported/Eigen/|#include <eigen3/unsupported/Eigen/|g' {} + || die
+ # remove broken cmake find file: https://github.com/prusa3d/PrusaSlicer/issues/13608
+ rm cmake/modules/FindEigen3.cmake || die
cmake_src_prepare
}
diff --git a/media-gfx/prusaslicer/prusaslicer-9999.ebuild b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
index fbf13e9d7d66..66c1089c97e8 100644
--- a/media-gfx/prusaslicer/prusaslicer-9999.ebuild
+++ b/media-gfx/prusaslicer/prusaslicer-9999.ebuild
@@ -43,6 +43,7 @@ RDEPEND="
media-libs/libjpeg-turbo:=
media-libs/libpng:0=
media-libs/qhull:=
+ net-libs/webkit-gtk:4.1
sci-libs/libigl
sci-libs/nlopt
sci-libs/opencascade:=
@@ -66,6 +67,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.8.1-fixed-linking.patch"
"${FILESDIR}/${PN}-2.8.1-cgal-6.0.patch"
"${FILESDIR}/${PN}-2.8.1-fstream.patch"
+ "${FILESDIR}/${PN}-2.8.1-fix-libsoup-double-linking.patch"
)
src_prepare() {
@@ -78,8 +80,8 @@ src_prepare() {
sed -i -e 's/find_package(OpenCASCADE 7.6.[0-9] REQUIRED)/find_package(OpenCASCADE REQUIRED)/g' \
src/occt_wrapper/CMakeLists.txt || die
- find . -type f \( -name '*.cpp' -o -name '*.h' -o -name '*.hpp' \) -exec \
- sed -i 's|#include <Eigen/|#include <eigen3/Eigen/|g; s|#include <unsupported/Eigen/|#include <eigen3/unsupported/Eigen/|g' {} + || die
+ # remove broken cmake find file: https://github.com/prusa3d/PrusaSlicer/issues/13608
+ rm cmake/modules/FindEigen3.cmake || die
cmake_src_prepare
}