summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-04-28 16:33:55 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-04-28 16:33:55 +0000
commit4f3030d3f38087be0009415ebec7be663e87ee17 (patch)
tree38af0f543ab05a652f5fe0a2023e017c55d4d907
parent2022-04-28 16:18:22 UTC (diff)
parentautotools.eclass: fix EAPI 8 conditional; simplify (diff)
downloadgentoo-4f3030d3f38087be0009415ebec7be663e87ee17.tar.gz
gentoo-4f3030d3f38087be0009415ebec7be663e87ee17.tar.bz2
gentoo-4f3030d3f38087be0009415ebec7be663e87ee17.zip
Merge updates from master
-rw-r--r--eclass/autotools.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index c275c83d55c2..e6658e361318 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -393,8 +393,8 @@ eautoconf() {
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
- case ${EAPI:-0} in
- 0|1|2|3|4|5|6|7)
+ case ${EAPI} in
+ 5|6|7)
eqawarn "This package has a configure.in file which has long been deprecated. Please"
eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
@@ -519,7 +519,7 @@ autotools_env_setup() {
5|6)
hv_args="--host-root"
;;
- 7)
+ *)
hv_args="-b"
;;
esac