summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-05-18 15:10:08 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-05-18 15:10:08 +0000
commit445a46dcbaca0d80d78d6f1e927ca6cd6feb5fe4 (patch)
treed3a10a00b42c3d15331f339990311acb227e5991
parent2017-05-18 14:44:00 UTC (diff)
parentmedia-libs/libao: Bump to version 1.2.2 (diff)
downloadgentoo-445a46dcbaca0d80d78d6f1e927ca6cd6feb5fe4.tar.gz
gentoo-445a46dcbaca0d80d78d6f1e927ca6cd6feb5fe4.tar.bz2
gentoo-445a46dcbaca0d80d78d6f1e927ca6cd6feb5fe4.zip
Merge updates from master
-rw-r--r--eclass/python-r1.eclass2
-rw-r--r--media-libs/libao/Manifest1
-rw-r--r--media-libs/libao/libao-1.2.2.ebuild53
3 files changed, 55 insertions, 1 deletions
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index 6181ec32af61..8de0a851856c 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -628,7 +628,7 @@ python_setup() {
local best_impl patterns=( "${@-*}" )
_python_try_impl() {
- if _python_impl_matches "${impl}" "${patterns[@]}"; then
+ if _python_impl_matches "${EPYTHON}" "${patterns[@]}"; then
best_impl=${EPYTHON}
fi
}
diff --git a/media-libs/libao/Manifest b/media-libs/libao/Manifest
index 1cbdb4194993..6c47c6696b29 100644
--- a/media-libs/libao/Manifest
+++ b/media-libs/libao/Manifest
@@ -1 +1,2 @@
DIST libao-1.2.0.tar.gz 464596 SHA256 03ad231ad1f9d64b52474392d63c31197b0bc7bd416e58b1c10a329a5ed89caf SHA512 9456953826c188d67129ad78366bb86d6243499f2cd340d20d61366f7e40a33f3f8ab601c7f18ce9e24aa22f898093b482b2415b7e428c1486ef7e5ac27b3ee4 WHIRLPOOL 00bca36fd033775f9fb8551ce20425d7c3ebd138174692831f256fbcef306e391479ae63a8bd25fa4995a2ff53ba5e478317ef6c3b5028925a737b08189f4bf2
+DIST libao-1.2.2.tar.gz 96134 SHA256 df8a6d0e238feeccb26a783e778716fb41a801536fe7b6fce068e313c0e2bf4d SHA512 d2736d25b60862e7d7469611ce31b1df40a4366ab160e2ff1b46919ae91692d1596c8468e4f016303b306fc3ac1bddc7b727f535a362f403c3fe7c6532e9045a WHIRLPOOL f24697f068b38e29c521542a093c740efd774334c7cedd2d2ae611bafe6b14c8844a3bbf845bd2c51c2a0338412b1d06dc401849f940e977884d1e5c2784152a
diff --git a/media-libs/libao/libao-1.2.2.ebuild b/media-libs/libao/libao-1.2.2.ebuild
new file mode 100644
index 000000000000..b48b15c68ef0
--- /dev/null
+++ b/media-libs/libao/libao-1.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool multilib multilib-minimal
+
+DESCRIPTION="The Audio Output library"
+HOMEPAGE="http://www.xiph.org/ao/"
+#SRC_URI="http://downloads.xiph.org/releases/ao/${P}.tar.gz"
+#SRC_URI="https://git.xiph.org/?p=libao.git;a=snapshot;h=refs/tags/${PV};sf=tgz -> ${P}.tar.gz"
+SRC_URI="https://github.com/xiph/libao/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="alsa nas mmap pulseaudio static-libs"
+
+RDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i "s:/lib:/$(get_libdir):g" ao.m4 || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-arts
+ --disable-esd
+ $(use_enable alsa alsa)
+ $(use_enable mmap alsa-mmap)
+ $(use_enable nas)
+ $(use_enable pulseaudio pulse)
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS CHANGES README TODO
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}