summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-05-31 23:18:53 -0700
committerMichał Górny <mgorny@gentoo.org>2020-06-02 09:11:01 +0200
commit3e24f76827fb4b305327d68a57216e4c73befd00 (patch)
tree451bec28ede329e97210eb2421f8d88b0ffb60b0
parentdev-python/wcwidth: Bump to 0.2.2 (diff)
downloadgentoo-3e24f76827fb4b305327d68a57216e4c73befd00.tar.gz
gentoo-3e24f76827fb4b305327d68a57216e4c73befd00.tar.bz2
gentoo-3e24f76827fb4b305327d68a57216e4c73befd00.zip
dev-python/Rx-3.1.0: bump
* Switch to EAPI 7 * Support Python 3.7/3.8/3.9 * Run tests Bug: https://bugs.gentoo.org/708270 Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/16040 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Rx/Manifest1
-rw-r--r--dev-python/Rx/Rx-3.1.0.ebuild30
-rw-r--r--profiles/package.mask1
3 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/Rx/Manifest b/dev-python/Rx/Manifest
index 118d4672457d..8ad0bfc293ab 100644
--- a/dev-python/Rx/Manifest
+++ b/dev-python/Rx/Manifest
@@ -1 +1,2 @@
DIST Rx-1.6.1.tar.gz 89543 BLAKE2B ee0b6c30c794febdd045231ff61a330a512c86a9dd3c56a6afa900c31ca774725d7bf5b589d46b60f79cd1f0bc967b5ab5bc87a58f6d3dbebbdb1b6618db875d SHA512 8602b5175c058e855ac4b67d8feed435f93632da2f4033fe0db54fcbb012a702786b29f97fe3fd641f054c3a61478dccac21c614b5708f7bfb0b986c9951e6a9
+DIST Rx-3.1.0.tar.gz 890293 BLAKE2B 268f6df5450d1235d50f9aee5cd43fe6e229acf7b2ddab5f1f97e80594aeff7beaa280fe272ac9cc8b80dc6874f4bb76e438e94c09712f2c37e72d8d40f9f283 SHA512 1d9f6639ef08dc991326b95fcbf0978adea55b35acab653fc16bd94ccf2ad3a1515e8cb4e8d2ff38d7a506306e310394339a8651a2a02fa22bfb7f17d86297f1
diff --git a/dev-python/Rx/Rx-3.1.0.ebuild b/dev-python/Rx/Rx-3.1.0.ebuild
new file mode 100644
index 000000000000..dca57f5969d9
--- /dev/null
+++ b/dev-python/Rx/Rx-3.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 python3_9 )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="https://github.com/ReactiveX/${MY_P}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index cb0ab1374caa..fc7c72117630 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -90,7 +90,6 @@ dev-python/toro
# Outdated. Not touched since the initial commit. Lacks py3.7 support.
# No reverse dependencies outside the three packages.
# Removal in 30 days. Bug #708270.
-dev-python/Rx
dev-python/graphql-core
dev-python/gql