summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 03:26:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:29:22 +0200
commit355166de55a21ac1687b244d149354dd6c6db39f (patch)
tree5596bf7262d18bef7461e4416ba72b7aa9d974af
parentdev-python/recurring-ical-events: Bump to 3.0.0 (diff)
downloadgentoo-355166de55a21ac1687b244d149354dd6c6db39f.tar.gz
gentoo-355166de55a21ac1687b244d149354dd6c6db39f.tar.bz2
gentoo-355166de55a21ac1687b244d149354dd6c6db39f.zip
dev-python/jaraco-context: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-context/Manifest1
-rw-r--r--dev-python/jaraco-context/jaraco-context-6.0.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/jaraco-context/Manifest b/dev-python/jaraco-context/Manifest
index ecd56663a6b7..32666e593aa6 100644
--- a/dev-python/jaraco-context/Manifest
+++ b/dev-python/jaraco-context/Manifest
@@ -1 +1,2 @@
DIST jaraco.context-5.3.0.tar.gz 13345 BLAKE2B d2f429335ea80a6b50ea9574adc45c25c0fc78e8ebb5edde218bcbbe7a2b27ae6b5c17453e71904240d0d873ebef36f7c7aeda4424d3fea2dd9aaf01af6fb4c5 SHA512 f63bf272c45ff5c43499621651b78841259040ac98d67c9db75fadebb1c497c1156e05f23bf7c91df3e91f1e070acb9f7dc665e7b242ba7b1ac1cf99a619494d
+DIST jaraco_context-6.0.0.tar.gz 14118 BLAKE2B 96901d173426e8bad5755c0e21ba789daf4217a7ed94efb81fdb3daf2d9a13f5875a17fa20a5193bb6a7a7c772b2b77e3b85a465039bdefa6231075a45133fda SHA512 a831ee8b732fc2b40e7de81d390fb5869317a127e5999a1c4f00f3ab81e04d4021733816e813c1ddbc1370540aca6205353c7a024f60d6f0dc59545abe505fa6
diff --git a/dev-python/jaraco-context/jaraco-context-6.0.0.ebuild b/dev-python/jaraco-context/jaraco-context-6.0.0.ebuild
new file mode 100644
index 000000000000..bb3bb1f1507b
--- /dev/null
+++ b/dev-python/jaraco-context/jaraco-context-6.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Context managers by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.context/
+ https://pypi.org/project/jaraco.context/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/backports-tarfile[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+BDEPEND="
+ test? (
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ jaraco/context/__init__.py::jaraco.context.repo_context
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.context"
+ version = "${PV}"
+ description = "Context managers by jaraco"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}context-${PV}.dist-info || die
+}