summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2019-12-01 20:29:51 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2019-12-01 20:29:51 +0000
commit2c2806b64d6a8779cf5f00fc5daaffef76300020 (patch)
tree0bc1df7860664cf857db9736a0512fcbeda241c7
parent2019-12-01 20:06:25 UTC (diff)
parentpackage.mask: Last rite net-analyzer/suricata (diff)
downloadgentoo-2c2806b64d6a8779cf5f00fc5daaffef76300020.tar.gz
gentoo-2c2806b64d6a8779cf5f00fc5daaffef76300020.tar.bz2
gentoo-2c2806b64d6a8779cf5f00fc5daaffef76300020.zip
Merge updates from master
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.50.3.ebuild58
-rw-r--r--dev-python/owslib/owslib-0.17.1-r1.ebuild42
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-2.4.1.ebuild49
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-42.0.2.ebuild89
-rw-r--r--eclass/distutils-r1.eclass6
-rw-r--r--profiles/package.mask27
-rw-r--r--sci-geosciences/qgis/qgis-9999.ebuild2
-rw-r--r--sci-libs/Shapely/Shapely-1.6.4_p2.ebuild2
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-0.12.10.ebuild48
13 files changed, 324 insertions, 3 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index f5bdbba5872e..302c4c49a0bd 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d
DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
DIST hypothesis-python-4.50.1.tar.gz 6811489 BLAKE2B 26efeb6b648f494e5d6c7b36f6c32c92bb7bf6ae0ae776d39d9e4a815122cb3832fc8b035823b7e11de41afa0b529b9ed38ee63b0a3cf0aafa3bded50fc04abb SHA512 b6d2799b2ab8e5809f9ac7bb910bd6844c853a50e1bdacb77afc4c3a09631cd626036dd4edf3b1e211bec4982feeb07c2273ad1a4029b737dc188b0d7c5a3beb
DIST hypothesis-python-4.50.2.tar.gz 6812169 BLAKE2B bcdba296b76d8fad64d2f3fcb23ff7452f558b1b47f1924048395c34f2dc49bd2525a3363a35e0013c8762954b681f96c3309eea3f64b276c13893d3ce40b564 SHA512 cd8a0f62caab16544abf923a43c411dea8abf1e0ed5e8ce18cf574959bbc20c31245b3022def80b0a08f234933cbc354804308942cb575a652a6b36814b58c59
+DIST hypothesis-python-4.50.3.tar.gz 6812208 BLAKE2B 2c5102e3fe62cf405f4e9216e516d9cf0a1fb3f138cb6578a75187bc8d5e1736eba9e88c88521ec9439e91f520d3077ea7bc116c9f059331534791e3ce969b31 SHA512 fbf4b5ca052ca6e3fc647b2b48c3f91d6aa6eba630abfe44c545d1d618834875ed8fe87b49daccc0780478bc259b790178640072e509e8dacbac9bc4b20d99fa
diff --git a/dev-python/hypothesis/hypothesis-4.50.3.ebuild b/dev-python/hypothesis/hypothesis-4.50.3.ebuild
new file mode 100644
index 000000000000..3def9e851218
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-4.50.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local pyver=$(python_is_python3 && echo 3 || echo 2)
+ pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/owslib/owslib-0.17.1-r1.ebuild b/dev-python/owslib/owslib-0.17.1-r1.ebuild
new file mode 100644
index 000000000000..29a6ac4beb8d
--- /dev/null
+++ b/dev-python/owslib/owslib-0.17.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib"
+SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || (
+ dev-python/elementtree[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test" # tests require WAN access
+
+S="${WORKDIR}/OWSLib-${PV}"
+
+python_test() {
+ "${EPYTHON}" "${S}/setup.py" test || die
+}
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index a47eba325f7a..02a19abffc90 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-1.9.5.1.tar.gz 4424543 BLAKE2B cdf954ec0fe794f354b246fcd5afeac01b796f84cc2456efce3e289fcfb12074d7352c9fa7e9d74356199135dfa9814c07da9379f85771dbb7130b8b9b7ecc34 SHA512 b0e0f85be01a3399cb41c4bf29d1a63ecb519fd45d6092a3558060d93c715afafd12f7532c8665839225ad7243e739a117677f6747bf34a0ccbde5e75c85f324
+DIST pyproj-2.4.1.tar.gz 462332 BLAKE2B bd5f8f34bd1e4f928cbbba8736ede96425f1823171b1e4da0ecd6ccf9f105d4f5d4c9f953f353382412883c70803421b4d9a5175aba5cabcb689fafb19484a89 SHA512 c8bc987991b8136951f038f504cb6ffa5f69663b9ba447b586ab29d30e91b05661c46726132ac2cbfd756d92842606b1d5a5167b84c66878688e5ac4e5259353
diff --git a/dev-python/pyproj/pyproj-2.4.1.ebuild b/dev-python/pyproj/pyproj-2.4.1.ebuild
new file mode 100644
index 000000000000..e634e69603c5
--- /dev/null
+++ b/dev-python/pyproj/pyproj-2.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python < 3.6 requires https://pypi.org/project/aenum/
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/jswhit/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=sci-libs/proj-6.2.0"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ append-cflags -fno-strict-aliasing
+}
+
+python_test() {
+ PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 9a7ba465b4f8..544e144408b9 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -2,3 +2,4 @@ DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31
DIST setuptools-41.5.1.zip 851097 BLAKE2B 2411db77cffb24190c1510c7fab623ae0fb2a248994eae01e1a79427d35d8bf6a2f065de0d95dc11105df0bb42962a57c914486b48dc91115ec32e4dbcbc059d SHA512 eb6e944c80448873f8970477aaf474e75879e2b81b91fdc7a308670fed231d52880c3be3452e7ed3f094f20d4afe54b1db24ec4d98845ed47ee5e71dbf66261d
DIST setuptools-42.0.0.zip 852125 BLAKE2B b3cbba2eb97f7d6d0bb1a1d582c927680ada8d4589c4a196886f95cddd5b8c8b14fb5f0a2397ab7bcdc4ddd5fe6d4eddfab53bf9f43e0781a666f3d88efb8117 SHA512 d430605f8da3820b8d902d339b63bc382b9ec1bb0187385f792226bdfa8c191634df69881e1c43ffa8900599307d0ba202cfcb2d30df12d061f8220b9eae854a
DIST setuptools-42.0.1.zip 852264 BLAKE2B fac352a9d87245655f8183a8037552d454441ca5d18be60986d3d7883472a8be6af83614cb73896b76a251eadb09c1a67db9789ddbc5beb1dd9c3e1ddadd671a SHA512 d8eea952dc3cd925ddf3aaf059e9042dcb2684fd841446d92f309fcf8ad1869a380784d137006ca1b46ee539b4e1867e5b61eae80553295897df702966447232
+DIST setuptools-42.0.2.zip 858444 BLAKE2B 2b77dbeeb9a3b4138810a96fe7ac0a7800717b4b68d6e9db2d146ca176127d5bfd5e4ef07adfa98758f8c4d05396152ca08e1707caf3d91703c7b268bd291f28 SHA512 ab623fd69b92111d3ab19a3ad9de9c07b4316f4130f3db4068a436d3c13c971d97506f7307c9f64d9cc9ca24a5f3800b68748455e70418d0c0cd240c93ebae35
diff --git a/dev-python/setuptools/setuptools-42.0.2.ebuild b/dev-python/setuptools/setuptools-42.0.2.ebuild
new file mode 100644
index 000000000000..34e7487de3a6
--- /dev/null
+++ b/dev-python/setuptools/setuptools-42.0.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Temporary hack to avoid py38 keywording hell. Please remove when
+# the test deps all have py38. Also setuptools' test pass with py38,
+# so you need to hack them all in locally before bumping and test.
+TEST_USEDEP=$(python_gen_usedep python2_7 python3_{5,6,7} pypy{,3})
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${TEST_USEDEP}]
+ dev-python/pip[${TEST_USEDEP}]
+ >=dev-python/pytest-3.7.0[${TEST_USEDEP}]
+ dev-python/pytest-fixture-config[${TEST_USEDEP}]
+ dev-python/pytest-virtualenv[${TEST_USEDEP}]
+ dev-python/wheel[${TEST_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+PATCHES=(
+ # fix regression introduced by reinventing deprecated 'imp'
+ # https://github.com/pypa/setuptools/pull/1905
+ "${FILESDIR}"/setuptools-42.0.0-imp-fix.patch
+)
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python3.8 ]]; then
+ if [[ ${PV} != 42.0.2 ]]; then
+ eerror "Please disable py38 hacks and test locally, then update this."
+ die "Python 3.8 support untested for ${PV}"
+ fi
+ einfo "Skipping testing on ${EPYTHON} due to unkeyworded deps"
+ return
+ fi
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index f44f0aee9c21..0c5d6781f83d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -821,7 +821,11 @@ distutils-r1_run_phase() {
debug-print-function ${FUNCNAME} "${@}"
if [[ ${DISTUTILS_IN_SOURCE_BUILD} ]]; then
- if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
+ # only force BUILD_DIR if implementation is explicitly enabled
+ # for building; any-r1 API may select one that is not
+ # https://bugs.gentoo.org/701506
+ if [[ ! ${DISTUTILS_SINGLE_IMPL} ]] &&
+ has "${EPYTHON/./_}" ${PYTHON_TARGETS}; then
cd "${BUILD_DIR}" || die
fi
local BUILD_DIR=${BUILD_DIR}/build
diff --git a/profiles/package.mask b/profiles/package.mask
index e0acc0412496..e5fe1ddf15f4 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -29,6 +29,33 @@
#--- END OF EXAMPLES ---
+# Michał Górny <mgorny@gentoo.org> (2019-12-01)
+# Multiple unresolved vulnerabilities. The current Gentoo version
+# has reached EOL upstream. The package hasn't been bumped since
+# mid-2018.
+# Removal in 30 days. Bug #686428.
+net-analyzer/suricata
+
+# Michał Górny <mgorny@gentoo.org> (2019-12-01)
+# Unresolved license issues. No reply from maintainer.
+# Removal in 30 days. Bug #694262.
+dev-util/idea-community
+
+# Michał Górny <mgorny@gentoo.org> (2019-12-01)
+# Unmaintained. Last release in 2012. Buggy ebuild.
+# Removal in 30 days. Bug #658302.
+app-text/pdfshuffler
+
+# Michał Górny <mgorny@gentoo.org> (2019-12-01)
+# Not updated since 2015. No reverse dependencies.
+# Removal in 30 days. Bug #695392.
+dev-python/quixote
+
+# Michał Górny <mgorny@gentoo.org> (2019-12-01)
+# Unresolved license issues. No reply from the maintainer.
+# Removal in 30 days. Bug #694268.
+dev-util/goland
+
# Matt Turner <mattst88@gentoo.org> (2019-12-01)
# browserpass ebuild ported to go-modules, so these modules now have no reverse
# dependencies.
diff --git a/sci-geosciences/qgis/qgis-9999.ebuild b/sci-geosciences/qgis/qgis-9999.ebuild
index 73aa5dd50222..6172fb371cc3 100644
--- a/sci-geosciences/qgis/qgis-9999.ebuild
+++ b/sci-geosciences/qgis/qgis-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="sqlite"
QT_MIN_VER="5.9.4"
diff --git a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
index 50528d9087df..111341b34ff8 100644
--- a/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
+++ b/sci-libs/Shapely/Shapely-1.6.4_p2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1 eapi7-ver
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 07ce1f73e703..202fe5e4d98d 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,3 +1,4 @@
+DIST exo-0.12.10.tar.bz2 1333794 BLAKE2B 6dd32fcb797f704713a01a01960cb047809e2d3fad3962fbc5a16a510f78ba359978664c4ca7b20e066fdac77a41568ed15af84b6f45048b6bd78a7fadcbeed1 SHA512 b532a33eededc0d81e37c49975281e64d27bacebe878b784669d18112bc70dc39a4e82f781ad602263b10e0167e6391511a8be51f37e82f7be3b14cb6990a49e
DIST exo-0.12.4.tar.bz2 1235738 BLAKE2B f05ae13bb5ec599686207df3fe7458b8a42227194c91c24397ed282d2c7a6ccf10989f14c662f2e0d986c59695de2b8d50743c8489bc716aaa001cbd23fe3598 SHA512 8f84258aeb5c1fcfe91e775af1e5fed02f36b3d18aa72d497cd05294d54f050d679628cdb4339219c67b203a8cc663704a240fc18e6a918cef363cf4d9b94783
DIST exo-0.12.8.tar.bz2 1342201 BLAKE2B 6f52072f169a48ace6490d4c272e7e1208ca66efc388c8706b183d8ebe908d2fc305ae0239647e96e860eaacb1fbc440fc8dd559757f29088548c95702b1401e SHA512 5b96f1e3ba7112d349ee7d986288996c52210304d0aa54594fdc8c85ec0b12e13791f320f28e91bd25afda5f1046f402ba4fcf2eca5df5d8fc0c3515cd6b98a3
DIST exo-0.12.9.tar.bz2 1333477 BLAKE2B 18b6892b32ff65350b9e64be8190a5d6ca3637c97ba1449e7e511c1efaf081a308c9a0796d845d0069186f85dc775f9196703a1f0a97c16de7bbae6aa94a47d8 SHA512 ae0e893c595553ff9db15967419ffd9d78ec6ab6dbcefcc02536367e04cc4db51d41305f0f527778ba9b8b04cb51bd560bff07ef5ba3a56d1acab1d1730e7ee7
diff --git a/xfce-base/exo/exo-0.12.10.ebuild b/xfce-base/exo/exo-0.12.10.ebuild
new file mode 100644
index 000000000000..77319c3c1ace
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gtk2"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42
+ dev-perl/URI
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ gtk2? ( >=x11-libs/gtk+-2.24:2 )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable gtk2)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}