summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-06-23 10:40:08 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-06-23 10:40:08 +0000
commit1bf6512adb94b8457822007c222add74e4dbc700 (patch)
treedfca9d3b1b75ad53de0d5888f21f872e6f4599d0
parent2021-06-23 10:21:23 UTC (diff)
parentgames-strategy/hedgewars: Add patch for fpc 3.2 ICE (diff)
downloadgentoo-1bf6512adb94b8457822007c222add74e4dbc700.tar.gz
gentoo-1bf6512adb94b8457822007c222add74e4dbc700.tar.bz2
gentoo-1bf6512adb94b8457822007c222add74e4dbc700.zip
Merge updates from master
-rw-r--r--app-doc/pms/pms-9999.ebuild4
-rw-r--r--eclass/flag-o-matic.eclass4
-rw-r--r--eclass/git-r3.eclass70
-rw-r--r--eclass/gnuconfig.eclass9
-rw-r--r--eclass/libtool.eclass11
-rw-r--r--eclass/multilib.eclass6
-rw-r--r--eclass/toolchain-funcs.eclass4
-rw-r--r--games-strategy/hedgewars/files/hedgewars-1.0.0-fpc-3.2.patch23
-rw-r--r--games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild2
9 files changed, 50 insertions, 83 deletions
diff --git a/app-doc/pms/pms-9999.ebuild b/app-doc/pms/pms-9999.ebuild
index b37a3c1f7af5..337c699dd800 100644
--- a/app-doc/pms/pms-9999.ebuild
+++ b/app-doc/pms/pms-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3
@@ -28,7 +28,7 @@ RDEPEND="!app-doc/pms-bin"
src_compile() {
# just in case; we shouldn't be generating any fonts
export VARTEXFONTS="${T}/fonts"
- emake $(usex twoside TWOSIDE=yes "")
+ emake $(usev twoside TWOSIDE=yes)
use html && emake html
}
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 2e04e2acb06b..d262a60b6bb2 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -4,7 +4,7 @@
# @ECLASS: flag-o-matic.eclass
# @MAINTAINER:
# toolchain@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: common functions to manipulate and query toolchain flags
# @DESCRIPTION:
# This eclass contains a suite of functions to help developers sanely
@@ -12,7 +12,7 @@
case ${EAPI:-0} in
0|1|2|3|4) die "flag-o-matic.eclass: EAPI ${EAPI} is too old." ;;
- 5|6|7) ;;
+ 5|6|7|8) ;;
*) die "EAPI ${EAPI} is not supported by flag-o-matic.eclass." ;;
esac
diff --git a/eclass/git-r3.eclass b/eclass/git-r3.eclass
index 9c4f2c9d778e..398170000498 100644
--- a/eclass/git-r3.eclass
+++ b/eclass/git-r3.eclass
@@ -4,21 +4,15 @@
# @ECLASS: git-r3.eclass
# @MAINTAINER:
# Michał Górny <mgorny@gentoo.org>
-# @SUPPORTED_EAPIS: 4 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: Eclass for fetching and unpacking git repositories.
# @DESCRIPTION:
# Third generation eclass for easing maintenance of live ebuilds using
# git as remote repository.
-case "${EAPI:-0}" in
- 0|1|2|3)
- die "Unsupported EAPI=${EAPI} (obsolete) for ${ECLASS}"
- ;;
- 4|5|6|7)
- ;;
- *)
- die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
- ;;
+case ${EAPI:-0} in
+ 5|6|7|8) ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
EXPORT_FUNCTIONS src_unpack
@@ -27,12 +21,10 @@ if [[ ! ${_GIT_R3} ]]; then
PROPERTIES+=" live"
-if [[ ! ${_INHERITED_BY_GIT_2} ]]; then
- if [[ ${EAPI:-0} != [0123456] ]]; then
- BDEPEND=">=dev-vcs/git-1.8.2.1[curl]"
- else
- DEPEND=">=dev-vcs/git-1.8.2.1[curl]"
- fi
+if [[ ${EAPI} != [56] ]]; then
+ BDEPEND=">=dev-vcs/git-1.8.2.1[curl]"
+else
+ DEPEND=">=dev-vcs/git-1.8.2.1[curl]"
fi
# @ECLASS-VARIABLE: EGIT_CLONE_TYPE
@@ -284,50 +276,6 @@ _git-r3_env_setup() {
if [[ ${EGIT_COMMIT} && ${EGIT_COMMIT_DATE} ]]; then
die "EGIT_COMMIT and EGIT_COMMIT_DATE can not be specified simultaneously"
fi
-
- # Migration helpers. Remove them when git-2 is removed.
-
- if [[ ${EGIT_SOURCEDIR} ]]; then
- eerror "EGIT_SOURCEDIR has been replaced by EGIT_CHECKOUT_DIR. While updating"
- eerror "your ebuild, please check whether the variable is necessary at all"
- eerror "since the default has been changed from \${S} to \${WORKDIR}/\${P}."
- eerror "Therefore, proper setting of S may be sufficient."
- die "EGIT_SOURCEDIR has been replaced by EGIT_CHECKOUT_DIR."
- fi
-
- if [[ ${EGIT_MASTER} ]]; then
- eerror "EGIT_MASTER has been removed. Instead, the upstream default (HEAD)"
- eerror "is used by the eclass. Please remove the assignment or use EGIT_BRANCH"
- eerror "as necessary."
- die "EGIT_MASTER has been removed."
- fi
-
- if [[ ${EGIT_HAS_SUBMODULES} ]]; then
- eerror "EGIT_HAS_SUBMODULES has been removed. The eclass no longer needs"
- eerror "to switch the clone type in order to support submodules and therefore"
- eerror "submodules are detected and fetched automatically. If you need to"
- eerror "disable or filter submodules, see EGIT_SUBMODULES."
- die "EGIT_HAS_SUBMODULES is no longer necessary."
- fi
-
- if [[ ${EGIT_PROJECT} ]]; then
- eerror "EGIT_PROJECT has been removed. Instead, the eclass determines"
- eerror "the local clone path using path in canonical EGIT_REPO_URI."
- eerror "If the current algorithm causes issues for you, please report a bug."
- die "EGIT_PROJECT is no longer necessary."
- fi
-
- if [[ ${EGIT_BOOTSTRAP} ]]; then
- eerror "EGIT_BOOTSTRAP has been removed. Please create proper src_prepare()"
- eerror "instead."
- die "EGIT_BOOTSTRAP has been removed."
- fi
-
- if [[ ${EGIT_NOUNPACK} ]]; then
- eerror "EGIT_NOUNPACK has been removed. The eclass no longer calls default"
- eerror "unpack function. If necessary, please declare proper src_unpack()."
- die "EGIT_NOUNPACK has been removed."
- fi
}
# @FUNCTION: _git-r3_set_gitdir
@@ -612,7 +560,7 @@ git-r3_fetch() {
local commit_date=${4:-${EGIT_COMMIT_DATE}}
# support new override API for EAPI 6+
- if ! has "${EAPI:-0}" 0 1 2 3 4 5; then
+ if [[ ${EAPI} != 5 ]]; then
# get the name and do some more processing:
# 1) kill .git suffix,
# 2) underscore (remaining) non-variable characters,
diff --git a/eclass/gnuconfig.eclass b/eclass/gnuconfig.eclass
index 173df6fd25e9..58bdcfd660a6 100644
--- a/eclass/gnuconfig.eclass
+++ b/eclass/gnuconfig.eclass
@@ -6,7 +6,7 @@
# Sam James <sam@gentoo.org>
# @AUTHOR:
# Will Woods <wwoods@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: Refresh bundled gnuconfig files (config.guess, config.sub)
# @DESCRIPTION:
# This eclass is used to automatically update files that typically come with
@@ -17,11 +17,8 @@
#
case ${EAPI:-0} in
- 5|6|7)
- ;;
- *)
- die "EAPI ${EAPI} is unsupported!"
- ;;
+ 5|6|7|8) ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
if [[ -z ${_GNUCONFIG_ECLASS} ]] ; then
diff --git a/eclass/libtool.eclass b/eclass/libtool.eclass
index 4565c8a8f6f8..a38f41588289 100644
--- a/eclass/libtool.eclass
+++ b/eclass/libtool.eclass
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: libtool.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 0 1 2 3 4 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: quickly update bundled libtool code
# @DESCRIPTION:
# This eclass patches ltmain.sh distributed with libtoolized packages with the
@@ -18,8 +18,8 @@ if [[ -z ${_LIBTOOL_ECLASS} ]]; then
_LIBTOOL_ECLASS=1
case ${EAPI:-0} in
- 0|1|2|3|4|5|6) DEPEND=">=app-portage/elt-patches-20170815" ;;
- 7) BDEPEND=">=app-portage/elt-patches-20170815" ;;
+ 5|6) DEPEND=">=app-portage/elt-patches-20170815" ;;
+ 7|8) BDEPEND=">=app-portage/elt-patches-20170815" ;;
*) die "${ECLASS}: EAPI ${EAPI} not supported" ;;
esac
@@ -43,7 +43,4 @@ elibtoolize() {
eltpatch "${@}" || die "eltpatch failed"
}
-uclibctoolize() { die "Use elibtoolize"; }
-darwintoolize() { die "Use elibtoolize"; }
-
fi
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index 6ba820229de3..67cad9875a12 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -4,14 +4,14 @@
# @ECLASS: multilib.eclass
# @MAINTAINER:
# toolchain@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: This eclass is for all functions pertaining to handling multilib configurations.
# @DESCRIPTION:
# This eclass is for all functions pertaining to handling multilib configurations.
case ${EAPI:-0} in
# EAPI=0 is still used by crossdev, bug #797367
- [0567]) ;;
+ 0|5|6|7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -519,7 +519,7 @@ multilib_toolchain_setup() {
fi
if [[ ${ABI} != ${DEFAULT_ABI} ]] ; then
- # Back that multilib-ass up so we can restore it later
+ # Backup multilib state so we can restore it later
for v in "${save_restore_variables[@]}" ; do
vv="_abi_saved_${v}"
[[ ${!v+set} == "set" ]] && export ${vv}="${!v}" || unset ${vv}
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 1643f64cab76..563d9deef40b 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -4,7 +4,7 @@
# @ECLASS: toolchain-funcs.eclass
# @MAINTAINER:
# Toolchain Ninjas <toolchain@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 5 6 7 8
# @BLURB: functions to query common info about the toolchain
# @DESCRIPTION:
# The toolchain-funcs aims to provide a complete suite of functions
@@ -15,7 +15,7 @@
case ${EAPI:-0} in
# EAPI=0 is still used by crossdev, bug #797367
- [0567]) ;;
+ 0|5|6|7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
diff --git a/games-strategy/hedgewars/files/hedgewars-1.0.0-fpc-3.2.patch b/games-strategy/hedgewars/files/hedgewars-1.0.0-fpc-3.2.patch
new file mode 100644
index 000000000000..b04dd0b69fa4
--- /dev/null
+++ b/games-strategy/hedgewars/files/hedgewars-1.0.0-fpc-3.2.patch
@@ -0,0 +1,23 @@
+
+# HG changeset patch
+# User alfadur
+# Date 1597053413 -10800
+# Node ID 6832dab555aefa6ef2830d9452a9a88c89299e85
+# Parent eee2b3eff91dec595a7cb486bcfd97036520e971
+workaround for FPC 3.2.0 ICE
+
+diff -r eee2b3eff91d -r 6832dab555ae hedgewars/uWorld.pas
+--- a/hedgewars/uWorld.pas Sun Aug 09 14:43:02 2020 +0200
++++ b/hedgewars/uWorld.pas Mon Aug 10 12:56:53 2020 +0300
+@@ -1168,8 +1168,8 @@
+ procedure ShiftWorld(Dir: LongInt); inline;
+ begin
+ preShiftWorldDx:= WorldDx;
+- WorldDx:= WorldDx + LongInt(Dir * LongInt(playWidth));
+-
++ Dir := Dir * LongInt(playWidth);
++ WorldDx:= WorldDx + Dir;
+ end;
+
+ procedure UnshiftWorld(); inline;
+
diff --git a/games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild b/games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild
index 7f1d4b6f7c5b..766ec2014dc9 100644
--- a/games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild
+++ b/games-strategy/hedgewars/hedgewars-1.0.0-r100.ebuild
@@ -54,6 +54,8 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${P}-qt-5.15.patch"
"${FILESDIR}/${PN}-1.0.0-cmake_lua_version.patch"
+ # http://hg.hedgewars.org/hedgewars/rev/6832dab555ae
+ "${FILESDIR}/${PN}-1.0.0-fpc-3.2.patch"
)
S="${WORKDIR}"/${MY_P}