summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-12-14 05:34:19 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-12-14 05:34:19 +0000
commit1a77fa227bd99345627edcf2c01cf5e2e6b74f86 (patch)
treea96292f7216eb6c703df505b11aecad4d52d12cf
parent2023-12-14 05:03:56 UTC (diff)
parentpython-utils-r1.eclass: fix EclassReservedName (drop obsolete ${EBUILD} old c... (diff)
downloadgentoo-1a77fa227bd99345627edcf2c01cf5e2e6b74f86.tar.gz
gentoo-1a77fa227bd99345627edcf2c01cf5e2e6b74f86.tar.bz2
gentoo-1a77fa227bd99345627edcf2c01cf5e2e6b74f86.zip
Merge updates from master
-rw-r--r--app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild2
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild2
-rw-r--r--eclass/distutils-r1.eclass6
-rw-r--r--eclass/python-utils-r1.eclass24
4 files changed, 12 insertions, 22 deletions
diff --git a/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
index 02746bc07a02..425f585ae197 100644
--- a/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
+++ b/app-admin/gentoo-retirement-scripts/gentoo-retirement-scripts-2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
DESCRIPTION="Scripts to help retiring Gentoo developers"
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
index 3f93f0ced781..95d75fb273cf 100644
--- a/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
+++ b/dev-python/python-bugzilla/python-bugzilla-3.2.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 0a7b18e4a1a4..0a9815f2d459 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -50,6 +50,7 @@ case ${EAPI} in
esac
# @ECLASS_VARIABLE: DISTUTILS_EXT
+# @PRE_INHERIT
# @DEFAULT_UNSET
# @DESCRIPTION:
# Set this variable to a non-null value if the package (possibly
@@ -1806,6 +1807,11 @@ distutils-r1_run_phase() {
tc-export AR CC CPP CXX
if [[ ${DISTUTILS_EXT} ]]; then
+ if [[ ${BDEPEND} == *dev-python/cython* ]] ; then
+ # Workaround for https://github.com/cython/cython/issues/2747 (bug #918983)
+ local -x CFLAGS="${CFLAGS} $(test-flags-CC -Wno-error=incompatible-pointer-types)"
+ fi
+
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
# always generate .c files from .pyx files to ensure we get latest
# bug fixes from Cython (this works only when setup.py is using
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 394f64a5d139..abb55bd2e942 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -153,17 +153,6 @@ _python_set_impls() {
done
fi
- if [[ -n ${obsolete[@]} && ${EBUILD_PHASE} == setup ]]; then
- # complain if people don't clean up old impls while touching
- # the ebuilds recently. use the copyright year to infer last
- # modification
- # NB: this check doesn't have to work reliably
- if [[ $(head -n 1 "${EBUILD}" 2>/dev/null) == *2022* ]]; then
- eqawarn "Please clean PYTHON_COMPAT of obsolete implementations:"
- eqawarn " ${obsolete[*]}"
- fi
- fi
-
local supp=() unsupp=()
for i in "${_PYTHON_ALL_IMPLS[@]}"; do
@@ -1336,15 +1325,8 @@ epytest() {
_python_check_EPYTHON
_python_check_occluded_packages
- local color
- case ${NOCOLOR} in
- true|yes)
- color=no
- ;;
- *)
- color=yes
- ;;
- esac
+ local color=yes
+ [[ ${NO_COLOR} ]] && color=no
local args=(
# verbose progress reporting and tracebacks
@@ -1389,6 +1371,8 @@ epytest() {
-p no:pytest-describe
-p no:plus
-p no:tavern
+ # does something to logging
+ -p no:salt-factories
)
fi