summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-14 21:48:19 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-15 09:37:44 +0300
commit012b51b954636137f315abfd8bd28f9840f8305e (patch)
treea3d8029063a2757d75df030495493d9ee02e4d1d
parentapp-admin/restart-services: update EAPI 6 -> 8 (diff)
downloadgentoo-012b51b954636137f315abfd8bd28f9840f8305e.tar.gz
gentoo-012b51b954636137f315abfd8bd28f9840f8305e.tar.bz2
gentoo-012b51b954636137f315abfd8bd28f9840f8305e.zip
app-admin/sxid: update EAPI 6 -> 8
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/32790 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-admin/sxid/sxid-4.2-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.2-r3.ebuild b/app-admin/sxid/sxid-4.2-r3.ebuild
new file mode 100644
index 000000000000..b62bc5855760
--- /dev/null
+++ b/app-admin/sxid/sxid-4.2-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="suid, sgid file and directory checking"
+HOMEPAGE="https://linukz.org/sxid.shtml https://github.com/taem/sxid"
+SRC_URI="https://linukz.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="selinux"
+
+RDEPEND="
+ virtual/mailx
+ selinux? ( sec-policy/selinux-sxid )
+"
+
+DOCS=( NEWS README docs/sxid.{conf,cron}.example )
+
+src_prepare() {
+ default
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ sed -i 's/bindir/sbindir/g' source/Makefile.in || die
+ sed -i -e 's/configure.in/configure.ac/g' Makefile || die
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "You will need to configure sxid.conf for your system using the manpage and example"
+}