summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2022-08-02 15:02:28 +0200
committerFabian Groffen <grobian@gentoo.org>2022-08-02 15:02:28 +0200
commit84982b6a98984b097e1f155699d269b3dddc7d2a (patch)
tree098a9cd6829f8a10030a76c9466361ad166d27ff /sys-devel
parentdev-libs/xerces-c: drop, version in gx86 should be fine (diff)
downloadprefix-84982b6a98984b097e1f155699d269b3dddc7d2a.tar.gz
prefix-84982b6a98984b097e1f155699d269b3dddc7d2a.tar.bz2
prefix-84982b6a98984b097e1f155699d269b3dddc7d2a.zip
sys-devel/gcc-12.1.0: workaround compilation issue on arm64-darwin
For some reason when flex invokes m4 during bootstrap of gcc, it fails which results in an empty file, causing compilation to fail. This is a really weird issue only happening on arm64/Apple SI, so just use the host flex which seems to work correctly. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-12.1.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-12.1.0.ebuild b/sys-devel/gcc/gcc-12.1.0.ebuild
index 29983dc1e2..590c202d8c 100644
--- a/sys-devel/gcc/gcc-12.1.0.ebuild
+++ b/sys-devel/gcc/gcc-12.1.0.ebuild
@@ -92,6 +92,13 @@ src_configure() {
# use sysroot with the linker, #756160
export gcc_cv_ld_sysroot=yes
;;
+ arm64-*-darwin*)
+ # only supported from darwin21, so no conflict with above
+ # case switch
+ # for the time being use system flex, for our doesn't work
+ # here (while it does fine elsewhere), #778014
+ export ac_cv_prog_FLEX=/usr/bin/flex
+ ;;
*-solaris*)
# todo: some magic for native vs. GNU linking?
myconf+=( --with-gnu-ld --with-gnu-as --enable-largefile )