summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-12-03 16:19:02 +0100
committerFabian Groffen <grobian@gentoo.org>2017-12-03 16:19:02 +0100
commit75173e1f07e816d34bf75066f89265ccda7de1ad (patch)
tree4090f2e85a65b96132ae58e5634b9e31c200fef6 /dev-libs
parentdev-libs/icu: cleanup (diff)
downloadprefix-75173e1f07e816d34bf75066f89265ccda7de1ad.tar.gz
prefix-75173e1f07e816d34bf75066f89265ccda7de1ad.tar.bz2
prefix-75173e1f07e816d34bf75066f89265ccda7de1ad.zip
dev-libs/icu: migrate to gx86
Bug: https://bugs.gentoo.org/458636
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/Manifest1
-rw-r--r--dev-libs/icu/files/icu-58.1-iterator.patch127
-rw-r--r--dev-libs/icu/files/icu-58.1-remove-bashisms.patch224
-rw-r--r--dev-libs/icu/files/icu-58.2-darwin.patch55
-rw-r--r--dev-libs/icu/icu-58.2.ebuild155
-rw-r--r--dev-libs/icu/metadata.xml8
6 files changed, 0 insertions, 570 deletions
diff --git a/dev-libs/icu/Manifest b/dev-libs/icu/Manifest
deleted file mode 100644
index dc6f8971f7..0000000000
--- a/dev-libs/icu/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST icu4c-58_2-src.tgz 23369902 SHA256 2b0a4410153a9b20de0e20c7d8b66049a72aef244b53683d0d7521371683da0c SHA512 5c21af748f48b392e6c0412bd0aee92162ea931820dcbfab4ec6e0299868504b303d88f7586cc95de55c777ac0dca3a29d6c8ca0892c646ebc864c8a5b5a162a WHIRLPOOL 25829f8ee870b703fd604ae5b9b584390a142f5011e2a5db18332453e2f1640d81270086f243318eeb93f187b04ea23dab14901ab81c8d924c8d47b1f77aee5a
diff --git a/dev-libs/icu/files/icu-58.1-iterator.patch b/dev-libs/icu/files/icu-58.1-iterator.patch
deleted file mode 100644
index 6f52375eb7..0000000000
--- a/dev-libs/icu/files/icu-58.1-iterator.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-source: http://bugs.icu-project.org/trac/changeset/39484/
-
-
-Index: icu/common/ulist.c
-===================================================================
---- icu/common/ulist.c (revision 39483)
-+++ icu/common/ulist.c (revision 39484)
-@@ -30,5 +30,4 @@
-
- int32_t size;
-- int32_t currentIndex;
- };
-
-@@ -52,5 +51,4 @@
- newList->tail = NULL;
- newList->size = 0;
-- newList->currentIndex = -1;
-
- return newList;
-@@ -81,6 +79,7 @@
- p->next->previous = p->previous;
- }
-- list->curr = NULL;
-- list->currentIndex = 0;
-+ if (p == list->curr) {
-+ list->curr = p->next;
-+ }
- --list->size;
- if (p->forceDelete) {
-@@ -151,5 +150,4 @@
- list->head->previous = newItem;
- list->head = newItem;
-- list->currentIndex++;
- }
-
-@@ -194,5 +192,4 @@
- curr = list->curr;
- list->curr = curr->next;
-- list->currentIndex++;
-
- return curr->data;
-@@ -210,5 +207,4 @@
- if (list != NULL) {
- list->curr = list->head;
-- list->currentIndex = 0;
- }
- }
-@@ -273,3 +269,2 @@
- return (UList *)(en->context);
- }
--
-Index: icu/i18n/ucol_res.cpp
-===================================================================
---- icu/i18n/ucol_res.cpp (revision 39483)
-+++ icu/i18n/ucol_res.cpp (revision 39484)
-@@ -681,4 +681,5 @@
- }
- memcpy(en, &defaultKeywordValues, sizeof(UEnumeration));
-+ ulist_resetList(sink.values); // Initialize the iterator.
- en->context = sink.values;
- sink.values = NULL; // Avoid deletion in the sink destructor.
-Index: icu/test/intltest/apicoll.cpp
-===================================================================
---- icu/test/intltest/apicoll.cpp (revision 39483)
-+++ icu/test/intltest/apicoll.cpp (revision 39484)
-@@ -82,14 +82,7 @@
- col = Collator::createInstance(Locale::getEnglish(), success);
- if (U_FAILURE(success)){
-- errcheckln(success, "Default Collator creation failed. - %s", u_errorName(success));
-- return;
-- }
--
-- StringEnumeration* kwEnum = col->getKeywordValuesForLocale("", Locale::getEnglish(),true,success);
-- if (U_FAILURE(success)){
-- errcheckln(success, "Get Keyword Values for Locale failed. - %s", u_errorName(success));
-- return;
-- }
-- delete kwEnum;
-+ errcheckln(success, "English Collator creation failed. - %s", u_errorName(success));
-+ return;
-+ }
-
- col->getVersion(versionArray);
-@@ -230,4 +223,27 @@
- delete aFrCol;
- delete junk;
-+}
-+
-+void CollationAPITest::TestKeywordValues() {
-+ IcuTestErrorCode errorCode(*this, "TestKeywordValues");
-+ LocalPointer<Collator> col(Collator::createInstance(Locale::getEnglish(), errorCode));
-+ if (errorCode.logIfFailureAndReset("English Collator creation failed")) {
-+ return;
-+ }
-+
-+ LocalPointer<StringEnumeration> kwEnum(
-+ col->getKeywordValuesForLocale("collation", Locale::getEnglish(), TRUE, errorCode));
-+ if (errorCode.logIfFailureAndReset("Get Keyword Values for English Collator failed")) {
-+ return;
-+ }
-+ assertTrue("expect at least one collation tailoring for English", kwEnum->count(errorCode) > 0);
-+ const char *kw;
-+ UBool hasStandard = FALSE;
-+ while ((kw = kwEnum->next(NULL, errorCode)) != NULL) {
-+ if (strcmp(kw, "standard") == 0) {
-+ hasStandard = TRUE;
-+ }
-+ }
-+ assertTrue("expect at least the 'standard' collation tailoring for English", hasStandard);
- }
-
-@@ -2467,4 +2483,5 @@
- TESTCASE_AUTO_BEGIN;
- TESTCASE_AUTO(TestProperty);
-+ TESTCASE_AUTO(TestKeywordValues);
- TESTCASE_AUTO(TestOperators);
- TESTCASE_AUTO(TestDuplicate);
-Index: icu/test/intltest/apicoll.h
-===================================================================
---- icu/test/intltest/apicoll.h (revision 39483)
-+++ icu/test/intltest/apicoll.h (revision 39484)
-@@ -36,4 +36,5 @@
- */
- void TestProperty(/* char* par */);
-+ void TestKeywordValues();
-
- /**
diff --git a/dev-libs/icu/files/icu-58.1-remove-bashisms.patch b/dev-libs/icu/files/icu-58.1-remove-bashisms.patch
deleted file mode 100644
index ef60ce4569..0000000000
--- a/dev-libs/icu/files/icu-58.1-remove-bashisms.patch
+++ /dev/null
@@ -1,224 +0,0 @@
-diff -ruN a/config/Makefile.inc.in b/config/Makefile.inc.in
---- a/config/Makefile.inc.in 2016-09-09 23:28:18.000000000 +0200
-+++ b/config/Makefile.inc.in 2016-11-05 19:43:07.688466668 +0100
-@@ -124,12 +124,6 @@
- # with usually. Many applications will want to add $(ICULIBS_I18N) as well.
- ICULIBS = $(ICULIBS_BASE) $(ICULIBS_I18N) $(ICULIBS_COMMON) $(ICULIBS_DATA)
-
--# Proper echo newline handling is needed in icu-config
--ECHO_N=@ICU_ECHO_N@
--ECHO_C=@ICU_ECHO_C@
--# Not currently being used but good to have for proper tab handling
--ECHO_T=@ICU_ECHO_T@
--
- ##################################################################
- ##################################################################
- #
-diff -ruN a/config/icu-config-bottom b/config/icu-config-bottom
---- a/config/icu-config-bottom 2016-09-09 23:28:18.000000000 +0200
-+++ b/config/icu-config-bottom 2016-11-05 19:49:00.854481361 +0100
-@@ -218,65 +218,65 @@
- ;;
-
- --cflags)
-- echo $ECHO_N "${CFLAGS} ${ECHO_C}"
-+ printf "%s" "${CFLAGS} "
- ;;
-
- --cc)
-- echo $ECHO_N "${CC} ${ECHO_C}"
-+ printf "%s" "${CC} "
- ;;
-
- --cxx)
-- echo $ECHO_N "${CXX} ${ECHO_C}"
-+ printf "%s" "${CXX} "
- ;;
-
- --cxxflags)
-- echo $ECHO_N "${CXXFLAGS} ${ECHO_C}"
-+ printf "%s" "${CXXFLAGS} "
- ;;
-
- --cppflags)
- # Don't echo the -I. - it's unneeded.
-- echo $ECHO_N "${CPPFLAGS} ${ECHO_C}" | sed -e 's/-I. //'
-+ printf "%s" "${CPPFLAGS} " | sed -e 's/-I. //'
- ;;
-
- --cppflags-searchpath)
-- echo $ECHO_N "-I${prefix}/include ${ECHO_C}"
-+ printf "%s" "-I${prefix}/include "
- ;;
-
- --cppflags-dynamic)
-- echo $ECHO_N "${SHAREDLIBCPPFLAGS} ${ECHO_C}"
-+ printf "%s" "${SHAREDLIBCPPFLAGS} "
- ;;
-
- --cxxflags-dynamic)
-- echo $ECHO_N "${SHAREDLIBCXXFLAGS} ${ECHO_C}"
-+ printf "%s" "${SHAREDLIBCXXFLAGS} "
- ;;
-
- --cflags-dynamic)
-- echo $ECHO_N "${SHAREDLIBCFLAGS} ${ECHO_C}"
-+ printf "%s" "${SHAREDLIBCFLAGS} "
- ;;
-
- --ldflags-system)
-- echo $ECHO_N "${LIBS} ${ECHO_C}"
-+ printf "%s" "${LIBS} "
- ;;
-
- --ldflags)
-- echo $ECHO_N "${LDFLAGS} ${ICULIBS} ${ECHO_C}"
-+ printf "%s" "${LDFLAGS} ${ICULIBS} "
- # $RPATH_LDFLAGS
- ;;
-
- --ldflags-libsonly)
-- echo $ECHO_N "${ICULIBS_I18N} ${ICULIBS_COMMON} ${ICULIBS_DATA} ${ECHO_C}"
-+ printf "%s" "${ICULIBS_I18N} ${ICULIBS_COMMON} ${ICULIBS_DATA} "
- ;;
-
- --ldflags-icuio)
-- echo $ECHO_N " ${ICULIBS_ICUIO} ${ECHO_C}"
-+ printf "%s" " ${ICULIBS_ICUIO} "
- ;;
-
- --ldflags-obsolete)
-- echo $ECHO_N "${ICULIBS_OBSOLETE} ${ECHO_C}"
-+ printf "%s" "${ICULIBS_OBSOLETE} "
- ;;
-
- --ldflags-toolutil)
-- echo $ECHO_N " ${ICULIBS_TOOLUTIL} ${ECHO_C}"
-+ printf "%s" " ${ICULIBS_TOOLUTIL} "
- ;;
-
- --ldflags-layout)
-@@ -285,7 +285,7 @@
- ;;
-
- --ldflags-searchpath)
-- echo $ECHO_N "-L${libdir} ${ECHO_C}"
-+ printf "%s" "-L${libdir} "
- ;;
-
- --detect-prefix)
-@@ -321,47 +321,47 @@
- ;;
-
- --shared-datadir)
-- echo $ECHO_N "${datadir} ${ECHO_C}"
-+ printf "%s" "${datadir} "
- ;;
-
- --incfile)
-- echo $ECHO_N "${pkglibdir}/Makefile.inc ${ECHO_C}"
-+ printf "%s" "${pkglibdir}/Makefile.inc "
- ;;
-
- --incpkgdatafile)
-- echo $ECHO_N "${pkglibdir}/pkgdata.inc ${ECHO_C}"
-+ printf "%s" "${pkglibdir}/pkgdata.inc "
- ;;
-
- --icudata)
-- echo $ECHO_N "${ICUDATA_NAME} ${ECHO_C}"
-+ printf "%s" "${ICUDATA_NAME} "
- ;;
-
- --icudata-mode)
-- echo $ECHO_N "${PKGDATA_MODE} ${ECHO_C}"
-+ printf "%s" "${PKGDATA_MODE} "
- ;;
-
- --icudata-install-dir)
-- echo $ECHO_N "${ICUPKGDATA_DIR} ${ECHO_C}"
-+ printf "%s" "${ICUPKGDATA_DIR} "
- ;;
-
- --icudatadir)
-- echo $ECHO_N "${ICUDATA_DIR} ${ECHO_C}"
-+ printf "%s" "${ICUDATA_DIR} "
- ;;
-
- --shlib-c)
-- echo $ECHO_N "${SHLIB_c} ${ECHO_C}"
-+ printf "%s" "${SHLIB_c} "
- ;;
-
- --shlib-cc)
-- echo $ECHO_N "${SHLIB_cc} ${ECHO_C}"
-+ printf "%s" "${SHLIB_cc} "
- ;;
-
- --version)
-- echo $ECHO_N $VERSION
-+ printf "%s" "$VERSION"
- ;;
-
- --unicode-version)
-- echo $ECHO_N $UNICODE_VERSION
-+ printf "%s" "$UNICODE_VERSION"
- ;;
-
- --host)
-diff -ruN a/configure.ac b/configure.ac
---- a/configure.ac 2016-10-04 21:30:20.000000000 +0200
-+++ b/configure.ac 2016-11-05 19:43:07.688466668 +0100
-@@ -22,24 +22,6 @@
- PACKAGE="icu"
- AC_SUBST(PACKAGE)
-
--# Use custom echo test for newline option
--# Current autoconf (2.65) gives incorrect echo newline option
--# for icu-config
--# This may be removed later - mow (June 17, 2010)
--ICU_ECHO_C= ICU_ECHO_N= ICU_ECHO_T=
--case `/bin/sh -c "echo -n x"` in
---n*)
-- case `/bin/sh -c "echo 'x\c'"` in
-- *c*) ICU_ECHO_T=' ';; # ECHO_T is single tab character.
-- *) ICU_ECHO_C='\c';;
-- esac;;
--*)
-- ICU_ECHO_N='-n';;
--esac
--AC_SUBST(ICU_ECHO_N)
--AC_SUBST(ICU_ECHO_C)
--AC_SUBST(ICU_ECHO_T)
--
- AC_MSG_CHECKING(for ICU version numbers)
-
- # Get the ICU version from uversion.h or other headers
-diff -ruN a/icudefs.mk.in b/icudefs.mk.in
---- a/icudefs.mk.in 2016-09-09 23:28:18.000000000 +0200
-+++ b/icudefs.mk.in 2016-11-05 19:43:07.688466668 +0100
-@@ -157,11 +157,6 @@
- ENABLE_STATIC = @ENABLE_STATIC@
- ENABLE_SHARED = @ENABLE_SHARED@
-
--# Echo w/o newline
--
--#ECHO_N = @ICU_ECHO_N@
--#ECHO_C = @ICU_ECHO_C@
--
- # Commands to compile
- COMPILE.c= $(CC) $(CPPFLAGS) $(DEFS) $(CFLAGS) -c
- COMPILE.cc= $(CXX) $(CPPFLAGS) $(DEFS) $(CXXFLAGS) -c
-diff -ruN a/test/hdrtst/Makefile.in b/test/hdrtst/Makefile.in
---- a/test/hdrtst/Makefile.in 2016-09-28 06:17:24.000000000 +0200
-+++ b/test/hdrtst/Makefile.in 2016-11-05 19:43:07.688466668 +0100
-@@ -35,9 +35,6 @@
- include $(shell icu-config --incfile)
- DIRS=$(prefix)/include/unicode
- LDIRS=$(prefix)/include/layout
--ECHO_T=@ECHO_T@
--ECHO_C=@ECHO_C@
--ECHO_N=@ECHO_N@
-
- all:
- @echo Please read this Makefile for more information.
diff --git a/dev-libs/icu/files/icu-58.2-darwin.patch b/dev-libs/icu/files/icu-58.2-darwin.patch
deleted file mode 100644
index e5a9000a34..0000000000
--- a/dev-libs/icu/files/icu-58.2-darwin.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-same as 4.7, but retargetted to apply with eapply
-
---- a/config/mh-darwin
-+++ b/config/mh-darwin
-@@ -4,6 +4,13 @@
- ## Copyright (c) 1999-2011 International Business Machines Corporation and
- ## others. All Rights Reserved.
-
-+
-+SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO)
-+FINAL_SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO_TARGET_VERSION).$(SO)
-+MIDDLE_SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO_TARGET_VERSION_MAJOR).$(SO)
-+
-+IS_DARWIN = yes
-+
- ## Flags for position independent code
- SHAREDLIBCFLAGS = -dynamic
- SHAREDLIBCXXFLAGS = -dynamic
-@@ -28,7 +35,7 @@
- ifeq ($(ENABLE_RPATH),YES)
- LD_SONAME = -Wl,-compatibility_version -Wl,$(SO_TARGET_VERSION_MAJOR) -Wl,-current_version -Wl,$(SO_TARGET_VERSION) -install_name $(libdir)/$(notdir $(MIDDLE_SO_TARGET))
- else
--LD_SONAME = -Wl,-compatibility_version -Wl,$(SO_TARGET_VERSION_MAJOR) -Wl,-current_version -Wl,$(SO_TARGET_VERSION) -install_name $(notdir $(MIDDLE_SO_TARGET))
-+LD_SONAME = -Wl,-compatibility_version -Wl,$(SO_TARGET_VERSION_MAJOR) -Wl,-current_version -Wl,$(SO_TARGET_VERSION) -install_name $(libdir)/$(notdir $(MIDDLE_SO_TARGET))
- endif
-
- ## Compiler switch to embed a runtime search path
---- a/stubdata/Makefile.in
-+++ b/stubdata/Makefile.in
-@@ -32,7 +32,11 @@
-
-
- ifneq ($(ENABLE_SHARED),)
-+ifeq ($(IS_DARWIN),)
- SO_TARGET = $(STUBDATA_LIBDIR)$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX)$(STUB_SUFFIX).$(SO)
-+else
-+SO_TARGET = $(LIBDIR)/$(STUBDATA_LIBDIR)$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX)$(STUB_SUFFIX).$(SO)
-+endif
- ALL_SO_TARGETS = $(FINAL_SO_TARGET) $(MIDDLE_SO_TARGET) $(SO_TARGET) $(BATCH_STUB_TARGET) $(SHARED_OBJECT)
- endif
-
---- a/tools/ctestfw/Makefile.in
-+++ b/tools/ctestfw/Makefile.in
-@@ -31,7 +31,11 @@
- endif
-
- ifneq ($(ENABLE_SHARED),)
-+ifeq ($(IS_DARWIN),)
- SO_TARGET = $(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO)
-+else
-+SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO)
-+endif
- ALL_SO_TARGETS = $(SO_TARGET) $(MIDDLE_SO_TARGET) $(FINAL_SO_TARGET) $(SHARED_OBJECT)
- endif
-
diff --git a/dev-libs/icu/icu-58.2.ebuild b/dev-libs/icu/icu-58.2.ebuild
deleted file mode 100644
index b046626072..0000000000
--- a/dev-libs/icu/icu-58.2.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils flag-o-matic toolchain-funcs autotools multilib-minimal
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-
-SLOT="0/${PV}"
-
-KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="debug doc examples static-libs"
-
-DEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen[dot]
- )
-"
-
-S="${WORKDIR}/${PN}/source"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/icu-config
-)
-
-PATCHES=(
- "${FILESDIR}/${PN}-58.1-remove-bashisms.patch"
- "${FILESDIR}/${PN}-58.1-iterator.patch"
- "${FILESDIR}/${PN}-58.2-darwin.patch"
-)
-
-src_prepare() {
- # apply patches
- default
-
- local variable
-
- # Disable renaming as it is stupid thing to do
- sed -i \
- -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
- common/unicode/uconfig.h || die
-
- # Fix linking of icudata
- sed -i \
- -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
- config/mh-linux || die
-
- # Append doxygen configuration to configure
- sed -i \
- -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
- configure.ac || die
-
- # Fix compilation on Solaris due to enabling of conflicting standards
- if [[ ${CHOST} == *-solaris* ]] ; then
- sed -i -e '/define _XOPEN_SOURCE_EXTENDED/s/_XOPEN/no_XOPEN/' \
- common/uposixdefs.h || die
- fi
-
- eautoreconf
-}
-
-src_configure() {
- # Use C++14
- append-cxxflags -std=c++14
-
- if tc-is-cross-compiler; then
- mkdir "${WORKDIR}"/host || die
- pushd "${WORKDIR}"/host >/dev/null || die
-
- CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
- RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
- "${S}"/configure --disable-renaming --disable-debug \
- --disable-samples --enable-static || die
- emake
-
- popd >/dev/null || die
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-renaming
- --disable-samples
- --disable-layoutex
- $(use_enable debug)
- $(use_enable static-libs static)
- )
-
- multilib_is_native_abi && myeconfargs+=(
- $(use_enable examples samples)
- )
- tc-is-cross-compiler && myeconfargs+=(
- --with-cross-build="${WORKDIR}"/host
- )
-
- # icu tries to use clang by default
- tc-export CC CXX
-
- # make sure we configure with the same shell as we run icu-config
- # with, or ECHO_N, ECHO_T and ECHO_C will be wrongly defined
- export CONFIG_SHELL=${EPREFIX}/bin/sh
- # probably have no /bin/sh in prefix-chain
- [[ -x ${CONFIG_SHELL} ]] || CONFIG_SHELL=${BASH}
-
- ECONF_SOURCE=${S} \
- econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc; then
- doxygen -u Doxyfile || die
- doxygen Doxyfile || die
- fi
-}
-
-multilib_src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 VERBOSE="1" check
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc; then
- docinto html
- dodoc -r doc/html/*
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
- docinto html
- dodoc ../readme.html
-}
diff --git a/dev-libs/icu/metadata.xml b/dev-libs/icu/metadata.xml
deleted file mode 100644
index 13ce236ee5..0000000000
--- a/dev-libs/icu/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>office@gentoo.org</email>
- <name>Gentoo Office project</name>
- </maintainer>
-</pkgmetadata>