aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-10-18 07:57:11 -0700
committerorbea <orbea@riseup.net>2024-10-18 07:57:11 -0700
commit83f564b52ab77d05cc1982cc1d177119a274e561 (patch)
treeb3abfd5bf95ca96a0b22aab07cbbbe04e8507a40
parentdev-lang/python: stabilize 3.12.6_p4 for arm64 (diff)
downloadlibressl-83f564b52ab77d05cc1982cc1d177119a274e561.tar.gz
libressl-83f564b52ab77d05cc1982cc1d177119a274e561.tar.bz2
libressl-83f564b52ab77d05cc1982cc1d177119a274e561.zip
dev-lang/python: sync ::gentoo
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-lang/python/python-3.10.15_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.11.10_p1.ebuild2
-rw-r--r--dev-lang/python/python-3.9.20_p1.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.10.15_p1.ebuild b/dev-lang/python/python-3.10.15_p1.ebuild
index aa52615..524ba7d 100644
--- a/dev-lang/python/python-3.10.15_p1.ebuild
+++ b/dev-lang/python/python-3.10.15_p1.ebuild
@@ -460,6 +460,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -494,6 +495,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.11.10_p1.ebuild b/dev-lang/python/python-3.11.10_p1.ebuild
index 0e85bc6..391f85a 100644
--- a/dev-lang/python/python-3.11.10_p1.ebuild
+++ b/dev-lang/python/python-3.11.10_p1.ebuild
@@ -473,6 +473,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -512,6 +513,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
diff --git a/dev-lang/python/python-3.9.20_p1.ebuild b/dev-lang/python/python-3.9.20_p1.ebuild
index 28ff5c1..baa948e 100644
--- a/dev-lang/python/python-3.9.20_p1.ebuild
+++ b/dev-lang/python/python-3.9.20_p1.ebuild
@@ -449,6 +449,7 @@ src_compile() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
fi
# also need to clear the flags explicitly here or they end up
@@ -483,6 +484,7 @@ src_test() {
# bug 660358
local -x COLUMNS=80
local -x PYTHONDONTWRITEBYTECODE=
+ local -x TMPDIR=/tmp
nonfatal emake -Onone test EXTRATESTOPTS="${test_opts[*]}" \
CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty