aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/sfwbar/sfwbar-1.0_beta12.ebuild')
-rw-r--r--gui-apps/sfwbar/sfwbar-1.0_beta12.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/gui-apps/sfwbar/sfwbar-1.0_beta12.ebuild b/gui-apps/sfwbar/sfwbar-1.0_beta12.ebuild
deleted file mode 100644
index cbcc01884..000000000
--- a/gui-apps/sfwbar/sfwbar-1.0_beta12.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson xdg
-
-DESCRIPTION="S* Floating Window Bar"
-HOMEPAGE="https://github.com/LBCrion/sfwbar"
-SRC_URI="https://github.com/LBCrion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="X mpd pulseaudio alsa"
-
-COMMON_DEPEND="
- dev-libs/glib:2
- dev-libs/json-c:=
- dev-libs/wayland
- gui-libs/gtk-layer-shell
- >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
- X? ( x11-libs/libxkbcommon )
- mpd? ( media-libs/libmpdclient )
- pulseaudio? ( media-libs/libpulse[glib] )
- alsa? ( media-libs/alsa-lib )
-"
-RDEPEND="${COMMON_DEPEND}
- virtual/freedesktop-icon-theme
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-libs/wayland-protocols-1.17
-"
-BDEPEND="dev-util/wayland-scanner"
-
-src_configure() {
- local emesonargs=(
- $(meson_feature mpd)
- $(meson_feature pulseaudio pulse)
- $(meson_feature X xkb)
- -Dnetwork=enabled
- -Dbsdctl=disabled
- )
-
- meson_src_configure
-}