aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/koi/koi-0.3.1.ebuild')
-rw-r--r--gui-apps/koi/koi-0.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/gui-apps/koi/koi-0.3.1.ebuild b/gui-apps/koi/koi-0.3.1.ebuild
new file mode 100644
index 000000000..af46f4d37
--- /dev/null
+++ b/gui-apps/koi/koi-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Theme scheduling for the KDE Plasma Desktop"
+HOMEPAGE="https://github.com/baduhai/Koi"
+SRC_URI="
+ https://github.com/baduhai/Koi/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/Koi-${PV}/src"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml]
+ kde-frameworks/kconfigwidgets:6
+ kde-frameworks/kconfig:6
+ kde-frameworks/kcoreaddons:6
+ kde-frameworks/kwidgetsaddons:6
+"
+RDEPEND="${DEPEND}
+"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules
+"