aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/tealdeer')
-rw-r--r--app-misc/tealdeer/tealdeer-1.5.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-misc/tealdeer/tealdeer-1.5.0.ebuild b/app-misc/tealdeer/tealdeer-1.5.0.ebuild
index a72322781..43664c7dd 100644
--- a/app-misc/tealdeer/tealdeer-1.5.0.ebuild
+++ b/app-misc/tealdeer/tealdeer-1.5.0.ebuild
@@ -186,7 +186,7 @@ xdg-2.4.0
zip-0.5.13
"
-inherit cargo bash-completion-r1
+inherit cargo flag-o-matic bash-completion-r1
DESCRIPTION="A very fast implementation of tldr in Rust."
HOMEPAGE="https://github.com/tldr-pages/tldr
@@ -199,6 +199,7 @@ SLOT="0"
KEYWORDS="~amd64"
RDEPEND="!app-text/tldr"
+BDEPEND=">=virtual/rust-1.54.0"
QA_FLAGS_IGNORED="usr/bin/tldr"
@@ -206,6 +207,11 @@ QA_FLAGS_IGNORED="usr/bin/tldr"
RESTRICT="test"
PROPERTIES="test_network"
+src_configure() {
+ filter-flags '-flto*' # ring crate fails compile with lto
+ cargo_src_configure
+}
+
src_install() {
cargo_src_install
einstalldocs