aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/blahaj/blahaj-2.2.0-r1.ebuild')
-rw-r--r--app-misc/blahaj/blahaj-2.2.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/blahaj/blahaj-2.2.0-r1.ebuild b/app-misc/blahaj/blahaj-2.2.0-r1.ebuild
new file mode 100644
index 000000000..393915bf2
--- /dev/null
+++ b/app-misc/blahaj/blahaj-2.2.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit shards
+
+DESCRIPTION="Gay sharks at your local terminal"
+HOMEPAGE="https://github.com/GeopJr/BLAHAJ"
+SRC_URI="https://github.com/GeopJr/BLAHAJ/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^^}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/boehm-gc
+ dev-libs/libevent
+ dev-libs/libpcre2
+ dev-libs/libyaml
+"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+ shards_src_install
+ dobin ${PN}
+}