aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/cpptoml/Manifest1
-rw-r--r--dev-cpp/cpptoml/cpptoml-0.1.1.ebuild28
-rw-r--r--dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch15
-rw-r--r--dev-cpp/cpptoml/metadata.xml18
4 files changed, 0 insertions, 62 deletions
diff --git a/dev-cpp/cpptoml/Manifest b/dev-cpp/cpptoml/Manifest
deleted file mode 100644
index 138b26fec..000000000
--- a/dev-cpp/cpptoml/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cpptoml-0.1.1.tar.gz 47398 BLAKE2B c0ce036bec4731c4dfe96d01076b9ca18a1c4108180d5dbc839dfc44b37eb0c7af85f685a6356ef92fa684219e2883dd341e64a2012505dacc3df73dfb9e28ca SHA512 14edce576514d53a7e13562d7f8d2b66ea2b95f44038396c0e26232ec81783042ebecec31ee272a99afef96d5c8582a8e81ea5167a787844b98de6ee6f545cc5
diff --git a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild b/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
deleted file mode 100644
index 4bae4abcb..000000000
--- a/dev-cpp/cpptoml/cpptoml-0.1.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Header-only library for parsing TOML"
-HOMEPAGE="https://github.com/skystrife/cpptoml"
-SRC_URI="https://github.com/skystrife/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="libcxx examples"
-
-RDEPEND="libcxx? ( sys-libs/libcxx )"
-DEPEND="${RDEPEND}"
-
-PATCHES="${FILESDIR}/${P}-limits.patch"
-
-src_configure() {
- local mycmakeargs=(
- -DCPPTOML_BUILD_EXAMPLES=$(usex examples)
- -DENABLE_LIBCXX=$(usex libcxx)
- )
- cmake_src_configure
-}
diff --git a/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch b/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
deleted file mode 100644
index 484f98044..000000000
--- a/dev-cpp/cpptoml/files/cpptoml-0.1.1-limits.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From c55a516e90133d89d67285429c6474241346d27a Mon Sep 17 00:00:00 2001
-From: Dirk Eddelbuettel <edd@debian.org>
-Date: Mon, 30 Nov 2020 09:41:49 -0600
-Subject: [PATCH] g++-11 requires limits header
-
---- a/include/cpptoml.h
-+++ b/include/cpptoml.h
-@@ -14,6 +14,7 @@
- #include <cstring>
- #include <fstream>
- #include <iomanip>
-+#include <limits>
- #include <map>
- #include <memory>
- #include <sstream>
diff --git a/dev-cpp/cpptoml/metadata.xml b/dev-cpp/cpptoml/metadata.xml
deleted file mode 100644
index bfae0bb6d..000000000
--- a/dev-cpp/cpptoml/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <longdescription lang="en">
-A header-only library for parsing TOML configuration files.
-
-Targets: TOML v0.5.0 as of August 2018.
-
-This includes support for the new DateTime format, inline tables, multi-line basic and raw strings, digit separators, hexadecimal integers, octal integers, binary integers, and float special values.
- </longdescription>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">ddemidov/vexcl</remote-id>
- </upstream>
- <use>
- <flag name="libcxx">Use libc++ for the C++ standard library</flag>
- </use>
-</pkgmetadata>