aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-08-22 19:21:19 +0200
committerGerben Jan Dijkman <gjdijkman@gjdwebserver.nl>2021-08-22 19:21:25 +0200
commit0e2df95027a2ed8c11d42b06dd4972de5e563f6a (patch)
tree45bff7c7db775b08977061d32e2ea4d4fb9f7030 /x11-wm
parentapp-misc/dragon: die on failed sed (diff)
downloadguru-0e2df95027a2ed8c11d42b06dd4972de5e563f6a.tar.gz
guru-0e2df95027a2ed8c11d42b06dd4972de5e563f6a.tar.bz2
guru-0e2df95027a2ed8c11d42b06dd4972de5e563f6a.zip
x11-wm/phoc: Fixed package
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Gerben jan Dijkman <gjdijkman@gjdwebserver.nl>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/phoc/files/Revert-layer-shell-error-on-0-dimension-without-anchors.diff42
-rw-r--r--x11-wm/phoc/files/xcursor-fix-false-positive-stringop-truncation.diff21
-rw-r--r--x11-wm/phoc/metadata.xml14
-rw-r--r--x11-wm/phoc/phoc-0.8.0.ebuild15
4 files changed, 84 insertions, 8 deletions
diff --git a/x11-wm/phoc/files/Revert-layer-shell-error-on-0-dimension-without-anchors.diff b/x11-wm/phoc/files/Revert-layer-shell-error-on-0-dimension-without-anchors.diff
new file mode 100644
index 000000000..be1eeb571
--- /dev/null
+++ b/x11-wm/phoc/files/Revert-layer-shell-error-on-0-dimension-without-anchors.diff
@@ -0,0 +1,42 @@
+From: =?utf-8?q?Guido_G=C3=BCnther?= <agx@sigxcpu.org>
+Date: Fri, 1 Jan 2021 13:58:55 +0100
+Subject: Revert "layer-shell: error on 0 dimension without anchors"
+
+This reverts commit 8dec751a6d84335fb04288b8efab6dd5c90288d3.
+
+Revert this until phosh has a fixed release.
+---
+ types/wlr_layer_shell_v1.c | 20 --------------------
+ 1 file changed, 20 deletions(-)
+
+diff --git a/types/wlr_layer_shell_v1.c b/types/wlr_layer_shell_v1.c
+index bc68111..d83b22b 100644
+--- a/types/wlr_layer_shell_v1.c
++++ b/types/wlr_layer_shell_v1.c
+@@ -307,26 +307,6 @@ static void layer_surface_role_commit(struct wlr_surface *wlr_surface) {
+ return;
+ }
+
+- const uint32_t horiz = ZWLR_LAYER_SURFACE_V1_ANCHOR_LEFT |
+- ZWLR_LAYER_SURFACE_V1_ANCHOR_RIGHT;
+- if (surface->client_pending.desired_width == 0 &&
+- (surface->client_pending.anchor & horiz) != horiz) {
+- wl_resource_post_error(surface->resource,
+- ZWLR_LAYER_SURFACE_V1_ERROR_INVALID_SIZE,
+- "width 0 requested without setting left and right anchors");
+- return;
+- }
+-
+- const uint32_t vert = ZWLR_LAYER_SURFACE_V1_ANCHOR_TOP |
+- ZWLR_LAYER_SURFACE_V1_ANCHOR_BOTTOM;
+- if (surface->client_pending.desired_height == 0 &&
+- (surface->client_pending.anchor & vert) != vert) {
+- wl_resource_post_error(surface->resource,
+- ZWLR_LAYER_SURFACE_V1_ERROR_INVALID_SIZE,
+- "height 0 requested without setting top and bottom anchors");
+- return;
+- }
+-
+ if (surface->closed) {
+ // Ignore commits after the compositor has closed it
+ return;
diff --git a/x11-wm/phoc/files/xcursor-fix-false-positive-stringop-truncation.diff b/x11-wm/phoc/files/xcursor-fix-false-positive-stringop-truncation.diff
new file mode 100644
index 000000000..d08b859a3
--- /dev/null
+++ b/x11-wm/phoc/files/xcursor-fix-false-positive-stringop-truncation.diff
@@ -0,0 +1,21 @@
+Description: xcursor: strncpy truncation warning with GCC 10 on s390x
+ Fix false positive stringop-truncation warning/error with GCC 10 on s390x
+ .
+Author: Lukas Märdian <slyon@ubuntu.com>
+Bug: https://github.com/swaywm/wlroots/issues/2018
+Last-Update: 2021-03-03
+---
+--- wlroots-0.12.0.orig/xcursor/xcursor.c
++++ wlroots-0.12.0/xcursor/xcursor.c
+@@ -655,8 +655,11 @@ _XcursorAddPathElt (char *path, const ch
+ elt++;
+ len--;
+ }
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wstringop-truncation"
+ strncpy (path + pathlen, elt, len);
+ path[pathlen + len] = '\0';
++#pragma GCC diagnostic pop
+ }
+
+ static char *
diff --git a/x11-wm/phoc/metadata.xml b/x11-wm/phoc/metadata.xml
index b372191c7..d495e34d9 100644
--- a/x11-wm/phoc/metadata.xml
+++ b/x11-wm/phoc/metadata.xml
@@ -1,5 +1,15 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gjdijkman@gjdwebserver.nl</email>
+ <name>Gerben Jan Dijkman</name>
+ </maintainer>
+ <longdescription lang="en">
+ Wayland compositor for mobile phones like the Librem 5.
+ </longdescription>
+ <upstream>
+ <doc>https://source.puri.sm/Librem5/phoc</doc>
+ <bugs-to>https://source.puri.sm/Librem5/phoc/-/issues</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/x11-wm/phoc/phoc-0.8.0.ebuild b/x11-wm/phoc/phoc-0.8.0.ebuild
index cda542c9d..0b27e0c08 100644
--- a/x11-wm/phoc/phoc-0.8.0.ebuild
+++ b/x11-wm/phoc/phoc-0.8.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson vala xdg
+inherit meson vala xdg gnome2-utils
MY_PV="v${PV}"
MY_P="${PN}-${MY_PV}"
@@ -12,7 +12,7 @@ WL_PV="0.12.0"
WL_P="wlroots-${WL_PV}"
DESCRIPTION="Wlroots based Phone compositor"
-HOMEPAGE="https://source.puri.sm/Librem5/phoc"
+HOMEPAGE="https://gitlab.gnome.org/World/Phosh/phoc"
# we don't use the version on gentoo because it breaks
# the phoc installation. we follow method used in archlinuxarm
@@ -51,7 +51,6 @@ BDEPEND="
virtual/pkgconfig
x11-base/xorg-server
"
-
PATCHES=(
"${FILESDIR}/0001-seat-Don-t-notify-on-key-release.patch"
"${FILESDIR}/0002-seat-inhibit-touch-events-when-in-power-save-mode-or.patch"
@@ -63,25 +62,29 @@ src_prepare() {
default
rm -r "${S}"/subprojects/wlroots || die "Failed to remove bundled wlroots"
cp -r "${WORKDIR}/${WL_P}" "${S}"/subprojects/wlroots || die "Failed to copy right version of wlroots"
+
+ cd "${S}"/subprojects/wlroots
+ eapply "${FILESDIR}"/xcursor-fix-false-positive-stringop-truncation.diff
+ eapply "${FILESDIR}"/Revert-layer-shell-error-on-0-dimension-without-anchors.diff
+
}
src_configure() {
local emesonargs=(
-Ddefault_library=shared
-Dtests=false
- -Dwlroots:logind-provider=systemd
- -Dwlroots:libseat=disabled
)
meson_src_configure
}
src_install() {
DESTDIR="${D}" meson_src_install
-# dobin "${S}"/helpers/scale-to-fit
+ dobin "${S}"/helpers/scale-to-fit
}
pkg_postinst() {
xdg_pkg_postinst
+ gnome2_schemas_update
}
pkg_postrm() {