aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2022-05-14 16:29:10 +0000
committerAisha Tammy <gentoo@aisha.cc>2022-05-14 16:29:32 +0000
commit36faed2487f1d610f3923a58197431b1eed6ca2f (patch)
treea37d9f29e79efcd4759f43490ae398cb84ec5153 /www-apps/uwebsockets
parentmedia-video/uxplay: version bump to 1.52, drop 1.51 (diff)
downloadguru-36faed2487f1d610f3923a58197431b1eed6ca2f.tar.gz
guru-36faed2487f1d610f3923a58197431b1eed6ca2f.tar.bz2
guru-36faed2487f1d610f3923a58197431b1eed6ca2f.zip
www-apps/uwebsockets: add 20.14.0
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'www-apps/uwebsockets')
-rw-r--r--www-apps/uwebsockets/Manifest1
-rw-r--r--www-apps/uwebsockets/uwebsockets-20.14.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/www-apps/uwebsockets/Manifest b/www-apps/uwebsockets/Manifest
index 0a9c55627..0a75f441c 100644
--- a/www-apps/uwebsockets/Manifest
+++ b/www-apps/uwebsockets/Manifest
@@ -1 +1,2 @@
DIST uwebsockets-20.11.0.tar.gz 750520 BLAKE2B 4c139bffcb60a5a2cf7245208e031905875261cfed968a03875358e31d5fb4cf02ff312fc7e5f7e9329ffcb9f9ee9c1204fcf9998fbb9df56163dc06820e2932 SHA512 cd4efb386b4d140c6ccbfa92e8be1d3c9b896474a3074b95ad35bedde9face80a1e4bae594359555010d76c2ccf8243b29e97079de8b0f18cda510274135b8e0
+DIST uwebsockets-20.14.0.tar.gz 751354 BLAKE2B 398aedfd8f253de9c66cfe889c7681f492124a9db1ca9554f560b170ac8ec4b4362f2dd7f351338e3c78819e49023f725d881052db609c631da6dbcb24e5e1a8 SHA512 f467942da6a151011a2e831081278eb2a816b215f5335c1e029d7130a56ab04595a3563c15821093d8f3a7b56e085427482cb026653fb24004817f2c08cb3376
diff --git a/www-apps/uwebsockets/uwebsockets-20.14.0.ebuild b/www-apps/uwebsockets/uwebsockets-20.14.0.ebuild
new file mode 100644
index 000000000..d8967872c
--- /dev/null
+++ b/www-apps/uwebsockets/uwebsockets-20.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RDEPEND=">=net-libs/usockets-0.6.0"
+
+src_prepare() {
+ default
+ mv src uWebSockets
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ doheader -r uWebSockets
+}