aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2022-04-26 17:39:35 +0000
committerAisha Tammy <gentoo@aisha.cc>2022-04-26 17:39:35 +0000
commit031ac6163a9ab7284db2ee94a7115bb77757cf7d (patch)
treedf9b208285d09cd9a423f07222839cd0dd1cc991 /sys-kernel
parentnet-libs/dpdk: restrict tests (diff)
downloadguru-031ac6163a9ab7284db2ee94a7115bb77757cf7d.tar.gz
guru-031ac6163a9ab7284db2ee94a7115bb77757cf7d.tar.bz2
guru-031ac6163a9ab7284db2ee94a7115bb77757cf7d.zip
sys-kernel/rte_kni-kmod: add 21.11.1, 22.03
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rte_kni-kmod/Manifest2
-rw-r--r--sys-kernel/rte_kni-kmod/rte_kni-kmod-21.11.1.ebuild78
-rw-r--r--sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild78
3 files changed, 158 insertions, 0 deletions
diff --git a/sys-kernel/rte_kni-kmod/Manifest b/sys-kernel/rte_kni-kmod/Manifest
index cf0fb5cc1..bcd3dead8 100644
--- a/sys-kernel/rte_kni-kmod/Manifest
+++ b/sys-kernel/rte_kni-kmod/Manifest
@@ -1 +1,3 @@
+DIST dpdk-21.11.1.tar.xz 15115156 BLAKE2B 089e98279922b5494b205d957f9ac05001a668f4536d45e5fd89b9f7d04779e0671ec428b2408963641da3ae999d5943a1ff5dc59c23020ccefce824609c8f11 SHA512 d7afc0c918626b1706a18a129086fcd3741b251c28fa00c5711eb85a03137e5ee6e08de7bd5ebe957e442dc9b901314042b382b223e74f0fdd5d560ac657f1b3
DIST dpdk-21.11.tar.xz 15102516 BLAKE2B e82fb03242b74e458810ee5e0d21feaf5d6d781b81b8dc5c2a2ab977bac202290dadc8734ea13993bb1cb1df4b5c4d770df574052a384b590ac798d19c370c59 SHA512 843282023c2f77a9b8af393d50c6dde54f09d490cd6f4a99f03d4df5df13a7d963aa86885fdf64e13f9da71e01c881d1f301dd093574a32cddd84f4b1fb58fd5
+DIST dpdk-22.03.tar.xz 15055548 BLAKE2B 16fb52618e72deba7097e4d920e160e14f1332eed2b8f2f2957f3dd1b847859e6b8b8cd6adef0513cd7bc528a37d4c481f803e8c5badaa299d2bb2af3615e696 SHA512 b3940642f99767323f39470c1e3e0eab7a07bcaca225e2a714b62ba6c59d2c66e4ea17d38e8266f37ed8b5c5c2ad272930fd28f545324ec0a1cb185685e06a5f
diff --git a/sys-kernel/rte_kni-kmod/rte_kni-kmod-21.11.1.ebuild b/sys-kernel/rte_kni-kmod/rte_kni-kmod-21.11.1.ebuild
new file mode 100644
index 000000000..488bf4d94
--- /dev/null
+++ b/sys-kernel/rte_kni-kmod/rte_kni-kmod-21.11.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit linux-mod python-single-r1 meson
+
+DESCRIPTION="DPDK Kernel Nic Interface module"
+HOMEPAGE="https://dpdk.org/"
+SRC_URI="https://fast.dpdk.org/rel/dpdk-${PV}.tar.xz"
+S="${WORKDIR}/dpdk-stable-${PV}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests need root
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ')
+ app-crypt/intel-ipsec-mb
+ dev-libs/elfutils
+ dev-libs/isa-l
+ dev-libs/jansson
+ dev-libs/libbpf
+ dev-libs/libbsd
+ dev-libs/openssl
+ net-libs/libmnl
+ net-libs/libpcap
+ sys-apps/dtc
+ sys-cluster/rdma-core
+ sys-process/numactl
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+CONFIG_CHECK="~IOMMU_SUPPORT ~AMD_IOMMU ~VFIO ~VFIO_PCI ~UIO ~UIO_PDRV_GENIRQ ~UIO_DMEM_GENIRQ ~HPET_MMAP"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ linux-mod_pkg_setup
+ python-single-r1_pkg_setup
+ # we still have to do meson configuration as it creates
+ # header files needed for compiling the rte_kni module
+ local emesonargs=(
+ -Denable_kmods=false
+ -Dmachine=default
+ -Dplatform=generic
+ )
+ meson_src_configure
+
+ # export after meson_src_configure as BUILD_DIR is needed for module compilation
+ export MODULE_NAMES="rte_kni(extra/dpdk:${S}/kernel/linux/kni)"
+ export BUILD_PARAMS="-C \"${KERNEL_DIR}\" M=\"${S}\"/kernel/linux/kni \
+ src=\"${S}\"/kernel/linux/kni \
+ MODULE_CFLAGS=\"${HAVE_ARG_TX_QUEUE} -include ${S}/config/rte_config.h -I${S}/lib/eal/include \
+ -I${S}/lib/kni -I${S}/kernel/linux/kni -I${BUILD_DIR} -I${S}\""
+ export BUILD_TARGETS="modules"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}
diff --git a/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild b/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild
new file mode 100644
index 000000000..44e368c06
--- /dev/null
+++ b/sys-kernel/rte_kni-kmod/rte_kni-kmod-22.03.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit linux-mod python-single-r1 meson
+
+DESCRIPTION="DPDK Kernel Nic Interface module"
+HOMEPAGE="https://dpdk.org/"
+SRC_URI="https://fast.dpdk.org/rel/dpdk-${PV}.tar.xz"
+S="${WORKDIR}/dpdk-${PV}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests need root
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pyelftools[${PYTHON_USEDEP}]
+ ')
+ app-crypt/intel-ipsec-mb
+ dev-libs/elfutils
+ dev-libs/isa-l
+ dev-libs/jansson
+ dev-libs/libbpf
+ dev-libs/libbsd
+ dev-libs/openssl
+ net-libs/libmnl
+ net-libs/libpcap
+ sys-apps/dtc
+ sys-cluster/rdma-core
+ sys-process/numactl
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+CONFIG_CHECK="~IOMMU_SUPPORT ~AMD_IOMMU ~VFIO ~VFIO_PCI ~UIO ~UIO_PDRV_GENIRQ ~UIO_DMEM_GENIRQ ~HPET_MMAP"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ linux-mod_pkg_setup
+ python-single-r1_pkg_setup
+ # we still have to do meson configuration as it creates
+ # header files needed for compiling the rte_kni module
+ local emesonargs=(
+ -Denable_kmods=false
+ -Dmachine=default
+ -Dplatform=generic
+ )
+ meson_src_configure
+
+ # export after meson_src_configure as BUILD_DIR is needed for module compilation
+ export MODULE_NAMES="rte_kni(extra/dpdk:${S}/kernel/linux/kni)"
+ export BUILD_PARAMS="-C \"${KERNEL_DIR}\" M=\"${S}\"/kernel/linux/kni \
+ src=\"${S}\"/kernel/linux/kni \
+ MODULE_CFLAGS=\"${HAVE_ARG_TX_QUEUE} -include ${S}/config/rte_config.h -I${S}/lib/eal/include \
+ -I${S}/lib/kni -I${S}/kernel/linux/kni -I${BUILD_DIR} -I${S}\""
+ export BUILD_TARGETS="modules"
+}
+
+src_compile() {
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+}