aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-03-08 22:31:36 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-03-18 08:31:09 +0500
commitb468dcd243ecbb0648eecaeed5da40875396ca69 (patch)
tree5c788f789e7a5ba2eab905db532092b23d417ad5 /net-nntp
parentmedia-video/mpv-mpris: rename library (diff)
downloadguru-b468dcd243ecbb0648eecaeed5da40875396ca69.tar.gz
guru-b468dcd243ecbb0648eecaeed5da40875396ca69.tar.bz2
guru-b468dcd243ecbb0648eecaeed5da40875396ca69.zip
net-nntp/inn: add 2.6.5
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/inn/Manifest2
-rw-r--r--net-nntp/inn/files/inn.tmpfiles1
-rw-r--r--net-nntp/inn/files/innd.service9
-rw-r--r--net-nntp/inn/inn-2.6.5.ebuild118
4 files changed, 129 insertions, 1 deletions
diff --git a/net-nntp/inn/Manifest b/net-nntp/inn/Manifest
index 86209df86..fd460e738 100644
--- a/net-nntp/inn/Manifest
+++ b/net-nntp/inn/Manifest
@@ -1,2 +1,4 @@
DIST inn-2.6.4.tar.gz 2610659 BLAKE2B 0cabe90b941f47d759179f71de10212ffb71c1955452ab1b04018a3f7dbb2f8fa0f2f3c534bda9fc08768b4ffa1034fcf2d59077fa1a5bb77801c74d11a6cab5 SHA512 0b1e4add9fe1f2a423f372adbce9622ffe943c75865427f30b18f5a5b8c2dae158d5bfa4d611631cb993757523bc858ca6ad907463bd5f91c60a851359a70c57
DIST inn-2.6.4.tar.gz.sha256.asc 620 BLAKE2B e21d72effaf090a7a8bbc6f1b6fc8f2b6a604dfbc594ae1bba5f559e93e0b352bd255a2b12880dabbd038f6204003064b9744def43ea6cfc0cd52aec0779f279 SHA512 17ab70d3df9500f3fbe0ee2e359bbaf8d54fcd4337000b44ab7e74f87c65617740b052d942f9e0adcb901e017ed64367f55e4dbb07075ae734fd05fcd5d21396
+DIST inn-2.6.5.tar.gz 2646269 BLAKE2B a7ac0016be44480a57a2603494f236d5cbfb40b2056768331b873c7ee4cc9845da7831d6ae0431dbbbc23d44561f8faadce6869a9af8f7b25235b824683814fc SHA512 7200880e179ac10dcb04ed534d2f3119ad4045e912016342e2552e3fc129a2b2d4360615bc03bc9f4e17c440cf07c8017c55f4c17400af140a8bf7b96dc52a2f
+DIST inn-2.6.5.tar.gz.asc 488 BLAKE2B 1c4899f85831ab40f359097d77c740f343c76542678753b961ff8dafb79c0277a67186163396568623c5af5fc0d1918ce7b1c0c73d936d65120039c2c72dd73a SHA512 f488554d90dcb8a4251113d7a7cc76899616797374e8e9703fffb5dd77ab83870fe6626564fe52ad6fc40b96c8b37f3aec125181008f7c2771a83715eaa06ea2
diff --git a/net-nntp/inn/files/inn.tmpfiles b/net-nntp/inn/files/inn.tmpfiles
new file mode 100644
index 000000000..791146741
--- /dev/null
+++ b/net-nntp/inn/files/inn.tmpfiles
@@ -0,0 +1 @@
+d /run/news 0755 news news -
diff --git a/net-nntp/inn/files/innd.service b/net-nntp/inn/files/innd.service
index ae7db3a44..dc5891882 100644
--- a/net-nntp/inn/files/innd.service
+++ b/net-nntp/inn/files/innd.service
@@ -1,6 +1,7 @@
[Unit]
Description=InterNetNews News Server
Documentation=https://www.eyrie.org/~eagle/software/inn/
+Documentation=man:innd(8)
After=network-online.target
Wants=network-online.target
ConditionPathExists=/etc/news/inn.conf
@@ -9,11 +10,17 @@ ConditionPathExists=/etc/news/inn.conf
Type=notify
Restart=on-abort
ExecStart=/opt/inn/bin/rc.news
-ExecReload=/opt/inn/bin/ctlinnd -t 20 reload '' 'systemd unit reload'
ExecStop=/opt/inn/bin/rc.news stop
+ExecReload=/opt/inn/bin/ctlinnd -t 20 reload all 'by systemd'
PIDFile=/run/news/innd.pid
User=news
Group=news
+ConfigurationDirectory=news
+LogsDirectory=news
+LogsDirectoryMode=775
+RuntimeDirectory=news
+StateDirectory=news
+StateDirectoryMode=775
AmbientCapabilities=CAP_NET_BIND_SERVICE
PrivateTmp=true
ProtectControlGroups=true
diff --git a/net-nntp/inn/inn-2.6.5.ebuild b/net-nntp/inn/inn-2.6.5.ebuild
new file mode 100644
index 000000000..cb5f1511d
--- /dev/null
+++ b/net-nntp/inn/inn-2.6.5.ebuild
@@ -0,0 +1,118 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit optfeature perl-functions python-single-r1 systemd tmpfiles verify-sig
+
+DESCRIPTION="InterNetNews -- the Internet meets Netnews"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/inn/"
+SRC_URI="https://archives.eyrie.org/software/${PN}/${P}.tar.gz
+ verify-sig? ( https://archives.eyrie.org/software/${PN}/${P}.tar.gz.asc )"
+
+LICENSE="BSD BSD-2 BSD-4 GPL-2+ ISC MIT RSA powell public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="berkdb gzip kerberos keywords largefile low-memory +perl +python sasl ssl systemd zlib"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ?? ( low-memory largefile )
+" # ?? ( bzip2 gzip )
+
+DEPEND="
+ app-crypt/gnupg
+ sys-libs/pam
+ virtual/libcrypt:=
+ !berkdb? ( sys-libs/gdbm:= )
+ berkdb? ( sys-libs/db:* )
+ kerberos? ( app-crypt/mit-krb5 )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ ssl? ( dev-libs/openssl:= )
+ systemd? ( sys-apps/systemd:= )
+ zlib? ( sys-libs/zlib:= )
+"
+RDEPEND="${DEPEND}
+ virtual/sendmail
+"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ verify-sig? ( sec-keys/openpgp-keys-russallbery )
+"
+
+DOCS=( CONTRIBUTORS HACKING INSTALL NEWS README TODO )
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/russallbery.asc"
+
+src_configure() {
+ econf_args=(
+ --prefix="${EPREFIX}"/opt/${PN}
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ --includedir="${EPREFIX}"/usr/include
+ --sysconfdir="${EPREFIX}"/etc/news
+
+ --with-db-dir="${EPREFIX}"/var/db/news
+ --with-doc-dir="${EPREFIX}"/usr/share/doc/${PF}
+ --with-http-dir="${EPREFIX}"/usr/share/${PN}/http
+ --with-libperl-dir=$(perl_get_vendorlib)
+ --with-log-dir="${EPREFIX}"/var/log/news
+ --with-run-dir="${EPREFIX}"/run/news
+ --with-spool-dir="${EPREFIX}"/var/spool/news
+ --with-tmp-dir="${EPREFIX}"/var/tmp/news
+
+ $(use_enable keywords)
+ $(use_enable largefile largefiles)
+ $(use_enable low-memory tagged-hash)
+ $(use_with berkdb bdb)
+ $(use_with kerberos krb5)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with sasl)
+ $(use_with ssl openssl)
+ $(use_with zlib)
+ )
+
+ if use gzip; then
+ econf_args+=( --with-log-compress=gzip )
+ # elif use bzip2; then
+ # econf_args+=( --with-log-compress=bzip2 )
+ else
+ econf_args+=( --with-log-compress=cat )
+ fi
+
+ econf "${econf_args[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir /var/log/inn/OLD
+ keepdir /var/tmp/news
+ keepdir /var/spool/news/{archive,articles,incoming/bad,innfeed,outgoing,overview}
+
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}"/usr/share/doc/${PF}/{GPL,LICENSE} || die
+ rm -r "${ED}"/run || die
+
+ doenvd "${FILESDIR}"/30inn
+ newinitd "${FILESDIR}"/ovdb.initd ovdb
+ for svc in cnfsstat innd innwatch; do
+ newinitd "${FILESDIR}"/${svc}.initd ${svc}
+ newconfd "${FILESDIR}"/${svc}.confd ${svc}
+ done
+
+ systemd_dounit "${FILESDIR}"/innd.service
+ newtmpfiles "${FILESDIR}"/inn.tmpfiles inn.conf
+}
+
+pkg_postinst() {
+ if use perl; then
+ optfeature "controlchan program" dev-perl/MIME-tools
+ optfeature "innreport script" dev-perl/GD
+ optfeature "send-uucp backend" net-misc/taylor-uucp
+ fi
+}