aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-03-19 12:05:59 +0100
committerKurt Kanzenbach <kurt@kmk-computers.de>2020-03-19 12:06:29 +0100
commit17bd3043818549f3c5e5261d55e429e98885b019 (patch)
tree5b3a677348d3211d2ab01e0ec381060cf843e371 /net-mail
parentdev-vcs/github-cli: remove package as it has been added upstream (diff)
downloadguru-17bd3043818549f3c5e5261d55e429e98885b019.tar.gz
guru-17bd3043818549f3c5e5261d55e429e98885b019.tar.bz2
guru-17bd3043818549f3c5e5261d55e429e98885b019.zip
net-mail/remail: A set of tools for crypted mailing lists (new package)
remail is a very simplistic mailing list tool which provides encryption. remail reads mail from a maildir, decrypts it with the mailing list private key and re-encrypts it for every enabled subscriber. The resulting mails are delivered to the localhost's SMTP server. remail supports S/MIME and PGP on both ends. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/remail/Manifest1
-rw-r--r--net-mail/remail/files/remail-0.9-setup.patch49
-rw-r--r--net-mail/remail/metadata.xml17
-rw-r--r--net-mail/remail/remail-0.9.ebuild50
4 files changed, 117 insertions, 0 deletions
diff --git a/net-mail/remail/Manifest b/net-mail/remail/Manifest
new file mode 100644
index 000000000..8a98135d5
--- /dev/null
+++ b/net-mail/remail/Manifest
@@ -0,0 +1 @@
+DIST remail-0.9.tar.gz 52616 BLAKE2B b63650de259e783c8922aff0b71b354763ee1cc3f70c0514951d9899917b764d8ec36a8005d2134812f32bb7fbe9f27a060b4c6f9e98ec8a98eb3b86f19950fc SHA512 f7a27d83db69e56cdcf8dd415535ca029e755c228d76c6e11817279789a1aed0b98ce42625dc9f0245eed8411edc570444aee33704ae47424059f0a1756293e7
diff --git a/net-mail/remail/files/remail-0.9-setup.patch b/net-mail/remail/files/remail-0.9-setup.patch
new file mode 100644
index 000000000..a4c91b112
--- /dev/null
+++ b/net-mail/remail/files/remail-0.9-setup.patch
@@ -0,0 +1,49 @@
+From 914c820b0b16a397f663930e897819a70ea556ae Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Wed, 18 Mar 2020 11:02:33 +0100
+Subject: [PATCH] remail: Add setup.py
+
+Make it possible to use setuptools.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ setup.py | 27 +++++++++++++++++++++++++++
+ 1 file changed, 27 insertions(+)
+ create mode 100644 setup.py
+
+diff --git a/setup.py b/setup.py
+new file mode 100644
+index 000000000000..fede9d368f0a
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,27 @@
++import setuptools
++
++with open("README.md", "r") as fh:
++ long_description = fh.read()
++
++requires = [ 'flufl-bounce>=3.0', 'M2Crypto>=0.35.2', 'pyinotify>=0.9.6',
++ 'python-gnupg>=0.4.5', 'ruamel.yaml>=0.16.5' ]
++
++setuptools.setup(
++ name="remail",
++ version="0.9",
++ author="Thomas Gleixner",
++ author_email="tglx@linutronix.de",
++ description="A set of tools for crypted mailing lists",
++ long_description=long_description,
++ long_description_content_type="text/markdown",
++ url="https://git.kernel.org/pub/scm/linux/kernel/git/tglx/remail.git/",
++ packages=setuptools.find_packages(),
++ scripts=[ 'remail_chkcfg', 'remail_daemon', 'remail_pipe' ],
++ classifiers=[
++ "Programming Language :: Python :: 3",
++ "License :: OSI Approved :: GPLv2 License",
++ "Operating System :: OS Independent",
++ ],
++ python_requires='>=3.6',
++ install_requires=requires,
++)
+--
+2.24.1
+
diff --git a/net-mail/remail/metadata.xml b/net-mail/remail/metadata.xml
new file mode 100644
index 000000000..280a936f4
--- /dev/null
+++ b/net-mail/remail/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kurt@kmk-computers.de</email>
+ <name>Kurt Kanzenbach</name>
+ </maintainer>
+ <longdescription>
+ remail is a very simplistic mailing list tool which provides encryption.
+
+ remail reads mail from a maildir, decrypts it with the mailing list private
+ key and re-encrypts it for every enabled subscriber. The resulting mails are
+ delivered to the localhost's SMTP server.
+
+ remail supports S/MIME and PGP on both ends.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-mail/remail/remail-0.9.ebuild b/net-mail/remail/remail-0.9.ebuild
new file mode 100644
index 000000000..cc60b21a9
--- /dev/null
+++ b/net-mail/remail/remail-0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="A set of tools for crypted mailing lists"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/tglx/remail.git/about/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/tglx/remail.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples systemd"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/flufl-bounce[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.35.2[${PYTHON_USEDEP}]
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/python-gnupg[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}/${P}-setup.patch" )
+
+python_compile() {
+ distutils-r1_python_compile
+
+ emake -C Documentation man
+ use doc && emake -C Documentation html
+}
+
+python_install_all() {
+ doman Documentation/output/man/*
+
+ use doc && local HTML_DOCS=( Documentation/output/html/. )
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r Documentation/examples
+ use systemd && systemd_dounit remail.service
+}