aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorVincent Phan <chinh4thepro@gmail.com>2024-04-29 17:41:09 -0400
committerVincent Phan <chinh4thepro@gmail.com>2024-04-29 17:41:43 -0400
commitf9076add13b0a8aa15e60c0ca4529cefc1ccc98b (patch)
treefc6384724995b0ed04c2d330a6c675657e55c8a7 /net-im
parentgnome-extra/extension-manager: Add 0.5.1 (diff)
downloadguru-f9076add13b0a8aa15e60c0ca4529cefc1ccc98b.tar.gz
guru-f9076add13b0a8aa15e60c0ca4529cefc1ccc98b.tar.bz2
guru-f9076add13b0a8aa15e60c0ca4529cefc1ccc98b.zip
net-im/vesktop-bin: new package, add 1.5.1
Signed-off-by: Vincent Phan <chinh4thepro@gmail.com>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/vesktop-bin/Manifest1
-rw-r--r--net-im/vesktop-bin/files/vesktop-bin.desktop10
-rw-r--r--net-im/vesktop-bin/files/vesktop-bin.pngbin0 -> 9763 bytes
-rw-r--r--net-im/vesktop-bin/metadata.xml11
-rw-r--r--net-im/vesktop-bin/vesktop-bin-1.5.1.ebuild73
5 files changed, 95 insertions, 0 deletions
diff --git a/net-im/vesktop-bin/Manifest b/net-im/vesktop-bin/Manifest
new file mode 100644
index 000000000..d7f4f0f94
--- /dev/null
+++ b/net-im/vesktop-bin/Manifest
@@ -0,0 +1 @@
+DIST vesktop.tar.gz 104972407 BLAKE2B 0c19c024611e87438347c3de87ce0688a14498290f639e29ad4b5488b34a2aaa765a2ef1f12d5b43522a1feb3ba3e71c1dfedb3a35b89d4e5340c8f3f002d53b SHA512 9440e7ec349e88aa42c3cff6579e0e915447e5713d419f8e4fd8b93261fd55a3b78122de4088554ad93632c5e1f2b9661e9b9ebb31646be18054ef8acb7aacc8
diff --git a/net-im/vesktop-bin/files/vesktop-bin.desktop b/net-im/vesktop-bin/files/vesktop-bin.desktop
new file mode 100644
index 000000000..3a50b0674
--- /dev/null
+++ b/net-im/vesktop-bin/files/vesktop-bin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Vesktop (bin)
+Comment=Vencord Desktop is a free/libre cross platform desktop app aiming to give you a snappier Discord experience with Vencord pre-installed
+GenericName=Internet Messenger
+Type=Application
+Exec=/usr/bin/vesktop-bin
+Icon=vesktop-bin
+Categories=Network;InstantMessaging;
+StartupWMClass=vencord-desktop
+Keywords=discord;vencord;
diff --git a/net-im/vesktop-bin/files/vesktop-bin.png b/net-im/vesktop-bin/files/vesktop-bin.png
new file mode 100644
index 000000000..027ab0b6b
--- /dev/null
+++ b/net-im/vesktop-bin/files/vesktop-bin.png
Binary files differ
diff --git a/net-im/vesktop-bin/metadata.xml b/net-im/vesktop-bin/metadata.xml
new file mode 100644
index 000000000..ae473e9a4
--- /dev/null
+++ b/net-im/vesktop-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chinh4thepro@gmail.com</email>
+ <name>Vincent Phan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Vencord/Vesktop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/vesktop-bin/vesktop-bin-1.5.1.ebuild b/net-im/vesktop-bin/vesktop-bin-1.5.1.ebuild
new file mode 100644
index 000000000..07a53b7e4
--- /dev/null
+++ b/net-im/vesktop-bin/vesktop-bin-1.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="vesktop"
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop linux-info unpacker xdg
+
+DESCRIPTION="All-in-one voice and text chat for gamers with Vencord Preinstalled"
+HOMEPAGE="https://github.com/Vencord/Vesktop/"
+SRC_URI="https://github.com/Vencord/Vesktop/releases/download/v${PV}/${MY_PN}-${PV}.tar.gz -> ${MY_PN}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify"
+RESTRICT="bindist mirror strip test"
+
+DEPEND="
+ libnotify? ( x11-libs/libnotify )
+ x11-misc/xdg-utils
+"
+
+BDEPEND="
+ dev-vcs/git
+"
+
+DESTDIR="/opt/${PN}"
+
+QA_PREBUILT="*"
+
+CONFIG_CHECK="~USER_NS"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ default
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_install() {
+
+ doicon -s 256 "${FILESDIR}/vesktop-bin.png"
+ domenu "${FILESDIR}/vesktop-bin.desktop"
+
+ exeinto "${DESTDIR}"
+
+ doexe vesktop chrome-sandbox libEGL.so libffmpeg.so libGLESv2.so libvk_swiftshader.so libvulkan.so.1
+
+ insinto "${DESTDIR}"
+ doins chrome_100_percent.pak chrome_200_percent.pak icudtl.dat resources.pak snapshot_blob.bin v8_context_snapshot.bin
+ insopts -m0755
+ doins -r locales resources
+
+ fowners root "${DESTDIR}/chrome-sandbox"
+ fperms 4711 "${DESTDIR}/chrome-sandbox"
+
+ [[ -x chrome_crashpad_handler ]] && doins chrome_crashpad_handler
+
+ dosym "${DESTDIR}/vesktop" "/usr/bin/vesktop-bin"
+
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}