aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYuhang Zeng <unlsycn@unlsycn.com>2024-08-01 02:24:15 +0800
committerYuhang Zeng <unlsycn@unlsycn.com>2024-08-01 02:24:53 +0800
commit8eb16e995b6a76857217f2246dad273d756539e1 (patch)
tree3ba77b6d19b5ac328ea02ccbd51925132e71b2ac /net-im
parentgames-emulation/dosbox-x: Drop 2024.03.01 (diff)
downloadguru-8eb16e995b6a76857217f2246dad273d756539e1.tar.gz
guru-8eb16e995b6a76857217f2246dad273d756539e1.tar.bz2
guru-8eb16e995b6a76857217f2246dad273d756539e1.zip
net-im/discord-ptb-bin: add 0.0.97
Signed-off-by: Yuhang Zeng <unlsycn@unlsycn.com>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/discord-ptb-bin/Manifest1
-rw-r--r--net-im/discord-ptb-bin/discord-ptb-bin-0.0.97.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-im/discord-ptb-bin/Manifest b/net-im/discord-ptb-bin/Manifest
index b5b43c7b9..fa2fdb20b 100644
--- a/net-im/discord-ptb-bin/Manifest
+++ b/net-im/discord-ptb-bin/Manifest
@@ -1 +1,2 @@
DIST discord-ptb-0.0.29.deb 77105454 BLAKE2B 191e70c5abb8284220bbc61c312b5feba63bda5833498627abe4829798d2647252933a17b4840f32432fdef5cbd8c494a0789d2620a0853ff6d7ba8fcb78eb02 SHA512 2bfd70927f5b622043abd1e47af0c86c6b5f6adcdfd8b2170a3c47bb5a9904e84d76dd08ddbb5c8da29f0a79a774c3a2106a1d33991cd5acaf7b454e476e5a0c
+DIST discord-ptb-0.0.97.deb 103058320 BLAKE2B 5c99f18f54c6eff755d427c15aca3000829a4580c8178d1ce786cd98d1beabed9a28cc6c04940ec8e46e865f78daa436212b7335b3d93811c6a9d3e50086426f SHA512 a8b11e5f4f1f5b14c4cf67b352d3f80ac56289f2f7259c6b5a2177b74e5f14dff6d38b1368e8c1e99ecc86962ba870b1156ea3b9eb23731c1da05dd0ea1c2a73
diff --git a/net-im/discord-ptb-bin/discord-ptb-bin-0.0.97.ebuild b/net-im/discord-ptb-bin/discord-ptb-bin-0.0.97.ebuild
new file mode 100644
index 000000000..86658ba7a
--- /dev/null
+++ b/net-im/discord-ptb-bin/discord-ptb-bin-0.0.97.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+MY_BIN="D${MY_PN/d/}"
+MY_BIN="${MY_BIN/-ptb/}PTB"
+
+inherit desktop linux-info pax-utils unpacker xdg
+
+DESCRIPTION="All-in-one voice and text chat"
+HOMEPAGE="https://discordapp.com/"
+SRC_URI="https://dl-ptb.discordapp.net/apps/linux/${PV}/${MY_PN}-${PV}.deb"
+
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror bindist"
+
+# libXScrnSaver is used through dlopen (bug #825370)
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ opt/discord-ptb/${MY_BIN}
+ opt/discord-ptb/chrome-sandbox
+ opt/discord-ptb/chrome_crashpad_handler
+ opt/discord-ptb/libffmpeg.so
+ opt/discord-ptb/libvk_swiftshader.so
+ opt/discord-ptb/libvulkan.so.1
+ opt/discord-ptb/libEGL.so
+ opt/discord-ptb/libGLESv2.so
+ opt/discord-ptb/libVkICD_mock_icd.so
+ opt/discord-ptb/swiftshader/libEGL.so
+ opt/discord-ptb/swiftshader/libGLESv2.so
+ opt/discord-ptb/swiftshader/libvk_swiftshader.so
+"
+
+CONFIG_CHECK="~USER_NS"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:/usr/share/${MY_PN}/${MY_BIN}:/opt/${MY_PN}/${MY_BIN}:g" \
+ usr/share/${MY_PN}/${MY_PN}.desktop || die
+}
+
+src_install() {
+ newicon usr/share/${MY_PN}/${MY_PN//-ptb}.png ${MY_PN}.png
+ domenu usr/share/${MY_PN}/${MY_PN}.desktop
+
+ insinto /opt/${MY_PN}
+ doins -r usr/share/${MY_PN}/.
+ fperms +x /opt/${MY_PN}/${MY_BIN}
+ dosym ../../opt/${MY_PN}/${MY_BIN} usr/bin/${MY_PN}
+
+ pax-mark -m "${ED}"/opt/${MY_PN}/${MY_PN}
+}