aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-06-29 10:15:44 +0200
committertastytea <gentoo@tastytea.de>2023-06-30 14:12:40 +0200
commit0c4d0f82e4f0b77942325b6ed9081432b3756d14 (patch)
treee9f2a1d54e9c5e938dc020f5abadc577cfad6c28 /net-im/nheko
parentnet-wireless/rtl8821cu: Ebuild fix (diff)
downloadguru-0c4d0f82e4f0b77942325b6ed9081432b3756d14.tar.gz
guru-0c4d0f82e4f0b77942325b6ed9081432b3756d14.tar.bz2
guru-0c4d0f82e4f0b77942325b6ed9081432b3756d14.zip
net-im/nheko: fix build error with >=dev-libs/libfmt-10
Signed-off-by: tastytea <gentoo@tastytea.de>
Diffstat (limited to 'net-im/nheko')
-rw-r--r--net-im/nheko/files/nheko-0.11.3-fix-build-against-fmt10.patch82
-rw-r--r--net-im/nheko/nheko-0.11.3.ebuild5
2 files changed, 86 insertions, 1 deletions
diff --git a/net-im/nheko/files/nheko-0.11.3-fix-build-against-fmt10.patch b/net-im/nheko/files/nheko-0.11.3-fix-build-against-fmt10.patch
new file mode 100644
index 000000000..dc9c5f8df
--- /dev/null
+++ b/net-im/nheko/files/nheko-0.11.3-fix-build-against-fmt10.patch
@@ -0,0 +1,82 @@
+# source: <https://src.fedoraproject.org/rpms/nheko/blob/rawhide/f/nheko-0.11.3-fmt10-fix.patch>
+# backport of upstream commit
+# <https://github.com/Nheko-Reborn/nheko/commit/e89e65d> by xvitaly for Fedora.
+
+From e89e65dc17020772eb057414b4f0c5d6f4ad98d0 Mon Sep 17 00:00:00 2001
+From: Nicolas Werner <nicolas.werner@hotmail.de>
+Date: Wed, 28 Jun 2023 13:16:10 +0200
+Subject: [PATCH] Fix build against fmt10
+
+fixes #1499
+---
+ src/Cache.cpp | 2 +-
+ src/encryption/DeviceVerificationFlow.cpp | 2 +-
+ src/timeline/InputBar.cpp | 10 ++++++----
+ src/ui/MxcMediaProxy.cpp | 9 ++++++---
+ 4 files changed, 14 insertions(+), 9 deletions(-)
+
+diff --git a/src/Cache.cpp b/src/Cache.cpp
+index c575ebf7..0c5e879c 100644
+--- a/src/Cache.cpp
++++ b/src/Cache.cpp
+@@ -438,7 +438,7 @@ Cache::loadSecretsFromStore(
+ if (job->error() && job->error() != QKeychain::Error::EntryNotFound) {
+ nhlog::db()->error("Restoring secret '{}' failed ({}): {}",
+ name.toStdString(),
+- job->error(),
++ static_cast<int>(job->error()),
+ job->errorString().toStdString());
+
+ fatalSecretError();
+diff --git a/src/encryption/DeviceVerificationFlow.cpp b/src/encryption/DeviceVerificationFlow.cpp
+index 0e9043dd..7dee9e6b 100644
+--- a/src/encryption/DeviceVerificationFlow.cpp
++++ b/src/encryption/DeviceVerificationFlow.cpp
+@@ -39,7 +39,7 @@ DeviceVerificationFlow::DeviceVerificationFlow(QObject *,
+ , deviceIds(std::move(deviceIds_))
+ , model_(model)
+ {
+- nhlog::crypto()->debug("CREATING NEW FLOW, {}, {}", flow_type, (void *)this);
++ nhlog::crypto()->debug("CREATING NEW FLOW, {}, {}", static_cast<int>(flow_type), (void *)this);
+ if (deviceIds.size() == 1)
+ deviceId = deviceIds.front();
+
+diff --git a/src/timeline/InputBar.cpp b/src/timeline/InputBar.cpp
+index 94944337..1fb210d8 100644
+--- a/src/timeline/InputBar.cpp
++++ b/src/timeline/InputBar.cpp
+@@ -948,14 +948,14 @@ MediaUpload::MediaUpload(std::unique_ptr<QIODevice> source_,
+ this,
+ [mediaPlayer](QMediaPlayer::Error error) {
+ nhlog::ui()->debug("Media player error {} and errorStr {}",
+- error,
++ static_cast<int>(error),
+ mediaPlayer->errorString().toStdString());
+ });
+ connect(mediaPlayer,
+ &QMediaPlayer::mediaStatusChanged,
+ [mediaPlayer](QMediaPlayer::MediaStatus status) {
+ nhlog::ui()->debug(
+- "Media player status {} and error {}", status, mediaPlayer->error());
++ "Media player status {} and error {}", static_cast<int>(status), static_cast<int>(mediaPlayer->error()));
+ });
+ connect(mediaPlayer,
+ qOverload<const QString &, const QVariant &>(&QMediaPlayer::metaDataChanged),
+diff --git a/src/ui/MxcMediaProxy.cpp b/src/ui/MxcMediaProxy.cpp
+index da5a2231..dbe63469 100644
+--- a/src/ui/MxcMediaProxy.cpp
++++ b/src/ui/MxcMediaProxy.cpp
+@@ -37,11 +37,11 @@ MxcMediaProxy::MxcMediaProxy(QObject *parent)
+ qOverload<QMediaPlayer::Error>(&MxcMediaProxy::error),
+ [this](QMediaPlayer::Error error) {
+ nhlog::ui()->info("Media player error {} and errorStr {}",
+- error,
++ static_cast<int>(error),
+ this->errorString().toStdString());
+ });
+ connect(this, &MxcMediaProxy::mediaStatusChanged, [this](QMediaPlayer::MediaStatus status) {
+- nhlog::ui()->info("Media player status {} and error {}", status, this->error());
++ nhlog::ui()->info("Media player status {} and error {}", static_cast<int>(status), static_cast<int>(this->error()));
+ });
+ connect(this,
+ qOverload<const QString &, const QVariant &>(&MxcMediaProxy::metaDataChanged),
diff --git a/net-im/nheko/nheko-0.11.3.ebuild b/net-im/nheko/nheko-0.11.3.ebuild
index c0f2be4bf..95c05cfa1 100644
--- a/net-im/nheko/nheko-0.11.3.ebuild
+++ b/net-im/nheko/nheko-0.11.3.ebuild
@@ -67,7 +67,10 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}"/${P}-fix-explicit-optional-construction.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-explicit-optional-construction.patch
+ "${FILESDIR}"/${P}-fix-build-against-fmt10.patch
+)
src_configure() {
local -a mycmakeargs=(