aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2024-09-10 14:52:24 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2024-09-10 14:52:36 +0200
commit0ee5f6ca613c4e1c9e7be4f7893b18de8bbd5ffb (patch)
tree6fac58d368712a694dd0bfb1eba1ba42670b705d /mpv-plugin
parentdev-python/guidata: drop 3.5.2, 3.6.1 (diff)
downloadguru-0ee5f6ca613c4e1c9e7be4f7893b18de8bbd5ffb.tar.gz
guru-0ee5f6ca613c4e1c9e7be4f7893b18de8bbd5ffb.tar.bz2
guru-0ee5f6ca613c4e1c9e7be4f7893b18de8bbd5ffb.zip
mpv-plugin/kde-night-color: add 20240910
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'mpv-plugin')
-rw-r--r--mpv-plugin/kde-night-color/Manifest1
-rw-r--r--mpv-plugin/kde-night-color/kde-night-color-20240910.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/mpv-plugin/kde-night-color/Manifest b/mpv-plugin/kde-night-color/Manifest
index 05bef8e3a..ce3d819ac 100644
--- a/mpv-plugin/kde-night-color/Manifest
+++ b/mpv-plugin/kde-night-color/Manifest
@@ -1 +1,2 @@
DIST kde-night-color-20230110.tar.bz2 2155 BLAKE2B 351898790a3e382a904f73f53cc926b40fdbafd0968d8f80e1f7c28a25ed42c8378f6ec51abf907f2dff59ba9f4869da7b2cb9dc4cef457196e7fd2fd5f30263 SHA512 8ece42c28e224934d053c452fef4df0bdba381593f994028168798f31218670c15fffe39d50cdeddc6e9d50c15f281c20b1a05e1b199e7d4266a64c1cede5dde
+DIST kde-night-color-20240910.tar.bz2 2144 BLAKE2B c8fef4e46cbf535de6319a109d19310e9408714b35f9a6ae1a489c3be0e07b738420a182a08f123380a9c06f47cb1259040b4b1b978b291884bacc9743f10225 SHA512 8eba518ccd49f266fe16e6010f299ef56988092dadd42e7d494dfd2e1b4fce4b2ca8e9e6427889ca83a6491535f2d04f605e1663bc8814febe0bce4800e5b3f2
diff --git a/mpv-plugin/kde-night-color/kde-night-color-20240910.ebuild b/mpv-plugin/kde-night-color/kde-night-color-20240910.ebuild
new file mode 100644
index 000000000..46aec6050
--- /dev/null
+++ b/mpv-plugin/kde-night-color/kde-night-color-20240910.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MPV_REQ_USE="cplugins(+),libmpv"
+inherit mpv-plugin toolchain-funcs
+
+COMMIT="287f8cf168e1ead4706f32c92b0c06aacc25e4fa"
+MY_P="${PN}-${COMMIT}"
+DESCRIPTION="Disable Night Color while mpv is running"
+HOMEPAGE="https://gitlab.com/smaniottonicola/kde-night-color"
+SRC_URI="https://gitlab.com/smaniottonicola/${PN}/-/archive/${COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtdbus:5
+ virtual/pkgconfig
+"
+
+MPV_PLUGIN_FILES=( ${PN}.so )
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}