aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Lloro <ivan.lloro.boada@gmail.com>2024-06-21 09:42:16 +0200
committerIvan Lloro <ivan.lloro.boada@gmail.com>2024-06-21 09:42:16 +0200
commit6845ac5af39d4ba01bc776354ed829ab91bb1405 (patch)
treec97f0096f0790f337811a982a7e82627e774a06f /media-gfx
parentapp-doc/geeknote: Python 3.12 is not working - set max to 3.11 (diff)
downloadguru-6845ac5af39d4ba01bc776354ed829ab91bb1405.tar.gz
guru-6845ac5af39d4ba01bc776354ed829ab91bb1405.tar.bz2
guru-6845ac5af39d4ba01bc776354ed829ab91bb1405.zip
media-gfx/mayo: new package, add 0.8.0
Signed-off-by: Ivan Lloro <ivan.lloro.boada@gmail.com>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/mayo/Manifest2
-rw-r--r--media-gfx/mayo/files/mayo-0.8.0-nogit.patch17
-rw-r--r--media-gfx/mayo/mayo-0.8.0.ebuild43
-rw-r--r--media-gfx/mayo/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/mayo/Manifest b/media-gfx/mayo/Manifest
new file mode 100644
index 000000000..a6e25bdd6
--- /dev/null
+++ b/media-gfx/mayo/Manifest
@@ -0,0 +1,2 @@
+AUX mayo-0.8.0-nogit.patch 487 BLAKE2B 40f2df604ec7c542b76e0f83eb848eb32dd741ec9b2308f300de3e919f856c347ded63759b8a12b1014f8a343f1b1d932980cb50e495b66d6686007f8911d808 SHA512 be8926163191cd13768c3b048cd972d92b5cf8078f364c920f5b6b7070f8ce9063de8fc041080a2d6aadaa13058c9d8a7448052f3e36a527ee55e9043a7d7861
+DIST mayo-0.8.0.tar.gz 9792039 BLAKE2B 9f6c6173996f9731445363ad756ffc51d478ef4a9c0710056941e3f3634ee320987eec99e7d56237ba1f11f6adaca7be2a47816af2b8f7f7c78ba74a1fa8d296 SHA512 4363a41c0ed1dd555302c7b5f61eee136d9ae6999f6a66c92c117cf2a9a74eb5ece991a22ffa29f095b7ec8a2c5426375628c8213ed94b6295c64019141539d7
diff --git a/media-gfx/mayo/files/mayo-0.8.0-nogit.patch b/media-gfx/mayo/files/mayo-0.8.0-nogit.patch
new file mode 100644
index 000000000..d14b50672
--- /dev/null
+++ b/media-gfx/mayo/files/mayo-0.8.0-nogit.patch
@@ -0,0 +1,17 @@
+--- a/version.pri
++++ b/version.pri
+@@ -1,12 +1,5 @@
+-system(git --version):HAVE_GIT=1
+-defined(HAVE_GIT, var) {
+- MAYO_VERSION_COMMIT = $$system(git rev-parse --short HEAD)
+- MAYO_VERSION_REVNUM = $$system(git rev-list --count HEAD)
+-} else {
+- MAYO_VERSION_COMMIT = ??
+- MAYO_VERSION_REVNUM = 0
+- warning("Git is not in PATH, cannot find commit ID nor revision number")
+-}
++MAYO_VERSION_COMMIT = ??
++MAYO_VERSION_REVNUM = 0
+
+ MAYO_VERSION_MAJ = 0
+ MAYO_VERSION_MIN = 8
diff --git a/media-gfx/mayo/mayo-0.8.0.ebuild b/media-gfx/mayo/mayo-0.8.0.ebuild
new file mode 100644
index 000000000..8c22ccc0a
--- /dev/null
+++ b/media-gfx/mayo/mayo-0.8.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Opensource 3D CAD viewer and converter"
+HOMEPAGE="https://github.com/fougue/mayo"
+SRC_URI="https://github.com/fougue/mayo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=sci-libs/opencascade-7.7.0-r2
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=media-libs/assimp-5.3.1
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-nogit.patch
+)
+
+src_configure() {
+
+ eqmake5 "CASCADE_INC_DIR=/usr/include/opencascade" "CASCADE_LIB_DIR=/usr/lib64/opencascade" "ASSIMP_INC_DIR=/usr/include/assimp" "ASSIMP_LIB_DIR=/usr/lib64" mayo.pro
+
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ install -d "${D}"/usr/bin/
+ install "${S}"/mayo "${D}"/usr/bin/ || die "failed to move locales"
+
+ einstalldocs
+}
diff --git a/media-gfx/mayo/metadata.xml b/media-gfx/mayo/metadata.xml
new file mode 100644
index 000000000..d92641e87
--- /dev/null
+++ b/media-gfx/mayo/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ivan.lloro.boada@gmail.com</email>
+ <name>Ivan Lloro</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fougue/mayo</remote-id>
+ </upstream>
+</pkgmetadata>