aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-07 18:12:00 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-07 18:19:16 +0200
commitd0a8c98881e80d9f3fca083ee2cd8d497bdc3219 (patch)
tree8532e37e4911c4bf33b185d07959932024b49844 /gui-apps/coreuniverse
parentgui-libs/libcsys: bump to 4.2.0_alpha; update live (diff)
downloadguru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.gz
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.bz2
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.zip
gui-apps/core*: bump to 4.2.0_alpha; update live
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/coreuniverse')
-rw-r--r--gui-apps/coreuniverse/Manifest1
-rw-r--r--gui-apps/coreuniverse/coreuniverse-4.2.0_alpha.ebuild34
-rw-r--r--gui-apps/coreuniverse/coreuniverse-9999.ebuild14
3 files changed, 40 insertions, 9 deletions
diff --git a/gui-apps/coreuniverse/Manifest b/gui-apps/coreuniverse/Manifest
index 1599da801..c3f0bffca 100644
--- a/gui-apps/coreuniverse/Manifest
+++ b/gui-apps/coreuniverse/Manifest
@@ -1 +1,2 @@
DIST coreuniverse-4.1.0.tar.gz 255877 BLAKE2B 14b85ebe99aa368daa8007f36626f7d6b00de94a9a69f55e7b8986c2127049e15d3d0f860bc35c0a84df90354bb1d3080724efab10c78d406a05eede814cc1dd SHA512 17cfd248fb7a7db9ba0df1777f01d0400116f9ce73ce2599a81cec6fcd8d27ab582e5e72effa7fd89eee352f029f91cf5b99dd1d507cd5250323203d593b49a3
+DIST coreuniverse-4.2.0_alpha.tar.gz 250744 BLAKE2B becbd4ad576f254ca307cdb6dfc9ab1a99031381a88a0b2b65d3034124d9a30472667ef4b3fe5e7efdc2588db913bd4977356bbbb27edfe4ab670385f7dd1a1c SHA512 120002cb912609081891602a5e12d97523eef4360292b034bf8572e05ea32710f231e02ca465ce943650e0c6f5f2132e20964c8f88c365078ee1d16cf4738327
diff --git a/gui-apps/coreuniverse/coreuniverse-4.2.0_alpha.ebuild b/gui-apps/coreuniverse/coreuniverse-4.2.0_alpha.ebuild
new file mode 100644
index 000000000..0931e6d07
--- /dev/null
+++ b/gui-apps/coreuniverse/coreuniverse-4.2.0_alpha.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="Shows information about apps for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreuniverse"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"
diff --git a/gui-apps/coreuniverse/coreuniverse-9999.ebuild b/gui-apps/coreuniverse/coreuniverse-9999.ebuild
index 2c3544aab..0931e6d07 100644
--- a/gui-apps/coreuniverse/coreuniverse-9999.ebuild
+++ b/gui-apps/coreuniverse/coreuniverse-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake xdg
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
DESCRIPTION="Shows information about apps for C Suite"
HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreuniverse"
@@ -12,9 +14,9 @@ if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${PV}"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
fi
RESTRICT="test"
@@ -30,9 +32,3 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i 's/CSuite/X-CSuite/' *.desktop || die
-}