aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-03-23 08:20:05 +0100
committerMaciej Barć <xgqt@riseup.net>2021-03-23 08:33:52 +0100
commit2ab43d8be7081a7df58f73f83861dcaac020a1ea (patch)
tree351636d64306b47e6fda1c5f85d2a7424bfd777e /gui-apps/coreuniverse
parentgui-apps/corepins: new pkg; add 4.1.0 and live (diff)
downloadguru-2ab43d8be7081a7df58f73f83861dcaac020a1ea.tar.gz
guru-2ab43d8be7081a7df58f73f83861dcaac020a1ea.tar.bz2
guru-2ab43d8be7081a7df58f73f83861dcaac020a1ea.zip
gui-apps/coreuniverse: new pkg; add 4.1.0 and live
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/coreuniverse')
-rw-r--r--gui-apps/coreuniverse/Manifest1
-rw-r--r--gui-apps/coreuniverse/coreuniverse-4.1.0.ebuild52
-rw-r--r--gui-apps/coreuniverse/coreuniverse-9999.ebuild52
-rw-r--r--gui-apps/coreuniverse/metadata.xml11
4 files changed, 116 insertions, 0 deletions
diff --git a/gui-apps/coreuniverse/Manifest b/gui-apps/coreuniverse/Manifest
new file mode 100644
index 000000000..1599da801
--- /dev/null
+++ b/gui-apps/coreuniverse/Manifest
@@ -0,0 +1 @@
+DIST coreuniverse-4.1.0.tar.gz 255877 BLAKE2B 14b85ebe99aa368daa8007f36626f7d6b00de94a9a69f55e7b8986c2127049e15d3d0f860bc35c0a84df90354bb1d3080724efab10c78d406a05eede814cc1dd SHA512 17cfd248fb7a7db9ba0df1777f01d0400116f9ce73ce2599a81cec6fcd8d27ab582e5e72effa7fd89eee352f029f91cf5b99dd1d507cd5250323203d593b49a3
diff --git a/gui-apps/coreuniverse/coreuniverse-4.1.0.ebuild b/gui-apps/coreuniverse/coreuniverse-4.1.0.ebuild
new file mode 100644
index 000000000..b7e6da131
--- /dev/null
+++ b/gui-apps/coreuniverse/coreuniverse-4.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Shows information about apps for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreuniverse"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i 's/CSuite/X-CSuite/' "${PN}.desktop" || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ einstalldocs
+
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/gui-apps/coreuniverse/coreuniverse-9999.ebuild b/gui-apps/coreuniverse/coreuniverse-9999.ebuild
new file mode 100644
index 000000000..b7e6da131
--- /dev/null
+++ b/gui-apps/coreuniverse/coreuniverse-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Shows information about apps for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/coreuniverse"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i 's/CSuite/X-CSuite/' "${PN}.desktop" || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ einstalldocs
+
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/gui-apps/coreuniverse/metadata.xml b/gui-apps/coreuniverse/metadata.xml
new file mode 100644
index 000000000..3ae065843
--- /dev/null
+++ b/gui-apps/coreuniverse/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@riseup.net</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">cubocore/coreapps/coreuniverse</remote-id>
+ </upstream>
+</pkgmetadata>