aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-07 18:12:00 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-07 18:19:16 +0200
commitd0a8c98881e80d9f3fca083ee2cd8d497bdc3219 (patch)
tree8532e37e4911c4bf33b185d07959932024b49844 /gui-apps/corepaint
parentgui-libs/libcsys: bump to 4.2.0_alpha; update live (diff)
downloadguru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.gz
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.tar.bz2
guru-d0a8c98881e80d9f3fca083ee2cd8d497bdc3219.zip
gui-apps/core*: bump to 4.2.0_alpha; update live
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/corepaint')
-rw-r--r--gui-apps/corepaint/Manifest1
-rw-r--r--gui-apps/corepaint/corepaint-4.2.0_alpha.ebuild34
-rw-r--r--gui-apps/corepaint/corepaint-9999.ebuild14
3 files changed, 40 insertions, 9 deletions
diff --git a/gui-apps/corepaint/Manifest b/gui-apps/corepaint/Manifest
index 734265936..62b8c0208 100644
--- a/gui-apps/corepaint/Manifest
+++ b/gui-apps/corepaint/Manifest
@@ -1,2 +1,3 @@
DIST corepaint-4.0.0.tar.gz 95037 BLAKE2B ac7ba3bcd28057206801211b87a7d420f94a9a46147008644d9b7d59169f48e3fc2a78f3ea2db5c034fa97b922b25b4d94025a2001293acc62aab74ab8d105d0 SHA512 dbb0a37100d9bd01b3512080e98162c6a25d3ab5ff19be3fefedf35c3398bdb160ad1ba2c9cb5d6950582c6bfc99d75c3768edf45fa6cfe1b898fb11a7ac4a9a
DIST corepaint-4.1.0.tar.gz 96506 BLAKE2B a5ec05d35e1d6ce086bb7ef55a0efbfe34273510b446492835e532e2420c52998495bba63e7cc4ce1080e144b1aa8bc5f10c06e58e1d6c0718b41c8c084c489d SHA512 c49d2388436e13717edaa957d7a81de2cf348324317baab27fbe1f9ef0a7086095c6996ee09300d350945af4dd1abe2f736dfcf49886443e0474245ff327227a
+DIST corepaint-4.2.0_alpha.tar.gz 108589 BLAKE2B 148739b145df83939733ae1797b83c60c6b8a161b13cfdb44ce1c478bb3671639487a025cf1cf7d3fe1e4f11ccdf93b75bbf8b3393a6bd85e2ea007efbec7f1c SHA512 3dcf40200b1677452f4eef7028e8036a883cb5072bbda2ddd50084607daf779124ab2709a974efb167e6b9b41c12085d1865ad56bc46ea70f554f293abe636ee
diff --git a/gui-apps/corepaint/corepaint-4.2.0_alpha.ebuild b/gui-apps/corepaint/corepaint-4.2.0_alpha.ebuild
new file mode 100644
index 000000000..f5a7ba9c9
--- /dev/null
+++ b/gui-apps/corepaint/corepaint-4.2.0_alpha.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="A paint app for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepaint"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"
diff --git a/gui-apps/corepaint/corepaint-9999.ebuild b/gui-apps/corepaint/corepaint-9999.ebuild
index 162903c97..f5a7ba9c9 100644
--- a/gui-apps/corepaint/corepaint-9999.ebuild
+++ b/gui-apps/corepaint/corepaint-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit cmake xdg
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
DESCRIPTION="A paint app for C Suite"
HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepaint"
@@ -12,9 +14,9 @@ if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${PV}"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
fi
RESTRICT="test"
@@ -30,9 +32,3 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i 's/CSuite/X-CSuite/' *.desktop || die
-}