aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHoël Bézier <hoelbezier@riseup.net>2024-11-17 13:18:18 +0100
committerHoël Bézier <hoelbezier@riseup.net>2024-11-17 13:36:36 +0100
commite2c2ed96047c532324207a5e17a0bb10b1ac1cc1 (patch)
treeeec3e4a4591c51c0a16238618375fcbd2eaa8717 /games-strategy
parentapp-text/dooit: drop 2.2.0, add 3.0.3 (diff)
downloadguru-e2c2ed96047c532324207a5e17a0bb10b1ac1cc1.tar.gz
guru-e2c2ed96047c532324207a5e17a0bb10b1ac1cc1.tar.bz2
guru-e2c2ed96047c532324207a5e17a0bb10b1ac1cc1.zip
games-strategy/slay-the-spire: new package, add 2.2
Signed-off-by: Hoël Bézier <hoelbezier@riseup.net>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/slay-the-spire/Manifest1
-rw-r--r--games-strategy/slay-the-spire/files/slay-the-spire6
-rw-r--r--games-strategy/slay-the-spire/metadata.xml8
-rw-r--r--games-strategy/slay-the-spire/slay-the-spire-2.2.ebuild56
4 files changed, 71 insertions, 0 deletions
diff --git a/games-strategy/slay-the-spire/Manifest b/games-strategy/slay-the-spire/Manifest
new file mode 100644
index 000000000..6f5cac884
--- /dev/null
+++ b/games-strategy/slay-the-spire/Manifest
@@ -0,0 +1 @@
+DIST slay_the_spire_2020_12_15_8735c9fe3cc2280b76aa3ec47c953352a7df1f65_43444.sh 443844375 BLAKE2B 8d6fc61900fa4c75fbc607531b850ba581200fc5612c68cfff50799588253392cb1060cc6b6e01701092f6ce57648ac736eaf1c572e609e82ac78ac3268c7e59 SHA512 fa8630e00d700e12d708febe4b1509e4ff4cb1c36906eb249ac2ad79e9cc0b1001152f571154e30c3f09bf482cacfc0eb9d0a1abcb72de710701f1d27064d195
diff --git a/games-strategy/slay-the-spire/files/slay-the-spire b/games-strategy/slay-the-spire/files/slay-the-spire
new file mode 100644
index 000000000..359b08f11
--- /dev/null
+++ b/games-strategy/slay-the-spire/files/slay-the-spire
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+gamedir="${XDG_DATA_DIR:-${HOME}/.local/share}/slay-the-spire"
+mkdir -p "$gamedir" &&
+cd "$gamedir" &&
+exec java -jar /opt/slay-the-spire/desktop-1.0.jar
diff --git a/games-strategy/slay-the-spire/metadata.xml b/games-strategy/slay-the-spire/metadata.xml
new file mode 100644
index 000000000..d5049a992
--- /dev/null
+++ b/games-strategy/slay-the-spire/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Hoël Bézier</name>
+ <email>hoelbezier@riseup.net</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-strategy/slay-the-spire/slay-the-spire-2.2.ebuild b/games-strategy/slay-the-spire/slay-the-spire-2.2.ebuild
new file mode 100644
index 000000000..c5f56957f
--- /dev/null
+++ b/games-strategy/slay-the-spire/slay-the-spire-2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="550M"
+inherit check-reqs desktop unpacker xdg
+
+DESCRIPTION="Deck-building roguelike game with four playable characters"
+HOMEPAGE="https://www.megacrit.com/"
+SRC_URI="slay_the_spire_2020_12_15_8735c9fe3cc2280b76aa3ec47c953352a7df1f65_43444.sh"
+S="${WORKDIR}/data/noarch/game"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+# Does not run with dev-java/openjdk: #894768
+RDEPEND="
+ dev-java/openjdk-bin
+ virtual/libc
+ x11-apps/xrandr
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip "${A}"
+}
+
+src_install() {
+ insinto "${DIR}"
+ doins desktop-1.0.jar mod-uploader.jar mts-launcher.jar
+ doins "${WORKDIR}/data/noarch/support/icon.png"
+
+ dobin "${FILESDIR}/slay-the-spire"
+
+ make_desktop_entry ${PN} "Slay the Spire" "${EPREFIX}${DIR}"/icon.png
+}