aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Bauer <samuel.bauer@yahoo.fr>2022-01-21 04:39:08 +0100
committerSamuel Bauer <samuel.bauer@yahoo.fr>2022-01-21 04:42:45 +0100
commit9bb6cd8cb6431aaa98a883a0e672daaad5259a51 (patch)
tree8446ee9af3773092df2b623c5d91804b19d29e37 /games-emulation
parentapp-misc/ssmtool: bump version (diff)
downloadguru-9bb6cd8cb6431aaa98a883a0e672daaad5259a51.tar.gz
guru-9bb6cd8cb6431aaa98a883a0e672daaad5259a51.tar.bz2
guru-9bb6cd8cb6431aaa98a883a0e672daaad5259a51.zip
games-emulation/citra: rework submodules and dependencies. always use system libfmt
Signed-off-by: Samuel Bauer <samuel.bauer@yahoo.fr>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/citra/citra-9999.ebuild33
-rw-r--r--games-emulation/citra/metadata.xml1
2 files changed, 21 insertions, 13 deletions
diff --git a/games-emulation/citra/citra-9999.ebuild b/games-emulation/citra/citra-9999.ebuild
index 602d34179..b2e44375e 100644
--- a/games-emulation/citra/citra-9999.ebuild
+++ b/games-emulation/citra/citra-9999.ebuild
@@ -8,12 +8,17 @@ inherit cmake git-r3 xdg
DESCRIPTION="A Nintendo 3DS Emulator"
HOMEPAGE="https://citra-emu.org"
EGIT_REPO_URI="https://github.com/citra-emu/citra"
-EGIT_SUBMODULES=( "*" "-boost" "-catch" "-cryptopp" "-enet" "-inih" "-libressl" "-externals/dynarmic/externals/xbyak" "-zstd" )
+EGIT_SUBMODULES=( '*'
+ '-boost' '-catch' '-cryptopp' '-cubeb' '-enet'
+ '-fmt' '-inih' '-libressl' '-libusb' '-zstd'
+ '-externals/dynarmic/externals/fmt'
+ '-externals/dynarmic/externals/xbyak'
+)
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="cubeb +hle-sound nls +qt5 sdl system-libfmt +telemetry video"
+IUSE="cubeb +hle-sound nls +qt5 sdl +telemetry video"
DEPEND="
cubeb? ( media-libs/cubeb )
@@ -29,22 +34,21 @@ DEPEND="
media-libs/libsdl2
>=dev-libs/inih-52
)
- system-libfmt? ( <=dev-libs/libfmt-8 )
video? ( media-video/ffmpeg )
>=app-arch/zstd-1.4.8
+ >=dev-libs/libfmt-8
>=dev-libs/openssl-1.1
dev-cpp/catch:0
+ dev-cpp/robin-map
dev-libs/boost:=
dev-libs/crypto++
net-libs/enet:1.3
+ virtual/libusb:1
"
RDEPEND="${DEPEND}"
REQUIRED_USE="|| ( qt5 sdl )"
src_unpack() {
- if use system-libfmt; then
- EGIT_SUBMODULES+=( "-fmt" "-externals/dynarmic/externals/fmt" )
- fi
git-r3_src_unpack
cp -a "${S}"/externals/xbyak "${S}"/externals/dynarmic/externals/ || die
@@ -54,6 +58,11 @@ src_unpack() {
}
src_prepare() {
+ # Dynarmic: ensure those are unbundled
+ for ext in fmt catch robin-map; do
+ rm -rf externals/dynarmic/externals/${ext} || die
+ done
+
# Do not care about submodules wanted one are already fetched
sed -i -e '/check_submodules_present()/d' CMakeLists.txt || die
@@ -80,12 +89,12 @@ src_prepare() {
src/{citra,citra_qt,dedicated_room,tests}/CMakeLists.txt || die
sed -i -e '1ifind_package(OpenSSL 1.1)' src/{citra,citra_qt,dedicated_room,tests}/CMakeLists.txt || die
- if use system-libfmt; then # Unbundle libfmt
- sed -i -e '/fmt/d' externals/CMakeLists.txt || die
- sed -i -e 's/fmt/&::&/' -e '1ifind_package(fmt)' \
- src/{core,citra,citra_qt,dedicated_room,input_common,tests,video_core}/CMakeLists.txt || die
- sed -i -e '1ifind_package(fmt)' externals/dynarmic/src/CMakeLists.txt || die
- fi
+ # Unbundle libfmt
+ sed -i -e '/fmt/d' externals/CMakeLists.txt || die
+ sed -i -e 's/fmt/&::&/' -e '1ifind_package(fmt)' \
+ src/{core,citra,citra_qt,dedicated_room,input_common,tests,video_core}/CMakeLists.txt || die
+ sed -i -e '1ifind_package(fmt)' externals/dynarmic/src/CMakeLists.txt || die
+ sed -i -e '/^#pragma once$/a#include <algorithm>' src/common/logging/log.h || die
# Unbundle zstd
sed -i -e 's:libzstd_static:${ZSTD_LIBRARIES}:' \
diff --git a/games-emulation/citra/metadata.xml b/games-emulation/citra/metadata.xml
index 87cb3dfdc..acd89943b 100644
--- a/games-emulation/citra/metadata.xml
+++ b/games-emulation/citra/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="cubeb">Enables the cubeb audio backend</flag>
<flag name="hle-sound">Enable HLE sound via FFmpeg audio (AAC) decoder</flag>
- <flag name="system-libfmt">Use system libfmt</flag>
<flag name="telemetry">Enable web services (telemetry, etc.)</flag>
<flag name="video">Enable FFmpeg video dumper</flag>
</use>