aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-07-16 12:11:05 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-07-16 12:11:12 +0900
commit878c7516f5dab76f7aff52d2699219720944c887 (patch)
tree052bd22525f90179ff95ceb4e1abb7f9da5b1f49 /dev-util
parentnet-p2p/feather: clean manifest (diff)
downloadguru-878c7516f5dab76f7aff52d2699219720944c887.tar.gz
guru-878c7516f5dab76f7aff52d2699219720944c887.tar.bz2
guru-878c7516f5dab76f7aff52d2699219720944c887.zip
dev-util/coq-lsp: new package, add 0.1.9
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/coq-lsp/Manifest1
-rw-r--r--dev-util/coq-lsp/coq-lsp-0.1.9.ebuild48
-rw-r--r--dev-util/coq-lsp/metadata.xml12
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/coq-lsp/Manifest b/dev-util/coq-lsp/Manifest
new file mode 100644
index 000000000..e51544e36
--- /dev/null
+++ b/dev-util/coq-lsp/Manifest
@@ -0,0 +1 @@
+DIST coq-lsp-0.1.9.tar.gz 25388271 BLAKE2B 8f1e49bdadfd792b96fda835b906e3b0d72f29eedaa3d4ef3825b1e92de03de2ec451c355adbc5d73a795173119761392cbfba8e9caf3d0de1035b2b3ddce942 SHA512 d452ae4598204abe8366fb72478e1d554e2a8de03a3ecc471392355a63c4992f41d891ef33cb913b52adba098d470121122d9fae85456eb8ce81204278ae5e18
diff --git a/dev-util/coq-lsp/coq-lsp-0.1.9.ebuild b/dev-util/coq-lsp/coq-lsp-0.1.9.ebuild
new file mode 100644
index 000000000..91ed69240
--- /dev/null
+++ b/dev-util/coq-lsp/coq-lsp-0.1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+COQ_MIN_V=8.19
+COQ_MAX_V=8.20
+
+DESCRIPTION="Visual Studio Code Extension and Language Server Protocol for Coq"
+HOMEPAGE="https://github.com/ejgallego/coq-lsp"
+SRC_URI="https://github.com/ejgallego/coq-lsp/archive/${PV}+${COQ_MIN_V}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${P}-${COQ_MIN_V}"
+
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sci-mathematics/coq-${COQ_MIN_V}.0:= <sci-mathematics/coq-${COQ_MAX_V}.0:=
+ sci-mathematics/coq-serapi:=
+
+ dev-ml/cmdliner:=
+ dev-ml/yojson:=
+ dev-ml/uri:=
+ dev-ml/dune-build-info:=
+
+ dev-ml/menhir:=
+
+ dev-ml/ppx_inline_test:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BEPEND="
+ test? (
+ dev-ml/alcotest:=
+ )
+"
diff --git a/dev-util/coq-lsp/metadata.xml b/dev-util/coq-lsp/metadata.xml
new file mode 100644
index 000000000..be9429698
--- /dev/null
+++ b/dev-util/coq-lsp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tokusan441@gmail.com</email>
+ <name>Hiroki Tokunaga</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ejgallego/coq-lsp/issues</bugs-to>
+ <remote-id type="github">ejgallego/coq-lsp</remote-id>
+ </upstream>
+</pkgmetadata>