aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2023-10-18 18:03:38 +0800
committerHuang Rui <vowstar@gmail.com>2023-10-18 18:03:38 +0800
commit613fa26ecf233e5da2b29bdb352951dcfb214b5d (patch)
tree9279157457fcd979af5554c6aef3e5d12f35ca4b /dev-tex
parentdev-tex/ninecolors: new package, add 2022.02.13 (diff)
downloadguru-613fa26ecf233e5da2b29bdb352951dcfb214b5d.tar.gz
guru-613fa26ecf233e5da2b29bdb352951dcfb214b5d.tar.bz2
guru-613fa26ecf233e5da2b29bdb352951dcfb214b5d.zip
dev-tex/tabularray: new package, add 2023.03.01
Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/tabularray/Manifest1
-rw-r--r--dev-tex/tabularray/metadata.xml31
-rw-r--r--dev-tex/tabularray/tabularray-2023.03.01.ebuild38
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-tex/tabularray/Manifest b/dev-tex/tabularray/Manifest
new file mode 100644
index 000000000..9a3b8e824
--- /dev/null
+++ b/dev-tex/tabularray/Manifest
@@ -0,0 +1 @@
+DIST tabularray-2023.03.01.zip 817801 BLAKE2B c80884f998e2c6c6406f8ae5d047b048864c135bdec65b7b2bd65f1e6c8a97fcebb13cf72e615c52a5bb77ac51da77d7a3fbd119c135698b40f9cee90883ff10 SHA512 ef0c67ccd6c90f22df61ce2a2e3b54a329dd7124e071985e696033754275e20ff07301bdf1a6e384c009d6462c2eb0bdc5034973697778b3b25e1e89f10e8c20
diff --git a/dev-tex/tabularray/metadata.xml b/dev-tex/tabularray/metadata.xml
new file mode 100644
index 000000000..bbddf05cd
--- /dev/null
+++ b/dev-tex/tabularray/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vowstar@gmail.com</email>
+ <name>Huang Rui</name>
+ </maintainer>
+ <longdescription lang="en">
+ LATEX tables are implemented using TEX commands such as \halign,
+ \noalign, \span, and \omit. In order to implement new features, many
+ macro packages have modified the inner table commands inside LATEX.
+ This makes package code complicated, difficult to maintain, and often
+ conflicts with each other.
+ At present, the LATEX3 programming layer is basically mature.
+ This tabularray package will discard the old \halign commands and
+ directly use LATEX3 functions to parse the table, and then typeset the
+ entire table. Under the premise of being compatible with the basic
+ syntax of LATEX2 tables, this macro package will completely separate
+ the content and style of the table, and the style of the table can be
+ completely set in key-val way.
+ </longdescription>
+ <longdescription lang="zh">
+ LATEX 表是使用 TEX 命令实现的,例如 \halign、\noalign、\span 和 \omit
+ 为了实现新的功能,很多宏包都修改了LATEX内部的内表命令。这使得包代码变得
+ 复杂、难以维护,并且经常相互冲突。
+ 目前LATEX3编程层已经基本成熟。这个 tabularray 包将抛弃旧的 \halign
+ 命令,直接使用 LATEX3 函数解析表格,然后排版整个表格。
+ 在兼容LATEX2表格基本语法的前提下,这个宏包将表格的内容和样式完全分离,
+ 表格的样式完全可以通过 键-值 的方式设置。
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-tex/tabularray/tabularray-2023.03.01.ebuild b/dev-tex/tabularray/tabularray-2023.03.01.ebuild
new file mode 100644
index 000000000..8f52aea9d
--- /dev/null
+++ b/dev-tex/tabularray/tabularray-2023.03.01.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit latex-package
+
+DESCRIPTION="Typeset tabulars and arrays with LATEX3"
+HOMEPAGE="https://www.ctan.org/pkg/tabularray/"
+SRC_URI="https://mirrors.ctan.org/macros/latex/contrib/tabularray.zip -> ${P}.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-tex/ninecolors
+ dev-texlive/texlive-latexrecommended
+ >=dev-texlive/texlive-latexextra-2012
+ dev-texlive/texlive-plaingeneric
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ app-arch/unzip
+"
+
+TEXMF="/usr/share/texmf-site"
+S=${WORKDIR}/${PN}
+
+src_install() {
+ latex-package_src_doinstall styles
+ dodoc README.txt
+ if use doc ; then
+ latex-package_src_doinstall pdf
+ fi
+}