aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-03 05:40:21 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-03 05:40:21 +0200
commitce00e3c1ce5950c95a73d720badcaa0b27b92fff (patch)
tree0eed27b8db00e70bb5e4010e3366162b0f4d04c1 /dev-python/vharfbuzz
parentdev-python/uharfbuzz: initial import (diff)
downloadguru-ce00e3c1ce5950c95a73d720badcaa0b27b92fff.tar.gz
guru-ce00e3c1ce5950c95a73d720badcaa0b27b92fff.tar.bz2
guru-ce00e3c1ce5950c95a73d720badcaa0b27b92fff.zip
dev-python/vharfbuzz: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/vharfbuzz')
-rw-r--r--dev-python/vharfbuzz/Manifest1
-rw-r--r--dev-python/vharfbuzz/metadata.xml13
-rw-r--r--dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/vharfbuzz/Manifest b/dev-python/vharfbuzz/Manifest
new file mode 100644
index 000000000..1a4f41a5b
--- /dev/null
+++ b/dev-python/vharfbuzz/Manifest
@@ -0,0 +1 @@
+DIST vharfbuzz-0.1.1.tar.gz 9036 BLAKE2B c22b1ef28612221b61a7f1565cb5ec37d0a8de852ad9899c1738eed58fc948c775248da460306a213cd39cfed3e180ba8440bfcda15428e2c071888be90657f7 SHA512 20579c380d15168c6635c7aa1a5d28a6c323e6bc25954a9ad2a03d172b414f2a4349f6d51ed2e8c737f8ae5331bc32c1cf1e02cc80544bbc5a265be4731feb01
diff --git a/dev-python/vharfbuzz/metadata.xml b/dev-python/vharfbuzz/metadata.xml
new file mode 100644
index 000000000..48c1f9a7b
--- /dev/null
+++ b/dev-python/vharfbuzz/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/simoncozens/vharfbuzz/issues</bugs-to>
+ <remote-id type="github">simoncozens/vharfbuzz</remote-id>
+ <remote-id type="pypi">vharfbuzz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild b/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild
new file mode 100644
index 000000000..0885f643d
--- /dev/null
+++ b/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A user-friendlier way to use Harfbuzz in Python"
+HOMEPAGE="https://github.com/simoncozens/vharfbuzz"
+SRC_URI="https://github.com/simoncozens/vharfbuzz/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS=""
+SLOT="0"
+
+RDEPEND="
+ dev-python/fonttools[${PYTHON_USEDEP}]
+ dev-python/uharfbuzz[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs dev-python/sphinxcontrib-napoleon