aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Santullo <m.santullo@posteo.net>2020-05-05 12:47:16 +0200
committerMichele Santullo <m.santullo@posteo.net>2020-05-05 12:47:16 +0200
commitfb1fd29f00d2c0cf79d3d74f25e747577c9d064a (patch)
tree2df334b45d2d7d98fada41c42aa8daeb3ab62bef /dev-cpp
parentdev-cpp/vectorwrapper: adding package (diff)
downloadguru-fb1fd29f00d2c0cf79d3d74f25e747577c9d064a.tar.gz
guru-fb1fd29f00d2c0cf79d3d74f25e747577c9d064a.tar.bz2
guru-fb1fd29f00d2c0cf79d3d74f25e747577c9d064a.zip
dev-cpp/sprout: adding package
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michele Santullo <m.santullo@posteo.net>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sprout/files/optional_binaries.patch12
-rw-r--r--dev-cpp/sprout/metadata.xml18
-rw-r--r--dev-cpp/sprout/sprout-9999.ebuild32
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-cpp/sprout/files/optional_binaries.patch b/dev-cpp/sprout/files/optional_binaries.patch
new file mode 100644
index 000000000..df6641f0f
--- /dev/null
+++ b/dev-cpp/sprout/files/optional_binaries.patch
@@ -0,0 +1,12 @@
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index a68233bf..ef38b570 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -1 +1,6 @@
+-subdirs( compost darkroom )
++if (WITH_WAVCONV)
++ subdirs( compost )
++endif()
++if (WITH_TEXCONV)
++ subdirs( darkroom )
++endif()
diff --git a/dev-cpp/sprout/metadata.xml b/dev-cpp/sprout/metadata.xml
new file mode 100644
index 000000000..01cb49eae
--- /dev/null
+++ b/dev-cpp/sprout/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+C++11/14 constexpr based Containers, Algorithms, Random numbers, Parsing, Ray tracing, Synthesizer, and others.
+ </longdescription>
+ <maintainer type="person">
+ <email>m.santullo@posteo.net</email>
+ <name>Michele Santullo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bolero-MURAKAMI/Sprout</remote-id>
+ </upstream>
+ <use>
+ <flag name="texconv">Install texconv from subproject compost</flag>
+ <flag name="wavconv">Install texconv from subproject darkroom</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-cpp/sprout/sprout-9999.ebuild b/dev-cpp/sprout/sprout-9999.ebuild
new file mode 100644
index 000000000..068f836ca
--- /dev/null
+++ b/dev-cpp/sprout/sprout-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="C++11/14 constexpr based Containers, Algorithms, Random numbers and others"
+HOMEPAGE="http://bolero-murakami.github.io/Sprout/"
+EGIT_REPO_URI="https://github.com/bolero-MURAKAMI/Sprout.git"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test texconv wavconv"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/optional_binaries.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test ON OFF)
+ -DWITH_TEXCONV=$(usex texconv ON OFF)
+ -DWITH_WAVCONV=$(usex wavconv ON OFF)
+ )
+ cmake_src_configure
+}