aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2025-01-23 15:42:12 +0100
committerDavid Roman <davidroman96@gmail.com>2025-01-23 15:42:19 +0100
commitd9457b14812e8b6789a6557a961cd998bf7c77ca (patch)
tree1a169d74a1aa366fec66f8a7d2b054609416080e /dev-cpp
parentnet-wireless/btscreenlocker: drop 1.6.3, 1.6.5, 1.7.0-r1 (diff)
downloadguru-d9457b14812e8b6789a6557a961cd998bf7c77ca.tar.gz
guru-d9457b14812e8b6789a6557a961cd998bf7c77ca.tar.bz2
guru-d9457b14812e8b6789a6557a961cd998bf7c77ca.zip
dev-cpp/wt: drop 4.11.0
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/wt/Manifest1
-rw-r--r--dev-cpp/wt/wt-4.11.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-cpp/wt/Manifest b/dev-cpp/wt/Manifest
index 23c0730d6..40b5e5674 100644
--- a/dev-cpp/wt/Manifest
+++ b/dev-cpp/wt/Manifest
@@ -1,2 +1 @@
-DIST wt-4.11.0.tar.gz 10563042 BLAKE2B c49427437298cccc930017d3f03badc33cfcacd370e88b0d18e96a0d4302843fac161d02f3af012cda26a24bac2585329d620324f00cdebad1e78cf59217608d SHA512 67557e39f97871855250d38434b1260d507d9bc27fe0d64e5bf3176eedc3b02269bb3167a9e31d61a30817a852e98fd594672bc5e0debd807523cc5f8db4d17f
DIST wt-4.11.1.tar.gz 10573506 BLAKE2B 832088ba70af307d2abc374c384f5c41920f07439b43e6a53705c34d634e4b412fb075342883f6bf6dda7418ff4277bacd264133afc61567b29ba9bcdfb92257 SHA512 b3afab7327abc7a61ec8963af79bd9b3a23127031416fda4115db74287c130a09d5dd99465c0643e28ef9f2feaabe6ea51a8a22f698ae487243c2ae0e635a412
diff --git a/dev-cpp/wt/wt-4.11.0.ebuild b/dev-cpp/wt/wt-4.11.0.ebuild
deleted file mode 100644
index 9db9580fc..000000000
--- a/dev-cpp/wt/wt-4.11.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Wt, C++ Web Toolkit"
-HOMEPAGE="https://www.webtoolkit.eu/wt https://github.com/emweb/wt"
-SRC_URI="https://github.com/emweb/wt/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="doc firebird mysql opengl +pango pdf postgres ssl"
-
-DEPEND="
- firebird? ( dev-db/firebird )
- mysql? ( virtual/mysql )
- opengl? ( virtual/opengl )
- pango? ( x11-libs/pango )
- postgres? ( dev-db/postgresql )
- ssl? ( dev-libs/openssl )
- dev-libs/boost:=
- media-libs/libharu
- media-gfx/graphicsmagick[jpeg,png]
- sys-libs/zlib
-"
-RDEPEND="${DEPEND}"
-
-BDEPEND="
- doc? (
- app-text/doxygen[dot]
- dev-qt/qtchooser
- dev-qt/qthelp
- )
-"
-# for qt6 dev-qt/qttools[qdoc]
-
-PATCHES=( "${FILESDIR}/wt-no-rundir.patch")
-
-src_configure() {
- # TODO
- #-DENABLE_QT6=$(usex qt6)
-
- local mycmakeargs=(
- -DLIB_INSTALL_DIR=$(get_libdir)
- -DBUILD_EXAMPLES=OFF
- -DINSTALL_DOCUMENTATION=$(usex doc)
- -DDOCUMENTATION_DESTINATION="share/doc/${PF}"
- -DENABLE_SSL=$(usex ssl)
- -DENABLE_HARU=$(usex pdf)
- -DENABLE_PANGO=$(usex pango)
- -DENABLE_SQLITE=ON
- -DENABLE_POSTGRES=$(usex postgres)
- -DENABLE_FIREBIRD=$(usex firebird)
- -DENABLE_MYSQL=$(usex mysql)
- -DENABLE_QT4=OFF
- -DENABLE_QT5=ON
- -DENABLE_SAML=ON
- -DENABLE_OPENGL=$(usex opengl)
- )
-
- cmake_src_configure
-}