aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-11 18:12:17 +0100
committerGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2023-07-11 18:14:19 +0100
commit17a58ed04debb889dad644dbe903dc985c71421b (patch)
treeeb860040067605a033f7354c63af2137203b51fd /app-text
parentapp-misc/glow: add 1.5.1 (diff)
downloadguru-17a58ed04debb889dad644dbe903dc985c71421b.tar.gz
guru-17a58ed04debb889dad644dbe903dc985c71421b.tar.bz2
guru-17a58ed04debb889dad644dbe903dc985c71421b.zip
app-text/sioyek: fix ebuild
Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sioyek/sioyek-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-text/sioyek/sioyek-9999.ebuild b/app-text/sioyek/sioyek-9999.ebuild
index 8d1c0d105..1c53974a1 100644
--- a/app-text/sioyek/sioyek-9999.ebuild
+++ b/app-text/sioyek/sioyek-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit git-r3 qmake-utils desktop
+inherit git-r3 qmake-utils desktop xdg
EGIT_REPO_URI="https://github.com/ahrm/sioyek.git"
DESCRIPTION="Sioyek is a PDF viewer with a focus on textbooks and research papers"
HOMEPAGE="https://github.com/ahrm/sioyek"
@@ -11,8 +11,8 @@ HOMEPAGE="https://github.com/ahrm/sioyek"
LICENSE="GPL-3"
SLOT="0"
-BDEPEND="media-libs/harfbuzz
- dev-qt/qtbase
+BDEPEND="media-libs/harfbuzz
+ dev-qt/qtbase
dev-qt/qt3d
"
@@ -22,8 +22,8 @@ src_compile() {
emake USE_SYSTEM_HARFBUZZ=yes
popd || die
- eapply_user
eqmake5 "CONFIG+=linux_app_image" pdf_viewer_build_config.pro
+ emake
}
src_install() {
#intall bin and shaders
@@ -37,5 +37,8 @@ src_install() {
doicon resources/sioyek-icon-linux.png
insinto /usr/share/sioyek && doins tutorial.pdf pdf_viewer/keys.config pdf_viewer/prefs.config
doman resources/sioyek.1
+}
-} \ No newline at end of file
+pkg_postinst() {
+ xdg_desktop_database_update
+}