aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-17 12:15:56 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-05-17 12:16:27 +0200
commitcfcb54da01a2ebdbc1cd8780f575a586544c711c (patch)
tree0457d4f0594e0b3c0a13e0421364437c3b49c91b /app-misc
parentImport go eclasses from go-overlay (diff)
downloadguru-cfcb54da01a2ebdbc1cd8780f575a586544c711c.tar.gz
guru-cfcb54da01a2ebdbc1cd8780f575a586544c711c.tar.bz2
guru-cfcb54da01a2ebdbc1cd8780f575a586544c711c.zip
app-misc/wego: new package
from https://github.com/Dr-Terrible/go-overlay/tree/e38b18e43d864397a170da46ddc1371877aab272 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/wego/Manifest4
-rw-r--r--app-misc/wego/metadata.xml28
-rw-r--r--app-misc/wego/wego-2.0.ebuild23
3 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/wego/Manifest b/app-misc/wego/Manifest
new file mode 100644
index 000000000..41ff991c4
--- /dev/null
+++ b/app-misc/wego/Manifest
@@ -0,0 +1,4 @@
+DIST github.com-mattn-go-colorable-9fdad7c.tar.gz 5586 BLAKE2B 4f41090d5b803e62b3cf5ab2bab05bf726006c2ccf5fe3e1c5c9a5042375ec652d6bddd09465b1748f969b5c78615e030e72a43d299a953d4fecaf2e8eb993cc SHA512 f3f1893c535cd050bdf83e8d13d5fa5f12b58272a1a373dc17c68a0021a0bd9e72817b5784dd1276cd963bbef07424d47c877d809df787058d8c87194f70b582
+DIST github.com-mattn-go-runewidth-d037b52.tar.gz 5895 BLAKE2B 32e5b025abe0ac98eea8e35278b76f2f447f80f5110fd5f66628510fa0488095f94beab0a010c4f511df04c8a8f503315910acc22f0ba9438a324da3faeeea08 SHA512 0795a78dbf805bcf3fb9887a0bb5875c6b8579302d9207a536d5d00dc8a97a732ae95d274d3b26215d9f900299b01a5b0869561e215def6c8d35d9603b9da551
+DIST github.com-schachmat-ingo-fab41e4.tar.gz 3170 BLAKE2B e37843954694c9cf5ae0a7faf953a5483f06d85bc7521ac199a0db9e6ca052f38ffac74b9f4256a2692f3f3055f49274cb0d7e1ac96c3a892da3553963d6e2da SHA512 8aedc3e85666c228f44f563fbc0264a3cd17fc4dc25f243d92995aeeb493533439600d147eeb9e23d00f108e8002a8b9e0fb4be309353ddd08f1efdd9582b849
+DIST wego-2.0.tar.gz 11185 BLAKE2B 1bf8030a0801a80d5bd367be9a53f01c232ece40fb6f66e4dd06a72ed44e2cc1d6da27888b148c24264ed4eec460b4b9d8e4ff6e91d55e134f275b3978048ace SHA512 92073393f420f72367955b08ef64a90eadc5a72f79f9c42ee1886918923e5953da15dd9ffaefc14aa444cfe5db5f903d88ec080f9ca3490da29efe5734a200f8
diff --git a/app-misc/wego/metadata.xml b/app-misc/wego/metadata.xml
new file mode 100644
index 000000000..7f13f1673
--- /dev/null
+++ b/app-misc/wego/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ <description>comaintainers welcome</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">schachmat/wego</remote-id>
+ <bugs-to>https://github.com/schachmat/wego/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+Features
+
+show forecast for 1 to 7 days
+nice ASCII art icons
+displayed info (metric or imperial units):
+temperature range (felt and measured)
+windspeed and direction
+viewing distance
+precipitation amount and probability
+ssl, so the NSA has a harder time learning where you live or plan to go
+multi language support
+config file for default location which can be overridden by commandline
+Automatic config management with ingo
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/wego/wego-2.0.ebuild b/app-misc/wego/wego-2.0.ebuild
new file mode 100644
index 000000000..c7a702174
--- /dev/null
+++ b/app-misc/wego/wego-2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GOLANG_PKG_IMPORTPATH="github.com/schachmat"
+GOLANG_PKG_HAVE_TEST=1
+GOLANG_PKG_USE_CGO=1
+
+GOLANG_PKG_DEPENDENCIES=(
+ "github.com/mattn/go-colorable:9fdad7c"
+ "github.com/mattn/go-runewidth:d037b52"
+ "github.com/schachmat/ingo:fab41e4"
+)
+
+inherit golang-single
+
+DESCRIPTION="Wego is a weather client for the terminal"
+
+LICENSE="BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="!test? ( test )"