aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-30 14:06:02 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-30 14:35:26 +0500
commit9bd2388895a6910f732a2c1149601d5fea0abfb9 (patch)
tree915fb96480d1cad54b2012238d4c7e9af37d2cc8 /app-misc/cheat
parentapp-admin/antidot: add 0.6.3, clean old (diff)
downloadguru-9bd2388895a6910f732a2c1149601d5fea0abfb9.tar.gz
guru-9bd2388895a6910f732a2c1149601d5fea0abfb9.tar.bz2
guru-9bd2388895a6910f732a2c1149601d5fea0abfb9.zip
app-misc/cheat: add 4.3.3
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-misc/cheat')
-rw-r--r--app-misc/cheat/Manifest1
-rw-r--r--app-misc/cheat/cheat-4.3.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/cheat/Manifest b/app-misc/cheat/Manifest
index d42831bad..eceafc3a3 100644
--- a/app-misc/cheat/Manifest
+++ b/app-misc/cheat/Manifest
@@ -1 +1,2 @@
DIST cheat-4.2.3.tar.gz 1615016 BLAKE2B c33ec7bd083580d6a8bee955e85dd8cc7b3a0bafe4dec52928862192aaa67832b4972e05ea97328fd7cbfe35c41fd904832a5473aecfa096e4845e488896bb6f SHA512 c523b3bd815d8db397c9ffa28d66c0ef7fd3c9392bd144ab0710dfd3472a47544cb2b8745b0d700099ea844c15e526f89d71ec6b233bf1d371c48cb86b100467
+DIST cheat-4.3.3.tar.gz 2777293 BLAKE2B da29c5d08bf5b4fbcce5e70f3d9f483801e4fac7c397a2be499e2dc3d09b9ad6889f753628fe2631d410a1a3c7cd64029f01112eebed6bb562c155bc11d6614d SHA512 e88de31d4473be440ab025521acdb1313bf16fa4dc984d694ddc4cd776b0ced8f3ff9094881e598152f4cb246586de096cb136639bb2509ff94b4459b315c7be
diff --git a/app-misc/cheat/cheat-4.3.3.ebuild b/app-misc/cheat/cheat-4.3.3.ebuild
new file mode 100644
index 000000000..d45719a63
--- /dev/null
+++ b/app-misc/cheat/cheat-4.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module optfeature
+
+DESCRIPTION="cheat allows you to create and view interactive cheatsheets on the command-line"
+HOMEPAGE="https://github.com/cheat/cheat"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# licenses present in the final built
+# software. Checked with dev-go/golicense
+LICENSE="MIT Apache-2.0 BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="man zsh-completion"
+
+RDEPEND="zsh-completion? ( !app-shells/zsh-completions )"
+BDEPEND="man? ( app-text/pandoc )"
+
+src_compile() {
+ ego build -o ${PN} ./cmd/${PN}
+
+ if use man; then
+ pandoc -s -t man doc/${PN}.1.md -o doc/${PN}.1 || die "building manpage failed"
+ fi
+}
+
+src_test() {
+ ego test ./cmd/${PN}
+}
+
+src_install() {
+ dobin ${PN}
+
+ use man && doman doc/${PN}.1
+
+ newbashcomp scripts/${PN}.bash ${PN}
+ insinto /usr/share/fish/vendor_completions.d
+ doins scripts/${PN}.fish
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins scripts/${PN}.zsh _cheat
+ fi
+}
+
+pkg_postinst() {
+ optfeature "fzf integration" app-shells/fzf
+}