aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 18:43:47 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 18:43:47 +0500
commit6e8743bc0a75abaa3a626245b184c8bd99612329 (patch)
tree914d0293eecdc6ebf76fb16ac26e56cc7570d935 /app-admin
parentwww-apps/gotosocial: add missing deps for docs (diff)
downloadguru-6e8743bc0a75abaa3a626245b184c8bd99612329.tar.gz
guru-6e8743bc0a75abaa3a626245b184c8bd99612329.tar.bz2
guru-6e8743bc0a75abaa3a626245b184c8bd99612329.zip
app-admin/krapplet: enable py3.11
Closes: https://bugs.gentoo.org/897358 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/krapplet/krapplet-0.3.1-r1.ebuild29
-rw-r--r--app-admin/krapplet/krapplet-0.3.1.ebuild32
2 files changed, 29 insertions, 32 deletions
diff --git a/app-admin/krapplet/krapplet-0.3.1-r1.ebuild b/app-admin/krapplet/krapplet-0.3.1-r1.ebuild
new file mode 100644
index 000000000..583766fee
--- /dev/null
+++ b/app-admin/krapplet/krapplet-0.3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="Krapplet (keyring applet): a Linux graphical password manager"
+HOMEPAGE="
+ https://gitlab.com/hfernh/krapplet
+ https://pypi.org/project/krapplet/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+gnome-keyring pass"
+REQUIRED_USE="|| ( gnome-keyring pass )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ gnome-keyring? ( dev-python/secretstorage[${PYTHON_USEDEP}] )
+ pass? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
+"
diff --git a/app-admin/krapplet/krapplet-0.3.1.ebuild b/app-admin/krapplet/krapplet-0.3.1.ebuild
deleted file mode 100644
index 3d63246e7..000000000
--- a/app-admin/krapplet/krapplet-0.3.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="Krapplet (keyring applet): a Linux graphical password manager"
-HOMEPAGE="https://gitlab.com/hfernh/krapplet https://pypi.org/project/krapplet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="+gnome-keyring pass"
-REQUIRED_USE="|| ( gnome-keyring pass )"
-
-# Upstream does not provide any test suite.
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/glib
- dev-libs/gobject-introspection
- gnome-keyring? ( dev-python/secretstorage )
- pass? ( dev-python/python-gnupg )
- x11-libs/gtk+:3"
-
-BDEPEND="${RDEPEND}"
-DEPEND="${BDEPEND}"