aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-02-25 04:18:10 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-02-25 04:18:10 +0500
commit66a18dd57caaabfc888dfdbe94aac0b6075b1657 (patch)
tree8e4d8d6417678eb3da518fa140bdaae1980fb9c7 /app-admin
parentwww-client/woob: enable py3.11 (diff)
downloadguru-66a18dd57caaabfc888dfdbe94aac0b6075b1657.tar.gz
guru-66a18dd57caaabfc888dfdbe94aac0b6075b1657.tar.bz2
guru-66a18dd57caaabfc888dfdbe94aac0b6075b1657.zip
app-admin/s-tui: enable py3.11
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/s-tui/Manifest3
-rw-r--r--app-admin/s-tui/s-tui-1.1.1.ebuild39
-rw-r--r--app-admin/s-tui/s-tui-1.1.3-r1.ebuild (renamed from app-admin/s-tui/s-tui-1.1.3.ebuild)8
3 files changed, 5 insertions, 45 deletions
diff --git a/app-admin/s-tui/Manifest b/app-admin/s-tui/Manifest
index 6a611056f..e8bad70d1 100644
--- a/app-admin/s-tui/Manifest
+++ b/app-admin/s-tui/Manifest
@@ -1,2 +1 @@
-DIST s-tui-1.1.1.tar.gz 2608558 BLAKE2B df3211e948acae7ad6b93bdd770cd0aae695da39e4746231f0aed7904dc35b480982ada249ab3dbc387b18dbf40029f2d8db23d71d764a141abe814c5c8117e6 SHA512 71de8fbdad7ebcf9e0ef84b35276315b6c23782c1e24cec1cabb5397e768aa2d5c3f0d3945e1693625b06c52dc1c4ceb7290f6262bf6cddca7afecdcff059bae
-DIST s-tui-1.1.3.tar.gz 2608383 BLAKE2B 15e8e47acb11df816b415eca6bb67db4464054570c9435f704e51dfbb5e798cda1e5c9e5baf69dc01917c6cebb1b040f4f594d2199de7dfb0be7425320357b49 SHA512 80a746187d7d4e4581b6a7c68c3939772eed95ae16530ca38692c9fcfdb98068e60fbe401cf741e1896d8a303a240b231c27a7bf5471c24357fe06df6fdfb153
+DIST s-tui-1.1.3.gh.tar.gz 2608383 BLAKE2B 15e8e47acb11df816b415eca6bb67db4464054570c9435f704e51dfbb5e798cda1e5c9e5baf69dc01917c6cebb1b040f4f594d2199de7dfb0be7425320357b49 SHA512 80a746187d7d4e4581b6a7c68c3939772eed95ae16530ca38692c9fcfdb98068e60fbe401cf741e1896d8a303a240b231c27a7bf5471c24357fe06df6fdfb153
diff --git a/app-admin/s-tui/s-tui-1.1.1.ebuild b/app-admin/s-tui/s-tui-1.1.1.ebuild
deleted file mode 100644
index 16dbc2055..000000000
--- a/app-admin/s-tui/s-tui-1.1.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Stress-Terminal UI monitoring tool"
-HOMEPAGE="https://amanusk.github.io/s-tui/"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/amanusk/${PN}.git"
- EGIT_SUBMODULES=()
-else
- # Pypi source doesn't include tests
- SRC_URI="https://github.com/amanusk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/psutil-5.6.0[${PYTHON_USEDEP}]
- >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-pkg_postinst() {
- elog "To get additional features, some optional runtime dependencies"
- elog "may be installed:"
- elog ""
- optfeature "Stress options in program menu" app-benchmarks/stress
-}
diff --git a/app-admin/s-tui/s-tui-1.1.3.ebuild b/app-admin/s-tui/s-tui-1.1.3-r1.ebuild
index 3178b5e09..03e07d2c8 100644
--- a/app-admin/s-tui/s-tui-1.1.3.ebuild
+++ b/app-admin/s-tui/s-tui-1.1.3-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 optfeature
DESCRIPTION="Stress-Terminal UI monitoring tool"
@@ -14,8 +15,7 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/amanusk/${PN}.git"
EGIT_SUBMODULES=()
else
- # Pypi source doesn't include tests
- SRC_URI="https://github.com/amanusk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/amanusk/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
fi