aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Bakhtiari <dev@mtbk.me>2021-07-03 11:34:28 +0200
committerMatthew Bakhtiari <dev@mtbk.me>2021-07-03 11:34:28 +0200
commita7a479316afbeac2bd824086740fd6bd0c360b05 (patch)
tree7b4810c39e27a6326e92820840cf366933088b56
parentdev-python/hstspreload: enable tests (diff)
downloadguru-a7a479316afbeac2bd824086740fd6bd0c360b05.tar.gz
guru-a7a479316afbeac2bd824086740fd6bd0c360b05.tar.bz2
guru-a7a479316afbeac2bd824086740fd6bd0c360b05.zip
dev-python/i3ipc: maintenance
Closes: https://bugs.gentoo.org/800145 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew <dev@mtbk.me>
-rw-r--r--dev-python/i3ipc/i3ipc-2.2.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/i3ipc/i3ipc-2.2.1.ebuild b/dev-python/i3ipc/i3ipc-2.2.1.ebuild
index 0846853e5..9b1a21c26 100644
--- a/dev-python/i3ipc/i3ipc-2.2.1.ebuild
+++ b/dev-python/i3ipc/i3ipc-2.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -17,3 +17,5 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/python-xlib"
DEPEND="${DEPEND}"
+
+distutils_enable_tests pytest